Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuration help with 2610 router and new NM-1E module.

I have a CISCO 2610 with WIC T1 and the 1 Fast Ethernet port that is part of the 2610 router and I have added 32 MB of RAM for a total of 64 MB RAM. I have now added a new NM-1E module. Here is a

show conf: (see problem/question below configuration)

Using 870 out of 29688 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

no logging console

enable password **********

!

!

!

!

!

ip subnet-zero

ip domain-name integraonline.com

ip name-server 206.163.82.4

!

!

!

!

interface FastEthernet0/0

ip address 198.x.x.x x.255.255.240

no ip directed-broadcast

duplex auto

speed auto

!

interface Serial0/0

ip address 198.x.x.x x.255.255.252

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

no fair-queue

!

interface Ethernet1/0

ip address 192.168.100.251 255.255.255.0

no ip directed-broadcast

!

ip classless

ip oute 0.0.0.0 0.0.0.0 Serial0/0

no ip http server

!

access-list 7 permit 192.168.100.0 0.0.0.254

route-map router permit 10

!

!

line con 0

exec-timeout 0 0

transport input none

line aux 0

line vty 0 4

password **********

login

!

end

Problem: FastEthernet 0/0 has been working good for 2 years. The Ethernet 1/0 (which I just added) can NOT see any WAN ip addresses. I can ping any of my assigned ip addresses 198.107.30.17 thru 198.107.30.30 and I can see Serial 0/0 at 198.107.20.234 but I can NOT see my providers gateway 198.107.20.233 from my LAN 192.168.100.XXX or anyother WAN ip addresses. I am pinging from a computer with an ip address of 192.168.100.248 Any help with my configuration to get it working or to speed things up would be greatly appreciated! Thank you for your time!!

If I were to update the IOS what version should I update too?

1 REPLY
VIP Purple

Re: Configuration help with 2610 router and new NM-1E module.

Hello,

I can ping your addresses 198.107.30.17 and 198.107.20.234 from the Internet, but I cannot ping 192.168.100.248. That is because the 192.168 range is private space, which means those addresses can never ping or reach any public IP addresses like those assigned from your provider, from the 198.107 range. You need to apply Network Address Translation to your configuration, here is what your configuration should look like (the additions have start with a -->):

---

Using 870 out of 29688 bytes

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

no logging console

enable password **********

!

!

!

!

!

ip subnet-zero

ip domain-name integraonline.com

ip name-server 206.163.82.4

!

!

!

!

interface FastEthernet0/0

ip address 198.107.30.17 255.255.255.240

no ip directed-broadcast

duplex auto

speed auto

!

interface Serial0/0

ip address 198.107.20.234 255.255.255.252

-->ip nat outside

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

no fair-queue

!

interface Ethernet1/0

-->ip nat inside

ip address 192.168.100.251 255.255.255.0

no ip directed-broadcast

!

ip classless

--> ip nat inside source list 7 interface serial 0 overload

ip route 0.0.0.0 0.0.0.0 Serial0/0

no ip http server

!

-->access-list 7 permit 192.168.100.0 0.0.0.255

!

line con 0

exec-timeout 0 0

transport input none

line aux 0

line vty 0 4

password **********

login

!

end

---

I took the line:

route-map router permit 10

out since it does not seem to be used for anything.

Check out this link, it has some tools that allow you to test if your public IP addresses are reachable:

http://www.all-nettools.com/tools1.htm

Let me know if you still need help.

Regards,

Georg

180
Views
0
Helpful
1
Replies
CreatePlease login to create content