Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Configuration NAT over backup interface (ISDN BRI)

How I can configure NAT over backup interface ISDN BRI?

  • Other Network Infrastructure Subjects
4 REPLIES
Cisco Employee

Re: Configuration NAT over backup interface (ISDN BRI)

Here is the url for sample config for isdn BRI backup using "backup interface"

http://www.cisco.com/warp/public/793/access_dial/backup_11047.html

Once you have that, you can use following link as a sample config to configure NAT over bri line

http://www.cisco.com/warp/public/471/ddreasyip.html

New Member

Re: Configuration NAT over backup interface (ISDN BRI)

Thank you for you interest, but it doesn't solve my problem. I have two interfaces, the first one is primary (int. serial), the second one is backup (ISDN BRI), here is the configuration:

!

interface FastEthernet0

ip address 192.xxx.xxx.xxx 255.255.255.0 (private)

ip nat inside

!

interface Serial0

backup delay 10 10

backup interface BRI0

ip address xxx.xxx.xxx.xxx 255.255.255.252 (public)

ip nat outside

!

interface BRI0

ip address xxx.xxx.xxx.xxx 255.255.255.0 (public)

ip nat outside

encapsulation ppp

dialer string 971100811

dialer load-threshold 1 either

dialer-group 1

service-policy output term

isdn switch-type basic-net3

no cdp enable

ppp authentication chap pap callin

ppp chap hostname IBM

ppp chap password 7 xxxxxxxxxxxxxxx

ppp pap sent-username IBM password 7 xxxxxxxxxxxxxxx

ppp multilink

!

ip nat inside source nonat interface Serial0 overload

ip nat inside source list 1 interface Serial0 overload

!

ip route 0.0.0.0 0.0.0.0 Serial0

ip route 0.0.0.0 0.0.0.0 BRI0

!

access-list 1 permit 192.168.0.0 0.0.0.255

!

When the primary interface goes down, the backup goes up. That's good, but the privite network (PC) can't go to the Internet! NAT doesn't function. You can't set up second ip nat command. How I can solve this problem?

Thank you for your answer !!!

Jakub Chytracek

Cisco Employee

Re: Configuration NAT over backup interface (ISDN BRI)

First of all you need to add following command as i don't see it in the config.

ip nat inside source list 1 interface bri0 overload

Once you have that NAT over bri should work fine. Once the serial interface is down, the default route to serial interface will be flushed from the routing table and willbe replaced by default route to bri0 interface.

New Member

Re: Configuration NAT over backup interface (ISDN BRI)

Of course I tried it before, but it also doesn't work, because if you set second NAT command, you overwrite the first one.

123
Views
0
Helpful
4
Replies
This widget could not be displayed.