Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configure a Gateway on 2600 Cisco Router

Hi All,

I had the instructions from Cisco web site and I tried to add a line to my 2600 Cisco Router as shown below.

S* 192.168.30.1 [1/0] via 192.168.10.1

When I finished input the commands below, my routing table DID NOT CHANGE. Any help would be appreciated.

These were input commands which I typed at console.

TCO_SR>enable

password:*******

TCO_SR#>config terminal

TCO_SR(config)#ip route 192.168.30.0 255.255.255.0 192.168.10.1

TCO_SR(config)#ip default-network 192.168.30.0

TCO_SR(config)#^z

I turned Off/On the router and did a "sh ip route" but there was no chages.

Original Configuration

TCO_SR>sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1- OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS - IS, L1 - IS - IS level - 1, L2 - IS - IS level - 2, * - candidate default

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C 192.168.30.0/24 is directly connected, Ethernet0/0

I 192.168.10.0/24 [100/8576] via 192.168.20.1, 00:01:20, Serial0/0

192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.20.0/24 is directly connected, Serial0/0

C 192.168.20.1/32 is directly connected, Serial0/0

S * 0.0.0.0/0 [1/0] is directly connected, Serial0/0

TCO_SR>

I would like my router to show below, the last line is the change that I want to add:

TCO_SR>sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1- OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS - IS, L1 - IS - IS level - 1, L2 - IS - IS level - 2, * - candidate default

Gateway of last resort is 192.168.30.1 to network 192.168.10.1

C 192.168.30.0/24 is directly connected, Ethernet0/0

I 192.168.10.0/24 [100/8576] via 192.168.20.1, 00:01:20, Serial0/0

192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.20.0/24 is directly connected, Serial0/0

C 192.168.20.1/32 is directly connected, Serial0/0

S * 0.0.0.0/0 [1/0] is directly connected, Serial0/0

S * 192.168.30.1 [1/0] via 192.168.10.1

TCO_SR>

Thank You In Advance,

Hao

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: Configure a Gateway on 2600 Cisco Router

Hao,

If your WINS Server is across the LAN, you may need to enable UDP Port Forwarding or put an IP Helper-Address on the router in S.F. The address on the IP Helper address will be your WINS in San Rafael. You need to make sure that ports 137-139(which are normally broadcast) can make it accross the WAN. This appears to be the issue... The above mentioned solutions can fix this MS inadaquacy. Happy routing!

J-

also... in response to the collision question on the 2600.. get a switch, that will fix it!

7 REPLIES
New Member

Re: Configure a Gateway on 2600 Cisco Router

Hao,

The problem is that the 192.168.30.0/24 network is directly connected and therefore has a lower ADMINISTRATIVE Distance (0). The static route that you are trying to use has an ADMIN distance of 1 (one), so it will not show up in the routing table unless the other route goes away.(Not likely since it is directly connected)**C 192.168.30.0/24 is directly connected, Ethernet0/0 **. Question: Why are you trying to send the 192.168.30.0/24 route through another path? Hope the above info helps... J-

New Member

Re: Configure a Gateway on 2600 Cisco Router

Hi Jamie,

I am having a problem connecting to the Host (MS SBS 2003 server) from a W2K workstation in San Francisco. From my W2K workstation in S.F, I can ping to the Cisco Router in San Rafael and MS Server using IP address but I can not logon to the MS Server or map to any shares on the server. Please see the details exchange with other expert below but no luck so far. Any suggestions is deeply appreciated.

I had 2 2600 Cisco routers that were previously configured with T1 line for Novell server using IPX. 1 router located in San Francisco and the other in San Rafael site.

I recently installed Microsoft Small Business Server 2003 using IP in San Rafael same location as Novell server.

I can logon sucessfully on both Microsoft and Novell server when my workstation is in San Rafael site.

When my workstation is moved to San Francisco I can't no longer logon to Microsoft server but I still can logon Novell server.

How do I configure the 2600 Cisco router so it will allow my workstation to logon from San Francisco site?

Below is the configuration from both routers:

San Francisco site 2600 Cisco Router configuration

TCO_2600# show config

Using 552 out of 29688 bytes

!

Version 11.3

no service password encryption

!

hostname TCO_2600

!

ipx routing 0050.735c.a3c0

!

!

!

!

interface Ethernet0/0

ip address 192.168.10.2 255.255.255.0

ipx encapsulation SAP

ipx network 1045

!

interface Serial0/0

ip address 192.168.20.1 255.255.255.0

encapsulation ppp

ipx network 100

!

router igrp 100

network 192.168.10.0

network 192.168.20.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.10.1

!

!

!

!

line con 0

line aux 0

line vty 0 1

!

no scheduler allocate

end

San Rafael site 2600 Cisco Router configuration

TCO_SR# show config

Using 580 out of 29688 bytes

!

Version 11.3

!

no service password encryption

!

hostname TCO_SR

!

ipx routing 0050.735c.aea0

!

!

!

!

interface Ethernet0/0

ip address 192.168.30.1 255.255.255.0

ipx network 300 encapsulation SAP

!

interface Serial0/0

ip address 192.168.20.2 255.255.255.0

encapsulation ppp

ipx network 100

service - module t1 clock source internal

!

router igrp 100

network 192.168.20.0

network 192.168.30.0

!

ip classes

ip route 0.0.0.0 0.0.0.0 Serial0/0

!

!

!

!

line con 0

line aux 0

line vty 0

login

line vty 1 4

!

no scheduler allocate

end

amit.shrivastava - network engineer,

Dec 24, 2003, 11:23pm PST

Hi Hao Can

pls paste the "sh ip route" details for both the routers in ur next post and also pls tell me the use of the static route defined in the san francisco router "ip route 0.0.0.0 0.0.0.0 192.168.10.1". I mean what 192.168.10.1 indicates ? ....is it any default gateway to reach internet??

Amit

haocan - Systems Analyst, Comsys

Dec 31, 2003, 10:13am PST

Hi Amit,

192.168.10.1 is default gateway to reach the internet. Let's me provide you a full picture.

In San Franscisco site, there are 2 routers, one is 1700 Cisco router which is a gateway to the Internet (192.168.10.1) I have no access to this configuration yet, the other is 2600 Cisco router and they are both connected to the same hub.I also found a lot of collisions in 2600 Router in San Franscisco, any idea to stop that.

In San Rafael site have only 1 2600 Cisco router which is connected to 2600 Cisco router in San Franscisco 2600 Cisco router thru T1 line.

Below is the results of both 2600 router:

San Francisco router

TCO_2600>sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS - IS, L1 - IS - IS level - 1, L2 - IS - IS level - 2, * - candidate default

U - per - user static route, o - ODR

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

I 192.168.30.0/24 [100/8576] via 192.168.20.2, 00:00:03, Serial0/0

C 192.168.10.0/24 is directly connected, Ethernet0/0

192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.20.0/24 is directly connected, Serial0/0

192.168.20.2/32 is directly subnetted, Serial0/0

S * 0.0.0.0/0 [1/0] via 192.168.10.1

San Rafael router

TCO_SR>sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1- OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS - IS, L1 - IS - IS level - 1, L2 - IS - IS level - 2, * - candidate default

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C 192.168.30.0/24 is directly connected, Ethernet0/0

I 192.168.10.0/24 [100/8576] via 192.168.20.1, 00:01:20, Serial0/0

192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.20.0/24 is directly connected, Serial0/0

C 192.168.20.1/32 is directly connected, Serial0/0

S * 0.0.0.0/0 [1/0] is directly connected, Serial0/0

TCO_SR>

Thanks,

Hao

New Member

Re: Configure a Gateway on 2600 Cisco Router

Hao,

If your WINS Server is across the LAN, you may need to enable UDP Port Forwarding or put an IP Helper-Address on the router in S.F. The address on the IP Helper address will be your WINS in San Rafael. You need to make sure that ports 137-139(which are normally broadcast) can make it accross the WAN. This appears to be the issue... The above mentioned solutions can fix this MS inadaquacy. Happy routing!

J-

also... in response to the collision question on the 2600.. get a switch, that will fix it!

New Member

Re: Configure a Gateway on 2600 Cisco Router

Thanks Jamie and Russ for your responses.

Jamie, I will try your recommendation and I'll let you know the result. How do I input the command

at console to have the IP helper shown below? The last line:

interface Ethernet0/0

ip address 192.168.10.2 255.255.255.0

ipx encapsulation SAP

ipx network 1045

ip helper-address Win3K_Server_IP_Address

Thanks,

Hao

New Member

Re: Configure a Gateway on 2600 Cisco Router

Hi Jamie,

I went ahead to input the following at S.F router console:

ip helper-address 192.x.x.x (Ip address of the MS server)

when I do the show config command, my routing table DO NOT SHOW ip helper-address 192.x.x.x.line What did I do wrong? Please advice.

Thanks,

Hao

New Member

Re: Configure a Gateway on 2600 Cisco Router

Hi Jamie,

You're a PRO, I've got one problem solved and I definitely take your advice to replace the Switch instead of the Hub to get rid of the Late Collission error message.

After I input command ip helper-address MS_Server_IP adress at the router console,Restarted my workstation, It worked fine now.

However I did a test by turn OFF/ON 2600 Router and tried logon my workstation again it stop working so I had to input the command IP helper again at the router console in order to have my workstation logon sucessfully.

My next question is how do I program the IP helper-address stay permanently on the 2600 Router.

Thanks to the PRO,

Hao

Gold

Re: Configure a Gateway on 2600 Cisco Router

If you are not using IGRP as your routing protocol, use a static to 0.0.0.0 0.0.0.0 as your default route, _not_ the ip default network command. The default network command was designed for IGRP, and has lots of issues with other routing protocols.

Again, I would strongly recommend against using the default network command to set a default route. Use a default route.

:-)

Russ.W

511
Views
0
Helpful
7
Replies
CreatePlease login to create content