Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

configure LANE with Cisco 7206 & IBM 8274 switch

Hi,

We have one Cisco 7206 router connected to 3COM CoreBuilder 7000 ATM switch ( configured as a LECS, LES ), The Cisco 7206 router configured as a LEC and it worked fine.

Now my customer want to change network configuration, remove 3COM CoreBuilder 7000, connect Cisco 7206 router to another one IBM 8274 switch, configure the Cisco 7206 router as a LECS, LES & LEC, but it fail to work.

Can you give me some advise to resolve this problem?

The following is the Cisco 7206 configuration ( configured as LECS, LES, LEC ) :

hostname Router

!

boot-start-marker

boot system flash disk0:c7200-js-mz.123-3.bin

boot-end-marker

!

logging queue-limit 100

no logging console

enable password xxxxx

!

no aaa new-model

ip subnet-zero

ip icmp rate-limit unreachable 2000

!

!

!

ip cef

!

lane database lanedatabase

name elan112 server-atm-address 47.00000000003C0000A0000000.000C8613E438.70

name elan113 server-atm-address 47.00000000003C0000A0000000.000C8613E438.71

name elan114 server-atm-address 47.00000000003C0000A0000000.000C8613E438.72

name elan115 server-atm-address 47.00000000003C0000A0000000.000C8613E438.73

name elan116 server-atm-address 47.00000000003C0000A0000000.000C8613E438.74

name elan117 server-atm-address 47.00000000003C0000A0000000.000C8613E438.75

name elan118 server-atm-address 47.00000000003C0000A0000000.000C8613E438.76

name elan119 server-atm-address 47.00000000003C0000A0000000.000C8613E438.77

name elan121 server-atm-address 47.00000000003C0000A0000000.000C8613E438.79

name elan122 server-atm-address 47.00000000003C0000A0000000.000C8613E438.7A

name elan123 server-atm-address 47.00000000003C0000A0000000.000C8613E438.7B

name elan130 server-atm-address 47.00000000003C0000A0000000.000C8613E438.82

name elan150 server-atm-address 47.00000000003C0000A0000000.000C8613E438.96

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

interface FastEthernet0/0

description 2C

ip address 10.6.254.248 255.255.0.0

ip access-group 115 in

no ip unreachables

ip route-cache flow

duplex full

speed auto

!

interface FastEthernet0/1

ip address x.x.x.254 255.255.255.224

ip access-group 115 in

no ip unreachables

ip route-cache flow

duplex auto

speed auto

!

interface Serial1/0

description 3

ip address 192.168.10.253 255.255.255.0

ip access-group 115 in

no ip unreachables

encapsulation ppp

serial restart-delay 0

no fair-queue

!

interface Serial1/1

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0

!

interface ATM2/0

no ip address

ip access-group 115 in

no ip unreachables

ip route-cache flow

atm pvc 1 0 5 qsaal

atm pvc 2 0 16 ilmi

atm uni-version 3.1

no atm ilmi-keepalive

lane client version 1

lane config database lanedatabase

lane config auto-config-atm-address

!

interface ATM2/0.112 multipoint

ip address 10.60.112.254 255.255.0.0

ip access-group 130 in

lane server-bus ethernet elan112

lane client ethernet elan112

!

interface ATM2/0.113 multipoint

ip address x.x.x.254 255.255.255.0

ip access-group 130 in

lane server-bus ethernet elan113

lane client ethernet elan113

!

interface ATM2/0.114 multipoint

ip address x.x.x.254 255.255.255.0

ip access-group 130 in

lane server-bus ethernet elan114

lane client ethernet elan114

!

interface ATM2/0.115 multipoint

ip address x.x.x.254 255.255.255.0

ip access-group 130 in

lane server-bus ethernet elan115

lane client ethernet elan115

!

interface ATM2/0.116 multipoint

ip address x.x.x.254 255.255.255.0

ip access-group 130 in

lane server-bus ethernet elan116

lane client ethernet elan116

!

interface ATM2/0.117 multipoint

ip address x.x.x.254 255.255.255.0

ip access-group 130 in

lane server-bus ethernet elan117

lane client ethernet elan117

!

interface ATM2/0.118 multipoint

ip address x.x.x.254 255.255.255.0

ip access-group 130 in

lane server-bus ethernet elan118

lane client ethernet elan118

!

interface ATM2/0.119 multipoint

ip address x.x.x.254 255.255.255.0

ip access-group 130 in

lane server-bus ethernet elan119

lane client ethernet elan119

!

interface ATM2/0.121 multipoint

ip address x.x.x.254 255.255.255.0

ip access-group 130 in

lane server-bus ethernet elan121

lane client ethernet elan121

!

interface ATM2/0.122 multipoint

ip address x.x.x.254 255.255.255.0

ip access-group 130 in

lane server-bus ethernet elan122

lane client ethernet elan122

!

interface ATM2/0.123 multipoint

ip address x.x.x.254 255.255.255.0

ip access-group 130 in

lane server-bus ethernet elan123

lane client ethernet elan123

!

interface ATM2/0.130 multipoint

ip address x.x.x.254 255.255.255.0

ip access-group 130 in

lane server-bus ethernet elan130

lane client ethernet elan130

!

interface ATM2/0.150 multipoint

ip address x.x.x.253 255.255.0.0

ip access-group 130 in

lane server-bus ethernet elan150

lane client ethernet elan150

!

ip classless

ip route 0.0.0.0 0.0.0.0 210.60.120.253

ip route 10.1.0.0 255.255.0.0 10.6.254.254

ip route 10.2.0.0 255.255.0.0 10.6.254.254

ip route 10.3.0.0 255.255.0.0 10.6.254.254

ip route 10.4.0.0 255.255.0.0 10.6.254.254

ip route 10.5.0.0 255.255.0.0 10.6.254.254

ip route 10.9.0.0 255.255.0.0 210.60.113.200

ip route 10.15.15.0 255.255.255.0 210.60.113.253

ip route 172.17.0.0 255.255.0.0 10.6.254.254

ip route 172.18.0.0 255.255.0.0 10.6.254.254

ip route 172.19.0.0 255.255.0.0 10.6.254.254

ip route 172.20.0.0 255.255.0.0 10.6.254.254

ip route 172.25.0.0 255.255.0.0 10.6.254.254

ip route 192.168.7.0 255.255.255.0 10.6.254.254

ip route 192.192.93.0 255.255.255.0 192.168.10.254

ip route 210.60.112.0 255.255.255.0 210.60.113.249

no ip http server

!

!

access-list 115 deny tcp any any eq 135

access-list 115 deny udp any any eq 135

access-list 115 deny tcp any any eq 4444

access-list 115 permit ip any any

!

!

!

!

!

dial-peer cor custom

!

!

!

!

gatekeeper

shutdown

!

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

password xxxx

login

!

!

!

end

Router#sh lane config

LE Config Server ATM2/0 config table:

Admin: up State: down

down reasons: NO-config-table;

ATM Address of this LECS: 39.03488001BC90000101A4E190.000C8613E43B.00 (auto)

the above address has NOT yet been registered with ILMI

the above address has NOT yet been registered with ATM signalling

actual user specified form: ...

cumulative total number of unrecognized packets received so far: 0

cumulative total number of config requests received so far: 0

cumulative total number of config failures so far: 0

Router#sh lane server

LE Server ATM2/0.112, Elan name: elan112, Admin: up, State: operational

Master/Backup: Backup, Type: ethernet, Max Frame Size: 1516

locally set elan-id: not set

elan-id obtained from LECS: not set

ATM address: 39.03488001BC90000101A4E190.000C8613E439.70

LECS used: 47.007900000000000000000000.00A03E000001.00 NOT yet connected

LE Server ATM2/0.113, Elan name: elan113, Admin: up, State: operational

Master/Backup: Backup, Type: ethernet, Max Frame Size: 1516

locally set elan-id: not set

elan-id obtained from LECS: not set

ATM address: 39.03488001BC90000101A4E190.000C8613E439.71

LECS used: 47.007900000000000000000000.00A03E000001.00 NOT yet connected

LE Server ATM2/0.114, Elan name: elan114, Admin: up, State: operational

Master/Backup: Backup, Type: ethernet, Max Frame Size: 1516

locally set elan-id: not set

elan-id obtained from LECS: not set

ATM address: 39.03488001BC90000101A4E190.000C8613E439.72

LECS used: 47.007900000000000000000000.00A03E000001.00 NOT yet connected

LE Server ATM2/0.115, Elan name: elan115, Admin: up, State: operational

Master/Backup: Backup, Type: ethernet, Max Frame Size: 1516

locally set elan-id: not set

elan-id obtained from LECS: not set

ATM address: 39.03488001BC90000101A4E190.000C8613E439.73

LECS used: 47.007900000000000000000000.00A03E000001.00 NOT yet connected

LE Server ATM2/0.116, Elan name: elan116, Admin: up, State: operational

Master/Backup: Backup, Type: ethernet, Max Frame Size: 1516

locally set elan-id: not set

elan-id obtained from LECS: not set

ATM address: 39.03488001BC90000101A4E190.000C8613E439.74

LECS used: 47.007900000000000000000000.00A03E000001.00 NOT yet connected

LE Server ATM2/0.117, Elan name: elan117, Admin: up, State: operational

Master/Backup: Backup, Type: ethernet, Max Frame Size: 1516

locally set elan-id: not set

elan-id obtained from LECS: not set

ATM address: 39.03488001BC90000101A4E190.000C8613E439.75

LECS used: 47.007900000000000000000000.00A03E000001.00 NOT yet connected

LE Server ATM2/0.118, Elan name: elan118, Admin: up, State: operational

Master/Backup: Backup, Type: ethernet, Max Frame Size: 1516

locally set elan-id: not set

elan-id obtained from LECS: not set

ATM address: 39.03488001BC90000101A4E190.000C8613E439.76

LECS used: 47.007900000000000000000000.00A03E000001.00 NOT yet connected

LE Server ATM2/0.119, Elan name: elan119, Admin: up, State: operational

Master/Backup: Backup, Type: ethernet, Max Frame Size: 1516

locally set elan-id: not set

elan-id obtained from LECS: not set

ATM address: 39.03488001BC90000101A4E190.000C8613E439.77

LECS used: 47.007900000000000000000000.00A03E000001.00 NOT yet connected

.......

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: configure LANE with Cisco 7206 & IBM 8274 switch

If your local router above is the one that should be LECS/LES/BUS/LEC, then your configuration is wrong. Is the ATM switch configured to point to the router as LECS? Notice in your output that the local LECS address and that notified from the switch are different. Also, your LANE database doesn't look like it's using local addresses. Use the 'sh lane def' command to determine your local addresses on the router to use for the atm-server-addresses.

For example your LECS address should be

39.03488001BC90000101A4E190.000C8613E43B.00

The server addresses for this same router would be for example...for elan119

39.03488001BC90000101A4E190.000C8613E439.77

so your database entry should be

name elan119 server-atm-address 39.03488001BC90000101A4E190.000C8613E439.77

Here are some links that might help you get the lane database correctly configured and your ATM switch set with correct LECS address.

http://www.cisco.com/cgi-bin/Support/browse/psp_view.pl?p=Technologies:ATM:LANE&s=Implementation_and_Configuration#Samples_and_Tips

3 REPLIES
Cisco Employee

Re: configure LANE with Cisco 7206 & IBM 8274 switch

If your local router above is the one that should be LECS/LES/BUS/LEC, then your configuration is wrong. Is the ATM switch configured to point to the router as LECS? Notice in your output that the local LECS address and that notified from the switch are different. Also, your LANE database doesn't look like it's using local addresses. Use the 'sh lane def' command to determine your local addresses on the router to use for the atm-server-addresses.

For example your LECS address should be

39.03488001BC90000101A4E190.000C8613E43B.00

The server addresses for this same router would be for example...for elan119

39.03488001BC90000101A4E190.000C8613E439.77

so your database entry should be

name elan119 server-atm-address 39.03488001BC90000101A4E190.000C8613E439.77

Here are some links that might help you get the lane database correctly configured and your ATM switch set with correct LECS address.

http://www.cisco.com/cgi-bin/Support/browse/psp_view.pl?p=Technologies:ATM:LANE&s=Implementation_and_Configuration#Samples_and_Tips

New Member

Re: configure LANE with Cisco 7206 & IBM 8274 switch

Hi,

What`s the following message mean :

the above address has NOT yet been registered with ILMI

the above address has NOT yet been registered with ATM signalling

Now I understand the LANE ATM address is wrong, but in the IBM 8274 switch, which parameter I must be setup? and is there any relation with Cisco 7206 router configuration?

Best Regards,

New Member

Re: configure LANE with Cisco 7206 & IBM 8274 switch

From you configuration your atm lecs server's atm address is "ATM Address of this LECS: 39.03488001BC90000101A4E190.000C8613E43B.00 (auto)"

Try to disable auto and change it to 47.00000000003C0000A0000000.000C8613E438.00

and make sure the lecs server answer's to the wellknow atm lecs address 47.007900000000000000000000.00A03E000001.00 see if it work.

Good luck,

Mark

216
Views
0
Helpful
3
Replies
CreatePlease login to create content