Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring a router to act as a DHCP server

Hi,

I am configuring a router to act as DHCP server. I have configured the router for a 10.0.0.0 pool, however the router is giving 193.168.1.0 IP pool. Any suggestions? The following is the config.

Thanks. Said

San1(config)#service dhcp

San1(config)#ip dhcp pool 10-net

San1(dhcp-config)#network 10.0.0.0 255.255.255.0

San1(dhcp-config)#ip dhcp excluded-address 10.0.0.1 10.0.0.10

San1(config)#ip dhcp excluded-address 10.0.0.1 10.0.0.10

"sh ip int br"

Ethernet0/0 10.0.0.1 YES NVRAM up up

TokenRing0/0 unassigned YES NVRAM administratively down down

Serial1/0 193.168.1.2 YES NVRAM up up

San1#sh run

Building configuration...

Current configuration : 1315 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname San1

!

boot-start-marker

boot-end-marker

!

enable secret xxxx

!

no aaa new-model

ip subnet-zero

ip cef

!

!

no ip domain lookup

ip dhcp excluded-address 10.0.0.1 10.0.0.10

!

ip dhcp pool 10-net

network 10.0.0.0 255.255.255.0

default-router 10.0.0.1

netbios-name-server 10.0.0.4

domain-name xyz.net

!

ip dhcp pool 193.168.3-net

network 193.x.x.x.x.255.0

default-router 193.168.3.1

dns-server 10.0.0.3

netbios-name-server 10.0.0.4

domain-name xyz.net

!

ip audit po max-events 100

no ftp-server write-enable

!

!

!

!

interface Ethernet0/0

ip address 10.0.0.1 255.255.255.0

half-duplex

!

interface TokenRing0/0

no ip address

shutdown

ring-speed 16

!

interface Serial1/0

ip address 193.x.x.x.255.255.0

no fair-queue

!

interface Serial1/1

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

no ip address

shutdown

!

router rip

version 2

network 10.0.0.0

network 193.x.x.0

!

ip http server

ip classless

!

!

!

line con 0

exec-timeout 0 0

password cisco

logging synchronous

login

line aux 0

password xxx

login

line vty 0 4

password xxx

login

!

!

end

4 REPLIES

Re: Configuring a router to act as a DHCP server

Hi Friend,

You have also configured second pool

ip dhcp pool 193.168.3-net

network 193.168.3.0 255.255.255.0

default-router 193.168.3.1

dns-server 10.0.0.3

netbios-name-server 10.0.0.4

domain-name xyz.net

Any particular reason why have you 192.168.3.x network pool.

Regards,

Ankur

New Member

Re: Configuring a router to act as a DHCP server

Ankur,

I have another router-Vista connected via serial to the DHCP server. 193.168.3.0 network is on the E0 of Vista. The DHCP server is giving 193.168.3.0. addresses to the appropriate network.

The DHCP server is not giving addresses to the local network where the server resides-10.0.0.0 network.

Said

Purple

Re: Configuring a router to act as a DHCP server

Hi Said,

One thing I would suggest is for you to enable the following debugs on your router - 'debug ip dhcp server packet' and 'debug ip dhcp server events' - then attempt to obtain an IP address from a node on the 10.0.0.0 network.

IF you then post this output, we may be in a better position to help you.

Paresh

Re: Configuring a router to act as a DHCP server

Hello Said,

just for clarification, you said that 193.x.x.x is on e0, but the configs are not matching:

interface Ethernet0/0

ip address 10.0.0.1 255.255.255.0

half-duplex

!

interface Serial1/0

ip address 193.x.x.x.255.255.0

no fair-queue

Probably, just a typo right?

But just confirming that the host is connected to E0.

Vlad

349
Views
0
Helpful
4
Replies
CreatePlease login to create content