Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Configuring Catalyst 2950

Hi Collegue,

My CallManager and ip phones are in placed.

I have a Catalyst 2950 ONLY available in my lab.

CallManager and IP phones are attached to my 2950. DHCP server is also configured in my Callmanager.

If I attached my IP phones how can I configure my 2950 to get the IP address in my call manager.

Please be advised.

Thanks

7 REPLIES
Cisco Employee

Re: Configuring Catalyst 2950

Hi,

Are you asking how you can configure the 2950 to receive a DHCP address from the callmanage?

thanks,

Bobby

Re: Configuring Catalyst 2950

Jhun,

THere is no configuration required on the 2950.

I assume that your IP phones and Call Manager are in common IP schema.

Just plug the phones and they should be getting the IP

However if you want the Auxillary VLAN feature .e connecting a phone and PC to the same port you ahve to configure voice vlan

eg (data =vlan 2 and voice =vlan 3)

(config)#switchport access vlan 2

(config)#switchport voice vlan 3

HTH

Narayan

Community Member

Re: Configuring Catalyst 2950

Hi, you may want to check out this document. The 2950 provides some low level QOS features you can use.

http://www.cisco.com/en/US/tech/tk389/tk813/technologies_q_and_a_item09186a00804976d3.shtml

Community Member

Re: Configuring Catalyst 2950

Hi Narayan,

see the config:

interface vlan 20

ip address 192.168.1.2 255.255.255.0

ip helper-address 192.168.1.5

no shut

config#interface fastethernet 0/17

config#switchport access vlan 20

config#spanning tree-portfast

config#

I try this configuration but nothing happen. Do I missed any configuration or the configuration is wrong?

Please be advised.

Thanks

Community Member

Re: Configuring Catalyst 2950

Hi Bobby,

Yes,I already configured the CallManager and I also run the DHCP server on the same machine.

I dont understand why all the IP phones is not getting any IP from the DHCP.

The CallManager and the IP Phones are attached in the same 2950 switch.

I created vlan 20 (Voice) see the configuration below:

interface vlan 20

ip address 192.168.1.2

ip helper-address 192.168.1.5

no shut

interface vlan1

no ip address

shutdown

**** port 1 and 2 are my call manager servers

**** port 17 to port 20 are the IP Phones

see the configuration for the port:

interface fastethernet 0/17

switchport access vlan 20

spanning tree portfast

I dont know if there is something missing or wrong in my configuration.

Can you help me to sort it out the problem.

Thanks.

Re: Configuring Catalyst 2950

Hello,

sorry for the confusion: the 2950 cannot do any layer 3 routing, so your VLAN 20 interface is for management only. Which VLAN are the call manager servers in ? If you have only the 2950, put all devices/switchports in the same VLAN.

Can you post the entire configuration of your 2950 ?

Regards,

GNT

Community Member

Re: Configuring Catalyst 2950

Hi,

You are right I was totally confused, I know that 2950 is a layer 2 switch only and cannot do routing.

I put all the devices in the same vlan without any configuration in the switchport and it works.

Thanks for the advise.

278
Views
3
Helpful
7
Replies
CreatePlease to create content