Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring DHCP

Hello,

I am fairly new to Cisco products. I have been asked to make sure our 2651 routers are able to pass DHCP to our core sever. After seardching I could not detrermine how to configure or to see if they are already configured to pass DHCP.

Any help would be appreciated

Tom

8 REPLIES
Cisco Employee

Re: Configuring DHCP

Check to see if helper address are configured on the interfaces

New Member

Re: Configuring DHCP

No I don't see that on the interface configs.

New Member

Re: Configuring DHCP

These would help making DHCP work

ip forward-protocol udp bootpc

ip forward-protocol udp bootps

New Member

Re: Configuring DHCP

Would I enter this in global config on both core router and the client router?

Bronze

Re: Configuring DHCP

Compiling all the information given,

- configure "ip helper-address " from interface config mode

(The interface connected to the LAN segment where the users are also connected)

- at global config mode:

ip forward-protocol udp bootpc (or port 67)

ip forward-protocol udp bootps (or port 68)

These configs should be entered only on the router where the user are connected.

Hope this helps.

New Member

Re: Configuring DHCP

I entered these confiogs. I t doesn't work. I tried to ping the server from theclien pc. I cannot ping the server. Here is a copy of the sh run.

siringo#sh run

Building configuration...

Current configuration : 1118 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname siringo

!

enable secret 5 $1$a/qI$nRNa.beX/S7M47oLGgNa20

!

voice-card 1

!

ip subnet-zero

ip cef

!

!

ip host cityhall 10.1.190.54

ip name-server 10.1.200.2

!

call rsvp-sync

!

!

!

!

!

!

controller T1 1/0

framing sf

linecode b8zs

!

!

!

interface Multilink1

ip address 10.254.5.2 255.255.0.0

ppp multilink

no ppp multilink fragmentation

multilink-group 1

!

interface FastEthernet0/0

ip address 10.5.254.1 255.255.0.0

ip helper-address 10.1.200.1

duplex auto

speed auto

!

interface Serial0/0

no ip address

encapsulation ppp

no fair-queue

ppp multilink

multilink-group 1

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

no ip address

encapsulation ppp

no fair-queue

ppp multilink

ppp multilink

multilink-group 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 Multilink1 10.254.5.1

ip route 10.1.0.0 255.255.0.0 Multilink1

ip http server

ip pim bidir-enable

!

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

end

siringo#

New Member

Re: Configuring DHCP

After I enter the "ip forward-protocal" in the global config I do not see it when I do a show run. Shoud I ?

Cisco Employee

Re: Configuring DHCP

254
Views
0
Helpful
8
Replies