cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
257
Views
0
Helpful
2
Replies

configuring dsl, atm

carl_townshend
Spotlight
Spotlight

Can someone please tell me how I would configure a typcial dsl broadband connection on my cisco router, Are isp's point to multipoint networks and how would the router gets its ip address from the isp, and would I need any PAT, routes on it ?

2 Replies 2

carl_townshend
Spotlight
Spotlight

anyone ?

Hello Carl,

which router do you have ? Here is a sample config for a Cisco 837:

hostname adslrouter_837

enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxx

no aaa new-model

ip subnet-zero

ip routing

ip ips po max-events 100

no ftp-server write-enable

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

no ip route-cache

hold-queue 100 out

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

no ip route-cache

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer0

description $FW_OUTSIDE$

ip address dhcp

ip mtu 1452

encapsulation ppp

dialer pool 1

dialer-group 1

ip nat outside

ppp authentication chap pap callin

ppp chap hostname USERNAME

ppp chap password 0 PASSWORD

ppp pap sent-username USERNAME password PASSWORD

!

ip classless

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 192.168.1.0

!

ip route 0.0.0.0 0.0.0.0 Dialer0

dialer-list 1 protocol ip permit

no ip http server

no ip http secure-server

!

control-plane

!

scheduler max-task-time 5000

end

I you have another router model that is not compatible with that config, let me know, I'll help you with the specifics...

Regards,

GP