Cisco Support Community
Community Member

configuring isdn ddr for frame-relay with NAT


Customer using 2503 link to us via serial interface (frame-relay) and using isdn port as an backup. Customer do not have public ip, only one public ip at serial interface. They use nat from ethernet(inside) to serial(outside). Problem arise when they try to use isdn as backup, after dial to our RAS they still get real ip to isdn interface but they can not configure NAT to isdn interface. IOS allow to configure NAT to only one interface per an access-list. If access-list 1 is used for NAT to serial, they can not used it for NAT to BRI at same time, but they need it when serial go down for backup purpose. What should we do?

many thanks in advance,



Re: configuring isdn ddr for frame-relay with NAT

Create 2 route-map statements one for serial and another one for BRI. Create an access-list and you can use match statement in route-map to link it with access-list. This will work fine. I think you should have 12.2 IOS to implemet this.

Community Member

Re: configuring isdn ddr for frame-relay with NAT

As the DDR is working fine.

Simply configure conditional NAT using route-maps.

I am assuming that you are using Serial0 for FR.

sample NAT config would look like this:


ip nat inside source route-map primary interface serial0 overload

ip nat inside source route-map backup interface bri0 overload

interface serial0

ip nat outside

interface bri0

ip nat outside

interface ethernet0

ip nat inside

route-map primary permit 10

match interface serial0

route-map backup permit 10

match interface bri0


CreatePlease to create content