Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring ISDN PRI as Backup for Channelized E1 config

Hi all,

We have a cisco 2600 series router with 2-port channelized E1/PRI card.

At central location we have the 2Mbps channelized E1 link mapped to respective remote location having 64Kbps leased link.

Now that the primary link is E1 we want to configure ISDN PRI as backup for all the remote locations on the second E1/PRI port at the central location.

remote location will be having ISDN as backup and will dial the central location in case of a lease line failure.

Any sample config will be appreciated.

Thanks

10 REPLIES
New Member

Re: Configuring ISDN PRI as Backup for Channelized E1 config

At central Location U can configure PRI as follows.

controller E1 1/1

framing NO-CRC4

pri-group timeslots 1-31

!

interface Serial1/1:15

description >>> ISDN PRI - 22100394 <<<

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer idle-timeout 900

dialer-group 1

isdn switch-type primary-net5

fair-queue 64 256 0

ppp authentication chap

!

In all remote Locations u can configure BRI as follows

interface Serial1/0

bandwidth 64

ip address x.x.x.x

backup interface BRI0/0

backup delay 20 30

encapsulation ppp

no ip route-cache

no ip mroute-cache

fair-queue 64 256 0

interface BRI0/0

ip unnumbered fastethernet0

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer idle-timeout 1200

dialer map ip "central router ip" name "hostname of central router" broadcast "pri number"

dialer load-threshold 70 outbound

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

Hope this solves ur problem.

Amit

New Member

Re: Configuring ISDN PRI as Backup for Channelized E1 config

Hi Amit,

Sorry for the interruption, I have scanned through the FORUM to look for the answer to my post on topic IP Routing Config on 2600 Router on Dec.22 under WAN, Routing and Switching and found your responses to different peoples and you solved the problem for them, and I considered you as an expert.

Do you have time to take a look at my IP Routing Config on 2600 Router problem posted on Dec.22? I copied and pasted my post problem below from the FORUM and hope you can help.

Thank You In Advance,

Hao Can

haocan@hotmail.com

WAN, Routing and Switching

IP Routing Config on 2600 Router

haocan - Systems Analyst, Comsys

Dec 18, 2003, 12:30pm PST

I had 2 2600 Cisco routers that were previously configured with T1 line for Novell server using IPX. 1 router located in San Francisco and the other in San Rafael site.

I recently installed Microsoft Small Business Server 2003 using IP in San Rafael same location as Novell server.

I can logon sucessfully on both Microsoft and Novell server when my workstation is in San Rafael site.

When my workstation is moved to San Francisco I can't no longer logon to Microsoft server but I still can logon Novell server.

How do I configure the 2600 Cisco router so it will allow my workstation to logon from San Francisco site?

Below is the configuration from both routers:

San Francisco site 2600 Cisco Router configuration

TCO_2600# show config

Using 552 out of 29688 bytes

!

Version 11.3

no service password encryption

!

hostname TCO_2600

!

ipx routing 0050.735c.a3c0

!

!

!

!

interface Ethernet0/0

ip address 192.168.10.2 255.255.255.0

ipx encapsulation SAP

ipx network 1045

!

interface Serial0/0

ip address 192.168.20.1 255.255.255.0

encapsulation ppp

ipx network 100

!

router igrp 100

network 192.168.10.0

network 192.168.20.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.10.1

!

!

!

!

line con 0

line aux 0

line vty 0 1

!

no scheduler allocate

end

San Rafael site 2600 Cisco Router configuration

TCO_SR# show config

Using 580 out of 29688 bytes

!

Version 11.3

!

no service password encryption

!

hostname TCO_SR

!

ipx routing 0050.735c.aea0

!

!

!

!

interface Ethernet0/0

ip address 192.168.30.1 255.255.255.0

ipx network 300 encapsulation SAP

!

interface Serial0/0

ip address 192.168.20.2 255.255.255.0

encapsulation ppp

ipx network 100

service - module t1 clock source internal

!

router igrp 100

network 192.168.20.0

network 192.168.30.0

!

ip classes

ip route 0.0.0.0 0.0.0.0 Serial0/0

!

!

!

!

line con 0

line aux 0

line vty 0

login

line vty 1 4

!

no scheduler allocate

end

New Member

Re: Configuring ISDN PRI as Backup for Channelized E1 config

Hi Hao Can

pls paste the "sh ip route" details for both the routers in ur next post and also pls tell me the use of the static route defined in the san francisco router "ip route 0.0.0.0 0.0.0.0 192.168.10.1". I mean what 192.168.10.1 indicates ? ....is it any default gateway to reach internet??

Amit

New Member

Re: Configuring ISDN PRI as Backup for Channelized E1 config

Hi Amit,

192.168.10.1 is default gateway to reach the internet. Let's me provide you a full picture.

In San Franscisco site, there are 2 routers, one is 1700 Cisco router which is a gateway to the Internet (192.168.10.1) I have no access to this configuration yet, the other is 2600 Cisco router and they are both connected to the same hub.I also found a lot of collisions in 2600 Router in San Franscisco, any idea to stop that.

In San Rafael site have only 1 2600 Cisco router which is connected to 2600 Cisco router in San Franscisco 2600 Cisco router thru T1 line.

Below is the results of both 2600 router:

San Francisco router

TCO_2600>sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS - IS, L1 - IS - IS level - 1, L2 - IS - IS level - 2, * - candidate default

U - per - user static route, o - ODR

Gateway of last resort is 192.168.10.1 to network 0.0.0.0

I 192.168.30.0/24 [100/8576] via 192.168.20.2, 00:00:03, Serial0/0

C 192.168.10.0/24 is directly connected, Ethernet0/0

192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.20.0/24 is directly connected, Serial0/0

192.168.20.2/32 is directly subnetted, Serial0/0

S * 0.0.0.0/0 [1/0] via 192.168.10.1

TCO_2600>

% AMDP2 - FE - 5 - Latecoll : AMDP2/FE<0/0>, Late collision

% AMDP2 - FE - 5 - Latecoll : AMDP2/FE<0/0>, Late collision

% AMDP2 - FE - 5 - Latecoll : AMDP2/FE<0/0>, Late collision

% AMDP2 - FE - 5 - Latecoll : AMDP2/FE<0/0>, Late collision

% AMDP2 - FE - 5 - Latecoll : AMDP2/FE<0/0>, Late collision

% AMDP2 - FE - 5 - Latecoll : AMDP2/FE<0/0>, Late collision

San Rafael router

TCO_SR>sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1- OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS - IS, L1 - IS - IS level - 1, L2 - IS - IS level - 2, * - candidate default

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C 192.168.30.0/24 is directly connected, Ethernet0/0

I 192.168.10.0/24 [100/8576] via 192.168.20.1, 00:01:20, Serial0/0

192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks

C 192.168.20.0/24 is directly connected, Serial0/0

C 192.168.20.1/32 is directly connected, Serial0/0

S * 0.0.0.0/0 [1/0] is directly connected, Serial0/0

TCO_SR>

Thanks,

Hao Can

New Member

Re: Configuring ISDN PRI as Backup for Channelized E1 config

Hi Gautam,

i suspect if u r from CMS India, u'll be using this setup in E-Seva right?

Amit's Answer is right and u can configure it using interface configuration posted in his reply.

Hello Amit,

what about the IP routing to remote sites at Central site? how can he configure route to remote site? He told that if the leased line fails then remote site will dial the PRI's phone number. i think Telco people will be giving a single number for a PRI. so if a remote site dials into central site the call may land in any channel of the PRI at Central site. so we are not sure of the interface on which remote site will be connecting if the leased line fails. if he is using a dynamic routing protocol, it will update the route to remote location. what if he is using static routes? can he use static routes in this situation? if so, how to configure routing using static routes?

thanks and Regards

manoj

New Member

Re: Configuring ISDN PRI as Backup for Channelized E1 config

Hi Manoj,

static routes can also be used as a floating route.If there is no dynamic routing protocol running then the remote site can use two static routes as foloows...

ip route 0.0.0.0 0.0.0.0 serial0

ip route 0.0.0.0 0.0.0.0 bri0/0 10

when leased line will be up the first route will be used and when down it will take the second route.

Rgds

Amit

New Member

Re: Configuring ISDN PRI as Backup for Channelized E1 config

Hi Amit,

its correct as for as remote site is concrned. u got my question wrong. i wanted to know how central site routing is configured, if i am using static routes?

thanks

Manoj.

New Member

Re: Configuring ISDN PRI as Backup for Channelized E1 config

at central site I can't give

ip route

because i am not sure of the interface on which call from remote site lands. it may land on say sx/0:1 when it makes its first call when its link fails for first time. and may land on (say) S x/0:2, when it makes a second call after link fails for the second time at later times.

so what i have to do, when i am using static routes at central site

thanks

Manoj

New Member

Re: Configuring ISDN PRI as Backup for Channelized E1 config

Hi manoj,

whenever the bri link of remote site will connect to central site irrespective of the channels it gets from the pri ,its ip address will be borrowed from fastethernet0...u can refer the config in my eralier post.

So at central router there will be two similar routes as follows...

ip route "wan ip address of the remote router"

ip route "Fast ethernet ip of the remote router" 10

when leased line will be up it will take the first oute , when down it will take the second one.

Rgs

Amit

New Member

Re: Configuring ISDN PRI as Backup for Channelized E1 config

Hi

602
Views
0
Helpful
10
Replies