Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Configuring MS Callback Between a Router and a Windows PC

I have setup the following 1720 router for Async (Pstn) callback to use with a windows PC dial-in.

Although I followed all the steps mentioned in the Cisco configuration example:

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080094338.shtml

(Asynchronous/Modem Technology - Configuring MS Callback Between a Router and a Windows PC)

I cannot make it work. Router answers and I am connected but no callback attempt is initiated!!!

Any ideas why?

Regards.

!

version 12.2

service timestamps debug datetime msec localtime

service timestamps log datetime localtime

service password-encryption

!

hostname PLA1RAS

!

logging buffered 4096 debugging

enable password 7 XXXXXXXX

!

username test1 callback-dialstring <phone> password 0 test

username test2 <phone> password 0 test

memory-size iomem 15

aaa new-model

!

!

aaa authentication login default enable

aaa authentication login NO_AUTHEN none

aaa authentication login use-local local

aaa authentication ppp default local

aaa session-id common

ip subnet-zero

no ip domain lookup

!

ip audit notify log

ip audit po max-events 100

!

isdn switch-type basic-net3

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

chat-script offhook "" "ATH1" OK

!

!

!

interface FastEthernet0

description connected to EthernetLAN

ip address 192.168.0.1 255.255.255.0

speed auto

no keepalive

no cdp enable

!

interface Serial0

physical-layer async

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer rotary-group 1

dialer-group 1

async mode interactive

no keepalive

!

interface Serial1

physical-layer async

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer rotary-group 1

dialer-group 1

async mode interactive

no keepalive

!

interface Dialer0

description connected to Dial-inPCs(ISDN)

ip unnumbered FastEthernet0

encapsulation ppp

no ip split-horizon

dialer in-band

dialer-group 1

peer default ip address pool IP_POOL

no cdp enable

ppp authentication chap pap callin

ppp multilink

!

ip local pool IP_POOL 192.168.0.3 192.168.0.5

ip classless

no ip http server

!

!

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

line 1 2

flush-at-activation

script modem-off-hook offhook

script callback callback

login authentication use-local

modem InOut

modem autoconfigure discovery

transport input all

autoselect during-login

autoselect ppp

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

!

3 REPLIES
Cisco Employee

Re: Configuring MS Callback Between a Router and a Windows PC

You need to add "ppp callback accept" under the interace dialer0. With that config looks ok. Now if it still dosen't work, we need to see the debug for following as indicated in "troubleshoot" on that doc that you are refering.

debug ppp negotiation

debug ppp authentication

debug aaa authentication

debug aaa authorization

debug chat

debug modem

debug ppp cbcp

debug ppp callback

Pl. post it here for a call.

New Member

Re: Configuring MS Callback Between a Router and a Windows PC

My mistake..., I attached a wrong dialer interface in my question. As you can see frommy interface serial configurations, they belong to rotary-group 1.

interface Dialer1

description connected to Dial-inPCs(modem)

ip unnumbered FastEthernet0

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer-group 1

peer default ip address pool IP_POOL

no cdp enable

ppp max-bad-auth 3

ppp callback accept

ppp authentication chap pap

I tried debuging callback but I see no attemp!! On the other hand If I try my Windows PC connection to a Windows server RAS callback works (so I assume my settings are correct on my client windows PC)

New Member

Re: Configuring MS Callback Between a Router and a Windows PC

This is the final configuration in case someone is intersested. It includes both PSTN and ISDN callback. Enjoy!

!

version 12.2

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname DIAL_IN_RAS

!

logging buffered 4096 debugging

enable secret 5

!

username isdntest callback-dialstring password 7

username pstntest callback-dialstring password 7

memory-size iomem 15

!

aaa new-model

!

!

aaa authentication login default local enable

aaa authentication login use-local local

aaa authentication ppp default local

aaa authorization network default local

aaa session-id common

ip subnet-zero

!

ip audit notify log

ip audit po max-events 100

!

isdn switch-type basic-net3

chat-script offhook "" "ATH1" OK

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

!

!

interface BRI0

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-net3

compress mppc

no cdp enable

ppp callback accept

!

interface FastEthernet0

description connected to EthernetLAN

ip address 192.168.0.1 255.255.255.0

speed auto

no keepalive

no cdp enable

!

interface Serial0

physical-layer async

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer rotary-group 1

dialer-group 1

async mode dedicated

no keepalive

!

interface Serial1

physical-layer async

no ip address

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer rotary-group 1

dialer-group 1

async mode dedicated

no keepalive

!

interface Dialer0

description connected to Dial-inPCs(ISDN)

ip unnumbered FastEthernet0

encapsulation ppp

no ip split-horizon

dialer in-band

dialer caller callback

dialer-group 1

peer default ip address pool IP_POOL

compress mppc

no cdp enable

ppp callback accept

ppp authentication chap pap

ppp multilink

!

interface Dialer1

description connected to Dial-inPCs(modem)

ip unnumbered FastEthernet0

encapsulation ppp

ip tcp header-compression passive

dialer in-band

dialer-group 1

peer default ip address pool IP_POOL

no keepalive

no cdp enable

ppp max-bad-auth 3

ppp callback accept

ppp authentication chap pap

!

ip local pool IP_POOL 192.168.0.10 192.168.0.15

ip classless

ip route 0.0.0.0 0.0.0.0

no ip http server

!

!

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

line 1 2

flush-at-activation

script modem-off-hook offhook

script callback callback

login authentication use-local

modem InOut

modem autoconfigure type usr_sportster

no exec

transport input all

autoselect during-login

autoselect ppp

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

line vty 0 4

!

no scheduler allocate

end

121
Views
0
Helpful
3
Replies
CreatePlease login to create content