cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2448
Views
0
Helpful
10
Replies

Configuring Multicast for Ghost Applications

Scott Fella
Hall of Fame
Hall of Fame

I have a 6509 with (2) L3 modules at the core and 3508's that connect to the 6509 for the access layer. I'm using 3512, 3524, and 3548 for my access layer switches. The network has about 17 VLANS configured. Each 3508 and the 3500 that connect are one vlan. However specific ports are configured for other vlans.... example... voice, wireless, printers...etc.

I want to enable multicast because we are using Ghost throughout the network. The question I have, is on the 6509, do I just enable IGMP Snooping and GMRP? Global commands and no port commands?

On the 3500's, is it also a global command? Configure CGMP and that's it?

Any input on what commands I should implement on the 6509 and in the 3500's or how I should configure the switches would help.

Thanks!

-Scott
*** Please rate helpful posts ***
10 Replies 10

Prashanth Krishnappa
Cisco Employee
Cisco Employee

Enable IGMP snooping on the 6500, CGMP on the XLs. Configure Multicast routing on the MSFCs, enable PIM/CGMP on the VLAN interfaces. Make sure the TTL on the multicast server is set to something more than number of VLANs you have

The following page on CCO should be useful as well

http://www.cisco.com/warp/public/473/22.html

Regards,

-Prashanth

milan.kulik
Level 10
Level 10

I've spent a lot of time fixing Ghost multicast problem and this is my solution:

1) set a mutlicast storm control on the port the Ghost server (multicast source) is connected to the network. I'm using 2000 rising and 1500

falling thresholds. This decreases the absolute number of multicasts flooded to the network.

2) enable IGMP snooping on switches which are IGMP-snooping enable (Cat6500, 2950) and set CGMP enable on switches which are not

(Cat4000). On Cat3500 and 2900 CGMP is enabled by default.

3) configure

ip pim sparse-mode

ip cgmp

on your router LAN port.

Don't use CGMP fast-leave if you're using HSRP in your network (address conflict).

The way this scenario works:

At the moment wokstation joins a multicast group it sends a IGMP join message. IGMP-enable switches detects it and they send multicast

traffic to appropriate ports only then. IGMP-not-enabled switches receive this info through CGMP - a router "translating" from IGMP to CGMP

is necessary.

There are some minor problems remaining (if the workstation joins several multicast groups rapidly it takes some time to detect it and

aproximately 30 sec multicast storm apears, e.g.) but generally this scenario works.

The above description is very rough, for detailed info see:

http://www.cisco.com/warp/public/473/38.html

http://www.cisco.com/warp/public/473/22.html

http://service4.symantec.com/SUPPORT/ghost.nsf/docid/1999033015222425

A good news in the end: There is a new Ghost version available which should be much more flexible and user friendly regarding

unicats/multicasts options.

Hope to help,

Milan

Okay... I understand better.

On the 6509, I will configure IGMP-Snooping that is all

On the 3500's I will configure CGMP that is all

On the port where the Ghost server is connected, I have to use a multicast storm control

Since I have both MSFC on the 6509 load-balancing vlans (odds on one / evens on the other), I should not configure CGMP fast-leave. On the MSFC's, I have to configure (this would be my router LAN port corect?:

ip pim sparse-mode

ip cgmp

This is it......correct?

Just making sure and thanks for the reply's!

-Scott
*** Please rate helpful posts ***

You don't have to use multicast storm control on the port where the Ghost server is connected but I would recommend it as a insurance for the case CGMP or IGMP mechanism fails.

To be correct, this is a solution for running Ghost in one VLAN and preventing multicast storms in it.

If you want to run Ghost application with Ghost server in one VLAN and clients in several VLANs, you should configure multicast routing which is much more complex and I'm not able to give an correct advice without your network detailed knowledge.

Regards,

Milan

This is how the netowrk is set up.

6509 with 2 sup L3 at the core

3508 at each IDF that connects to the 6509 gig module. Each IDF is configured for it's own vlan. (IDF 2-Vlan-2 ....... IDF 16-Vlan 16)

Connected to the 3508 are 3512, 3524, 3524-PWR, and 3548. However, switch ports might be configured for another vlan (voice vlan, wireless vlan, printer vlan). Switches are not daisy chained, each has a seperate fiber going to the 3508.

I do have HSRP configured in the 6509, odd vlans active on one of the MSFC's and even vlans avtive on the other MSFC's.

I do wnat to run Ghost in one vlan and clients will be in all other vlans.

6509 L2

!

#igmp

set igmp enable

!

------snip------

Session 15 Example

ip subnet-zero

!

ip multicast-routing

ip dvmrp route-limit 20000

ip cef

ip dhcp-server 10.2.0.9

ipx routing 0030.b639.2bf8

cns event-service server

!

!

!

!interface Vlan1

ip address 10.2.100.2 255.255.255.0

ip helper-address 10.2.0.9

no ip redirects

no ip directed-broadcast

no ip mroute-cache

standby 1 priority 105 preempt

standby 1 ip 10.2.100.1

ip pim sparse-dense-mode

!

interface Vlan2

ip address 10.2.2.2 255.255.255.0

ip helper-address 10.2.0.9

no ip redirects

no ip directed-broadcast

ipx encapsulation SAP

ipx network 230F0002

standby 2 priority 110 preempt

standby 2 ip 10.2.2.1

ip pim sparse-dense-mode

------snip------

Let me know what other configurations I need to do. I have not configured any of the 3500's yet.

-Scott
*** Please rate helpful posts ***

Should I configure the interfaces with:

ip pim sparse-dense-mode

or

ip pim sparse-mode

-Scott
*** Please rate helpful posts ***

Sparse-dense mode will almost always do the right thing, and is the preferred choice.

/Chris Thomas, UCLA ATS

Thanks! I will give it a shot.

-Scott
*** Please rate helpful posts ***

You said to set a multicast storm control on the port the Ghost server is connected to. The server is connected to to the 6509 port 7/4. So I did a SET PORT BROADCAST 7/4 75%..... does this look okay?

Thanks!

-Scott
*** Please rate helpful posts ***

I would use set port broadcast 7/4 25 multicast enable or something like that - I'm not using Cat6500 in my network but I suppose it might work. But be careful and check if the filter really works. There is a note in Cat6000 documentation saying that it's possible to filter multicasts on Gigabit ports - so I'm not sure if it works on FastEthernet ports (it doesn't on Cat4000, e.g.).

What I'm using is following:

interface FastEthernet0/20

description Ghost

port storm-control broadcast action filter

port storm-control broadcast threshold rising 2500 falling 1500

port storm-control multicast action filter

port storm-control multicast threshold rising 3000 falling 2000

on Cat3524. It enables me to define the exact number of multicast per second allowed to enter the network from the Ghost server port.

Regarding your router config:

you should use ip multicast-routing global configuration command to enable multicast routing from one VLAN to the others.

But I didn't configure it personally so I don't know details what else is necessary. The only I recommend looking to your config is to check if your "no ip mroute-cache" for VLAN1 is correct.

I'm also not sure that the sparse-dense mode is optimal - the sparse mode prevents multicast flooding in strict way.

Regards,

Milan

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco