Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Configuring NAT on Serial Interface

Is this the proper way to configure NAT ona Serial Interface if I have only one routable IP address?

Current configuration : 1021 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Liver

!

enable password 7 011A12277425353A0D7867273E

!

memory-size iomem 20

ip subnet-zero

!

!

no ip domain-lookup

!

ip audit notify log

ip audit po max-events 100

ip ssh time-out 120

ip ssh authentication-retries 3

!

crypto mib ipsec flowmib history tunnel size 200

crypto mib ipsec flowmib history failure size 200

!

!

!

interface Ethernet0

no ip address

shutdown

half-duplex

!

interface FastEthernet0

ip address 10.100.10.1 255.255.255.0

ip nat inside

speed auto

!

interface Serial0

description connected to Internet

ip address 207.144.160.66 255.255.255.252

ip nat outside

!

ip nat inside source list 1 interface Serial0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Serial0

no ip http server

ip pim bidir-enable

!

!

snmp-server community public RO

!

line con 0

exec-timeout 0 0

password 7 1306471F1B5C16233E29

login

line aux 0

line vty 0 4

password 7 110A4908074219051127

login

!

end

1 REPLY
New Member

Re: Configuring NAT on Serial Interface

Yes, but you're missing:

access-list 1 permit 10.0.0.0 0.255.255.255

This will tell NAT to translate everyone on the 10.x.x.x network to your 207.144.160.66 address.

Mick.

133
Views
0
Helpful
1
Replies
CreatePlease to create content