Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

configuring two Vlans on one cat 3548xl and dotq trunking

Hello Guys,

The Network diagram on this url is exactly what i wannt to configure, but with some difference.

http://www.cisco.com/en/US/tech/tk389/tk390/technologies_configuration_example09186a00800949fd.shtml

At the moment wy have only Vlan 1 on the cat 3548xl and no trunking configure on between Router and Switch. all switch interfaces are on the Vlan1 and obtain thier Ip addresse from an DHCP (PC) Server also on the VLAN 1.

a) I wannt to create a new Vlan (Vlan2) for Wireless LAN and configure on the Router another DHCP Server to assign Ip Addresse only for Wireless users.

b) no connection between Both VLANs (not Ping) because Wireless Users are External Users, there will only need to get an Internet access no LAN Connectivity.

how can It configure this issue ? is possibleto configure it like this ?

do you have any better solution ?

Thanks for any help

AFE

2 REPLIES
Bronze

Re: configuring two Vlans on one cat 3548xl and dotq trunking

sounds like you need to create a second vlan in the switch and make the uplink to the router a trunk. Connect the wireless access points to switch ports that you put into the new vlan. It also sounds like you want to run the router as a dhcp server for that vlan, that should work. Then you need access lists to block the wireless network from reaching the other interior network. However, you may need to open holes in the access list to let them reach dns or the dhcp server will have to feed them a dns they can reach on the internet. If you are planning authentication you will need to account for the location of the authentication host.

New Member

Re: configuring two Vlans on one cat 3548xl and dotq trunking

Thanks for your replay Jackson,

you understand my prob. I am just doing the test with a cat 3550 xl and an 2600 router. I configure it like an the link but cannot ping through the Trunk link,

sh cdp on bothe site works fine but L3 not

please check the config an let me know what wrong

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1

ip address 10.60.9.254 255.255.255.0

no ip redirects

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 10.60.19.254 255.255.255.0

no ip redirects

!

interface Ethernet1/0

no ip address

shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip http server

!

-----------------------------------------------------------

BBZ_RouterTest#sh cdp ne

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID

BBZ_SwitchTest Fas 0/0 169 S I WS-C3550-4Fas 0/1

--------------------------------------------------------------------------------------------

interface FastEthernet0/1

description connect trunk to router

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address

!

interface FastEthernet0/2

no ip address

...

interface FastEthernet0/48

description Connect to WLAN

switchport access vlan 2

no ip address

interface Vlan1

ip address 10.60.9.250 255.255.255.0

no ip route-cache

!

ip default-gateway 10.60.9.254

ip http server

----------------------

BBZ_SwitchTest# sh cdp ne

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID

BBZ_RouterTest Fas 0/1 124 R 2620 Fas 0/0.1

BBZ_SwitchTest#

Thanks

AFE

123
Views
0
Helpful
2
Replies