Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Confirming HSRP Operation....

Which method is best? I'd had two people give me these two configs, which is more straight-forward as far as efficiency goes?

________________________________

interface Vlan500

description Connection to Flat Network

ip address 198.186.47.2 255.255.255.0

ip address 198.186.44.2 255.255.255.0 secondary

ip address 198.186.45.2 255.255.255.0 secondary

ip address 198.186.46.2 255.255.255.0 secondary

ip address 198.186.43.2 255.255.255.0 secondary

ip address 198.186.59.2 255.255.255.0 secondary

ip address 198.186.61.2 255.255.255.0 secondary

no ip redirects

mls rp management-interface

standby 1 ip 198.186.47.1

standby 1 ip 198.186.44.1 secondary

standby 1 ip 198.186.45.1 secondary

standby 1 ip 198.186.46.1 secondary

standby 1 ip 198.186.43.1 secondary

standby 1 ip 198.186.59.1 secondary

standby 1 ip 198.186.61.1 secondary

standby 1 priority 106

standby 1 preempt

__________________________________

OR------>

__________________________________

interface Vlan500

description Connection to Flat Network

ip address 198.186.47.2 255.255.255.0

no ip redirects

mls rp management-interface

standby 1 ip 198.186.47.1

standby 1 priority 106

standby 1 preempt

ip address 198.186.44.2 255.255.255.0 secondary

no ip redirects

mls rp management-interface

standby 1 ip 198.186.44.1

standby 1 priority 106

standby 1 preempt

ip address 198.186.45.2 255.255.255.0 secondary

no ip redirects

mls rp management-interface

standby 1 ip 198.186.45.1

standby 1 priority 106

standby 1 preempt

ip address 198.186.46.2 255.255.255.0 secondary

no ip redirects

mls rp management-interface

standby 1 ip 198.186.46.1

standby 1 priority 106

standby 1 preempt

ip address 198.186.43.2 255.255.255.0 secondary

no ip redirects

mls rp management-interface

standby 1 ip 198.186.43.1

standby 1 priority 106

standby 1 preempt

ip address 198.186.59.2 255.255.255.0 secondary

no ip redirects

mls rp management-interface

standby 1 ip 198.186.59.1

standby 1 priority 106

standby 1 preempt

ip address 198.186.61.2 255.255.255.0 secondary

no ip redirects

mls rp management-interface

standby 1 ip 198.186.61.1

standby 1 priority 106

standby 1 preempt

4 REPLIES
Community Member

Re: Confirming HSRP Operation....

The first one. The second is definitely wrong. By typing "standby 1 ip x.y.z.w" over and over, you are constantly replacing the "standby 1" ip address. You'll end up with "standby 1 ip 198.186.61.1" as the only standby ip address when all is said and done.

HTH,

Mike

Community Member

Re: Confirming HSRP Operation....

I am just interested, can you put different secondary addresses in different HRSP groups ?

If you have previous config with secondary addressing, can you put different seccondary addresses in different HRSP groups, something like this:

standby 1 ip 198.186.47.1

standby 1 priority 106

standby 2 ip 198.186.46.1

standby 2 priority 50

standby 3 ip 198.186.45.1

standby 3 priority 106

...

Regards,

Danijela

Silver

Re: Confirming HSRP Operation....

Sure you can. You can even define standby addresses which are not defined on the interface (although you had best know what you're doing or you may not like the results :-). See Chapter 6 "Multiple Routers at a Single Site" in my book High Availability Networking with Cisco for a variety of ways to take advantage of HSRP (and several other techniques to protect against router failure).

Good luck and have fun!

Vincent C Jones

www.networkingunlimited.com

Community Member

Re: Confirming HSRP Operation....

Thanks Vincent. I asked that because obvious drawback of original configuration is that it doesn’t perform load sharing.

Regards,

Danijela

113
Views
0
Helpful
4
Replies
CreatePlease to create content