Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Confused the CORE Switch's

HI!

PS Throw Light to the following SCenario:

I Have 5 distribution switchs(6509-sup20) connected to Core switch 6509-sup20.the routing protocole its EIGRP.I SENT THE Following Network as a summary to the CORE:

DS1)10.11.0.0:

DS2)10.12.0.0:

DS3:10.13.0.0:

DS4:10.14.0.0:

DS5:10.15.0.0:

Now maybe these confused the core switch.what is the OPTIMUM Way to uncofused the core?& let the core always function properly as well as very good performance

i waiting ur reply!

15 REPLIES
Hall of Fame Super Bronze

Re: Confused the CORE Switch's

Why you said the Core switch is confused ?

You aren't seeing the summary route ?

Can we see the 'sh ip route eigrp' from the Core switch ?

What device is performing the summary route ?

Can we see the command you typed and under what interface ?

New Member

Re: Confused the CORE Switch's

Hi EdisonOrtiz

10xs for ur reply!the devices that performe summary the 5 Distribution(6509)

2)INT gigx/x

ip summary EIGRP 10 10.11.0.0 255.255.0.0

10xs

New Member

Re: Confused the CORE Switch's

Hi mates!

can some one reply here!

10xs

Hall of Fame Super Bronze

Re: Confused the CORE Switch's

The summary command should be

ip summary EIGRP 10 10.8.0.0 255.248.0.0

In order to include all these networks

DS1)10.11.0.0:

DS2)10.12.0.0:

DS3)10.13.0.0:

DS4)10.14.0.0:

DS5)10.15.0.0:

Please rate helpful posts.

Thanks

New Member

Re: Confused the CORE Switch's

Hi Freind!

10xs for ur reply!mabe u get me wrong.i meant i sent summary from each dist to the core;let say ds1 responsible for this network:10.11.0.0;the command should be:

ip summary EIGRP 10 10.11.0.0 255.255.0.0

and so on for the remaining Distribution's.

10xs for ur relpy!reply if i'm miss Understood..

10xs freind for ur reply

Hall of Fame Super Bronze

Re: Confused the CORE Switch's

If the distribution switch is advertising the network 10.11.0.0, it will send this network without the 'ip summary EIGRP' on the interface.

I'm afraid, I have a hard time understanding what are you trying to achieve.

Let's make it easier, can you post a diagram or any supporting documentation on your network ? Diagrams can be really helpful here.

New Member

Re: Confused the CORE Switch's

HI EdisonOrtiz!

i have attached the topology

LET Take DS3;DS3(10.11.0.0) Respomsible for these network:

10.11.1.0

10.11.2.0

10.11.3.0

10.11.4.0

10.11.5.0

10.11.6.0

10.11.7.0

10.11.8.0

10.11.9.0

10.11.10.0

10.11.11.0

10.11.12.0

10.11.13.0

10.11.14.0

in the DS3 PORT-CHANNEL:

I SENT THE Sent the summaru addrerss toward the core like this:

ip summary address EIGRP 10 10.11.0.0 255.255.0

like this for all my Distribution;every Distribution responsible for many networks like ds3

10xs for ur patient

Hall of Fame Super Bronze

Re: Confused the CORE Switch's

First, you have to include the command

no auto-summary

under the EIGRP process on each DIST switch.

Then you can summarize as you posted.

If you don't include the no auto-summary within the EIGRP process, it will summarize to a classful boundary which is 10.0.0.0

so in short the commands you need are:

router eigrp 10

network 10.0.0.0

no auto-summary

interface port-channel #

ip summary-address EIGRP 10 10.11.0.0 255.255.0.0

New Member

Re: Confused the CORE Switch's

Hi Freind!

10xs for ur reply.regardes to EIGRP Advertised on each DS.WOULD BE LIKE THIS:

DS1

......

router eigrp 10

network 10.11.0.0

no auto-summary

interface port-channel #

ip summary-address EIGRP 10 10.11.0.0 255.255.0.0

DS2

.....

router eigrp 10

network 10.12.0.0

no auto-summary

interface port-channel #

ip summary-address EIGRP 10 10.12.0.0 255.255.0.0

DS3

......

interface port-channel #

ip summary-address EIGRP 10 10.13.0.0 255.255.0.0

router eigrp 10

network 10.13.0.0

no auto-summary

I Advertised these network like this.am i correct?

now waht would be the config from the core side?

10xs

Hall of Fame Super Bronze

Re: Confused the CORE Switch's

You can use the major network of 10.0.0.0 under the EIGRP process and it will automatically include all 'connected' networks within that range. It will then be summarized as you wish at the interface level.

The Core will receive these summarized networks from the DIST switches and it then can in turn summarized its own 'connected' networks like explain above with the IP SUMMARY-ADDRESS EIGRP on the outbound interface.

New Member

Re: Confused the CORE Switch's

Hi

u mean that i need to use ip summary also on the core?the core already learned this networks.could u ps list the config of the core 4 (EIGRP Section) dependent on my previous topology

10xs for ur reply

Hall of Fame Super Bronze

Re: Confused the CORE Switch's

router eigrp 10

network 10.0.0.0

no auto-summary

New Member

Re: Confused the CORE Switch's

Hi Friend!

u don't thing that this advertisment(network 10.0.0.0 ) affect the core?why we didn;t advertise these network individualy loke this:

core

......

router eigrp 10

network (conneted interface)

network 10.11.0.0 0.0.255.255

network 10.12.0.0 0.0.255.255

network 10.13.0.0 0.0.255.255

network 10.14.0.0 0.0.255.255

no auto-summary

am i correct?PS ADVISE?I NEED THE OPTIMUM BEHAVIOR OF THE CORE(6509 SUP20)

10XS FOR UR PATIENT TO HELP ME

Hall of Fame Super Bronze

Re: Confused the CORE Switch's

Under the EIGRP process, the network statement should only include subnets that you want to advertised FROM the router. Subnets that are learned from other devices need NOT to be listed.

If you issue

'sh ip interface brief'

on the core, you can select what networks you want to advertise FROM the core to all devices sharing the same EIGRP AS.

For instance, if the 'sh ip int bri' includes the following networks:

172.16.1.1

192.168.1.1

10.1.1.1

Then your EIGRP process should be like

router eigrp 10

network 172.16.1.0

network 192.168.1.0

network 10.1.1.0

You can also use another method if you have multiple subnets that are within the major network, for instance:

10.11.0.0

10.12.0.0

10.13.0.0

10.14.0.0

could be represented with a single command

router eigrp 10

network 10.0.0.0

no auto-summary.

It will advertise the subnets listed above and not the 10.0.0.0 network because 'no auto-summary' is also part of the EIGRP process.

now if you have the following connected networks:

10.11.0.0 thru 10.14.0.0 AND 10.50.0.0 thru 10.60.0.0 but only want to advertise the 10.11.0.0 thru 10.14.0.0 network then the EIGRP process would be like

router eigrp 10

network 10.8.0.0 0.0.7.255

no auto-summary

Please rate helpful posts.

Thanks

New Member

Re: Confused the CORE Switch's

Hi Friend!

10xs for explanation.

123
Views
16
Helpful
15
Replies
CreatePlease login to create content