Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Confusion Reigns! Why could token rings segments not access the internet?

This is something that happened to us over the weekend. It might take some time to explain but if anyone knows anything about why this might have happened, please let me know.

On Saturday we lost a 3620 router with a NM1FE1R2W (Fast E, TokenRing, 2 WIC) network module. We took a power hit and lost the code and also could not get the ethernet port to come back up. I wish this was the entire problem.

We had a spare 7204 with fastethernet, four token ring, and an eight serial port module that we used to replace it. It was definitely overkill but it had all the ports we needed.

This 7204 (and the old 3620) connects to one ethernet segment that is just a stub network and one token ring segment that connects to the rest of the resources for our users. You have to go through the token ring port to access email and internet services. The serial port connects to a 3640 at a hospital. At the hospital there are two ethernet ports (one connects to a 6506 with the RSM and has a bunch of ethernet networks on it) and three serial ports. The three serial ports are plugged into line drivers that feed IBM routers that run token ring segments.

So basically, in order for all users (token ring and ethernet) at the hospital to access email and internet services, they connect to the 3640 at the hospital and then go over a T1 line to the main office 7204. The 7204 ships these packets out the token ring interface to the desired destination and you got yourself internet and mail! Simple really ......except...........

When we replaced the dead 3620 with the 7204 none of the users of the Token Ring segments at the Hospital could get email or internet access. Ethernet users were fine. Everyone was actually able to ping the mail and proxy servers but for some reason they timed out when trying to establish connections with Outlook or Explorer.

The ONLY difference in the config of the two routers was that the 3620 has a 10/100 ethernet port and it is set at 10MB half duplex. The 7204 is only a 100MB port and therefore would be set at 100MB half duplex. But this really shouldnt matter because the traffic doesnt have to cross this interface anyway. Does it?

Anyone have ANY ideas about what is going on? It works at 10MB half duplex but not at 100MB on the ethernet port. We have since replaced the 7204 with an RMA's 3620 and the mail and internet services came right back up.

2 REPLIES

Re: Confusion Reigns! Why could token rings segments not access

As I understand IP routing was working properly. A ping was possible.

This points to some kind of mtu problem. It is a pity that we cannot compare configs. So the following remains an educated guess but I would say that the 7204 had a smaller mtu size configured on the TR (probably 1500) than the 3620. This can easily result in the issue you describe.

New Member

Re: Confusion Reigns! Why could token rings segments not access

Here are the configs for your reference. As I said, they seem to me to be identical except for the fact that the 7204 ethernet port cannot be set to 10MB.

The config for the 3620:

version 12.1

no service single-slot-reload-enable

service nagle

service timestamps debug datetime msec localtime

service timestamps log datetime localtime

service password-encryption

!

hostname ISDR006

!

logging buffered 16384 debugging

logging rate-limit console 10 except errors

enable secret 5

enable password 7

!

clock timezone PST -8

clock summer-time PDT recurring

ip subnet-zero

!

!

no ip finger

ip domain-name infosys

ip name-server 172.x.x.x

!

ipx routing 0004.9ae4.63e1

call rsvp-sync

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 172.26.1.205 255.255.255.0

speed 10

half-duplex

!

interface Serial0/0

description T1 Connection to NMC ID: 53HCQA994693-001

ip address 172.25.252.65 255.255.255.252

ipx network B01C

ipx update interval rip 300

ipx update interval sap 300

no fair-queue

!

interface TokenRing0/0

mtu 4096

ip address 172.25.5.203 255.255.255.0

ip ospf priority 0

ipx encapsulation SNAP

ipx network A086

ipx update interval rip 300

ipx update interval sap 300

ring-speed 16

!

router ospf 10

log-adjacency-changes

network 172.25.5.0 0.0.0.255 area 0.0.0.0

network 172.25.252.0 0.0.0.255 area 0.0.0.0

network 172.26.1.0 0.0.0.255 area 0.0.0.0

!

ip classless

ip route 172.26.1.0 255.255.255.0 FastEthernet0/0

ip http server

!

logging source-interface FastEthernet0/0

logging 172.26.1.32

snmp-server community public RO

snmp-server trap link ietf

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps config

snmp-server enable traps syslog

!

!

!

!

dial-peer cor custom

!

!

!

banner login

!

line con 0

transport input none

line aux 0

line vty 0 4

password 7

login

!

ntp clock-period 17179864

ntp server 172.25.xxx

end

And the config for the 7204 is:

!

! NVRAM config last updated at 13:07:02 PST Sat Jan 11 2003

!

version 12.0

service timestamps debug datetime msec localtime

service timestamps log datetime localtime

service password-encryption

!

hostname ISDR006-TEMP

!

enable secret 5

!

clock timezone PST -8

clock summer-time PDT recurring

ip subnet-zero

!

!

ip domain-name infosys

ip name-server 172.25.xxx

!

ip cef

ipx routing 0003.e410.2800

cns event-service server

!

!

!

!

!

interface FastEthernet0/0

ip address 172.26.1.205 255.255.255.0

no ip directed-broadcast

half-duplex

!

interface TokenRing1/0

mtu 4096

ip address 172.25.5.203 255.255.255.0

no ip directed-broadcast

ip ospf priority 0

ipx encapsulation SNAP

ipx network A086

ipx update interval rip 300

ipx update interval sap 300

ring-speed 16

!

interface TokenRing1/1

no ip address

no ip directed-broadcast

shutdown

ring-speed 16

!

interface TokenRing1/2

no ip address

no ip directed-broadcast

shutdown

ring-speed 16

!

interface TokenRing1/3

no ip address

no ip directed-broadcast

shutdown

ring-speed 16

!

interface Serial2/0

description T1 Connection to NMC ID: 53HCQA994693-001

ip address 172.25.252.65 255.255.255.252

no ip directed-broadcast

ipx network B01C

ipx update interval rip 300

ipx update interval sap 300

no fair-queue

serial restart-delay 0

!

interface Serial2/1

no ip address

no ip directed-broadcast

shutdown

serial restart-delay 0

!

interface Serial2/2

no ip address

no ip directed-broadcast

shutdown

serial restart-delay 0

!

interface Serial2/3

no ip address

no ip directed-broadcast

shutdown

serial restart-delay 0

!

interface Serial2/4

no ip address

no ip directed-broadcast

shutdown

serial restart-delay 0

!

interface Serial2/5

no ip address

no ip directed-broadcast

shutdown

serial restart-delay 0

!

interface Serial2/6

no ip address

no ip directed-broadcast

shutdown

serial restart-delay 0

!

interface Serial2/7

no ip address

no ip directed-broadcast

shutdown

serial restart-delay 0

!

router ospf 10

network 172.25.5.0 0.0.0.255 area 0.0.0.0

network 172.25.252.0 0.0.0.255 area 0.0.0.0

network 172.26.1.0 0.0.0.255 area 0.0.0.0

!

ip classless

ip route 172.26.1.0 255.255.255.0 FastEthernet0/0

ip http server

!

logging source-interface FastEthernet0/0

snmp-server engineID local 0000000902000003E4102800

snmp-server enable traps config

snmp-server host 172.25.xxx public snmp

!

!

!

!

banner login

!

line con 0

transport input none

line aux 0

line vty 0 4

password 7

login

transport input lat pad v120 mop telnet rlogin udptn nasi

line vty 5 15

login

transport input lat pad v120 mop telnet rlogin udptn nasi

!

ntp server 172.25.xxx

end

There you go! I have a case opened with TAC but they don't have any ideas yet.

82
Views
0
Helpful
2
Replies