Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Connect Cisco 1605 to Comcast @home Cable modem

Having some config problems, can not seem to get it to work i have a 1605 Cisco router, and i would like to use it to connect my lan to the cable modem is it posible without extra hardware, if so what hardware would i need.

  • Other Network Infrastructure Subjects
4 REPLIES
New Member

Re: Connect Cisco 1605 to Comcast @home Cable modem

1) What version of software do you have (Show version)

2) Do you have a static IP or a dynamic IP?

3) Does your ISP require PPPOE?

4) What is your configuration (Show Run)

New Member

Re: Connect Cisco 1605 to Comcast @home Cable modem

1. Version 12.0(3)T

2. Dynamic IP, but i do recall specifying the ip, and it still working.

3. No PPPOE Required

4. as far as the configureation i have specified one internal address of 192.168.1.1 255.255.255.0, one extenal address of the isp.

hostname that the isp requires. ip default-gateway of the isp, ip name-server's ip domain-name, and a static route to isp.

Please let me know if you need any more info, or if you have any idea's.

Thanks

Brian

New Member

Re: Connect Cisco 1605 to Comcast @home Cable modem

It doesn't sound like you enabled NAT/PAT:

http://www.cisco.com/warp/public/cc/pd/iosw/ioft/ionetn/prodlit/1195_pp.htm

http://www.cisco.com/warp/public/556/nat-cisco.shtml

Try something like this:

interface Ethernet0

description Cable Modem Connection

mac-address 0008.a3f7.bd5d

! Some ISP's require you to register a MAC address. Make sure this is correct.

ip address dhcp

! If you can't issue the ip address dhcp command you need to upgrade IOS

! I think you need Version 12.1(2)T or better

! Don't use a static address if they require dynamic, this will cause problems

ip access-group 199 in

no ip proxy-arp

ip accounting output-packets

ip accounting access-violations

ip nat outside

no ip route-cache

no ip mroute-cache

ntp disable

no snmp trap link-status

no cdp enable

!

interface Ethernet1

description Internal Network

ip address 192.168.1.1 255.255.255.0

ip access-group 102 in

no ip proxy-arp

ip accounting output-packets

ip accounting access-violations

ip nat inside

no ip route-cache

no ip mroute-cache

!

ip nat inside source list 1 interface Ethernet0 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 199 deny icmp any any log

access-list 199 deny ospf any any log

access-list 199 deny eigrp any any log

access-list 199 deny rip any any log

access-list 199 deny ip 10.0.0.0 0.255.255.255 any log

access-list 199 deny ip 192.168.0.0 0.0.255.255 any log

access-list 199 deny ip 127.0.0.0 0.255.255.255 any log

access-list 199 permit ip any any log

New Member

Re: Connect Cisco 1605 to Comcast @home Cable modem

OK i have found out from previous posts that this version of Cisco IOS Cisco IOS Version 12.0(9) does not support dynamicly assigned IP's, so i will not be able to use this IOS to support my ISP, my router type is cisco 1605. My question is what version will support dynamicly assigned ip's, and where can i purchase a copy, what are my options, do i have to go directly to cisco.

Thanks in advance.

Brian

193
Views
0
Helpful
4
Replies