Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Connect to Internet through proxy using a 2621 router

We recently bought a 2621 router with 3 Ethernet interfaces. We also got a DirecPC satellite dish to serve as a redundant Internet connection for both our LAN and web servers (no ISDN, DSL, or cable is currently available here out in the sticks, so we were stuck with satellite). The three networks connected to the router are: 10.22.0.0 (primary Internet connection), 10.21.0.0 (DirecPC connection), and 10.20.0.0 (our LAN). All networks have are subnetted (255.255.0.0). Right now we are still running on our primary connection which is a cross-county fiber line to the ISD, who is our ISP, which in turn has a multiple T1 circuit to the phone company. My next step is to be able to configure the router to be able to route all Internet traffic to 10.21.1.2 (DPC proxy server), on port 1111. I would like to be able to accomplish this without having to configure the proxy settings on every PC, only having to worry about having the default gateway set on each PC on the LAN, and letting the router convert it to proxy (port 1111) traffic, if possible. The ultimate goal is to have the router automatically choose best path between the two links (undoubtably it would choose the primary connection, because the latency is hugely lower, but it'd be best to have it automatically switch to the other link once it detects the primary link as down). From what I've learned and been told, best path selection can only really be used with exterior and BGP routing protocols, where it would choose between two autonomous systems. Well, not only are we a single autonomous system here, but we also are a private network within a single autonomous system. So the current plan is to have two configurations on a TFTP server on the LAN - one with the router set to route only to the primary connection, and the other to route only to DirecPC. The only problem with that is that it's not automated - IS personnel would have to be notified of a downed connection in order to load the appropriate config file. Having said that, I'll post our current config file:

show run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Raptor

!

enable secret 5 -not shown-

enable password -not shown-

!

!

!

!

!

ip subnet-zero

!

!

!

!

interface FastEthernet0/0

ip address 10.20.1.1 255.255.0.0

no ip directed-broadcast

no ip mroute-cache

speed auto

full-duplex

!

interface FastEthernet0/1

ip address 10.21.1.1 255.255.0.0

no ip directed-broadcast

no ip mroute-cache

duplex auto

speed auto

!

interface Ethernet1/0

ip address 10.22.1.11 255.255.0.0

no ip directed-broadcast

no ip mroute-cache

!

ip classless

ip route 10.21.0.0 255.255.0.0 FastEthernet0/1

no ip http server

!

line con 0

transport input none

line aux 0

line vty 0 4

password -not shown-

login

!

no scheduler allocate

end

I would like to thank in advance anyone who can help me tackle this!

1 REPLY

Re: Connect to Internet through proxy using a 2621 router

Often times complex configuration issues are best addressed in an interactive session with one of our trained technical assistance engineers. While other forum users may be able to help, it’s often difficult to do so for this type of issue.

To utilize the resources at our Technical Assistance Center, please visit http://www.cisco.com/tac and to open a case with one of our TAC engineers, visit http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

126
Views
0
Helpful
1
Replies
CreatePlease to create content