Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Connected subnet not being advertised by OSPF, why?

Hello all,

We have a strange problem trying to advertise two connect subnets into OSPF. The only difference is that one network is a /24, the other is a /28.

Look at my show ip route results, note the "Advertised by" line.

CORE-L3a#sh ip route 192.168.118.16

Routing entry for 192.168.118.16/28

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via ospf 1, rip

Advertised by rip

Routing Descriptor Blocks:

* directly connected, via Vlan118

Route metric is 0, traffic share count is 1

CORE-L3a#sh ip route 192.168.1.0

Routing entry for 192.168.1.0/24

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via ospf 1, rip

Advertised by ospf 1 subnets route-map OSPFstatic rip

Routing Descriptor Blocks:

* directly connected, via Vlan100

Route metric is 0, traffic share count is 1

Here is what the related rip and OSPF setting look like:

router ospf 1

no log-adjacency-changes

no auto-cost

area 1 range 192.168.96.16 255.255.255.248

redistribute connected subnets route-map OSPFstatic

redistribute static subnets route-map OSPFstatic

redistribute rip

network 192.168.96.16 0.0.0.7 area 1

!

router rip

version 2

redistribute static route-map OSPFstatic

passive-interface Vlan96

network 192.168.118.0

network 192.168.1.0

no auto-summary

access-list 1 permit 192.168.1.0

access-list 2 permit 192.168.118.0

!

route-map OSPFstatic permit 2

match ip address 1 2

What am I missing?

Thanks for any help,

-Peter

9 REPLIES
Silver

Re: Connected subnet not being advertised by OSPF, why?

Peter

you need a network statement in OSPF 1 for 192.168.118.16

New Member

Re: Connected subnet not being advertised by OSPF, why?

Hello,

A show ip ospf database external on 192.168.118.16 yields:

CORE-L3a#sh ip ospf database external 192.168.118.16

OSPF Router with ID (206.6.107.3) (Process ID 1)

CORE-L3a#

Where the same command on 192.168.1.0 yields:

CORE-L3a#sh ip ospf database external 192.168.1.0

OSPF Router with ID (192.168.1.3) (Process ID 1)

Type-5 AS External Link States

LS age: 764

Options: (No TOS-capability, DC)

LS Type: AS External Link

Link State ID: 192.168.1.0 (External Network Number )

Advertising Router: 192.168.1.3

LS Seq Number: 80000116

Checksum: 0xDC2A

Length: 36

Network Mask: /24

Metric Type: 2 (Larger than any link state path)

TOS: 0

Metric: 20

Forward Address: 0.0.0.0

External Route Tag: 0

It still appears that my 192.168.118.16/28 network is not being advertised by OSPF for some reason.

On the remote router, I see the 192.168.1.0/24 as external and no route for the 192.168.118.16/28 network.

Thx,

-Peter

Silver

Re: Connected subnet not being advertised by OSPF, why?

did you try to change your network statement to

192.168.118.0 0.0.0.255 area 1

I am a little confused about your acl 1 & 2. I think you can permit both networks with ACL 1

New Member

Re: Connected subnet not being advertised by OSPF, why?

Hello,

I will try to add the network statement after close of business today.

But it still doesn't make sense what my other class C, 192.168.1.0/24 is being pushed out to my remote network via the "redistributed connected" statement. I don't have a network statement for the 192.168.1.0/24

My 192.168.118.16/28 network is also locally connected...

Thx,

-Peter

P.S. You are right about by ACL statement. My 192.168.1.0/24 network is actually a registered Class C. Just wanted to keep some privacy. :)

Silver

Re: Connected subnet not being advertised by OSPF, why?

it says it is directly connected to vlan 100, you are reditributing connected as well as rip in OSPF , and you are advertising that range in rip . What is the IP range of vlan 100 ?

New Member

Re: Connected subnet not being advertised by OSPF, why?

There could be some overlap in what we are advertising (RIP and OSPF). I'm jumping into this OSPF area as a novice trying to fix a problem unfortunately.

The "router" we are running on is a MSFC2 module on a CAT-6K switch, thus the directly connected to VLAN reference. The range of the subnet is 192.168.1.1 to 192.168.1.254. The VLAN100 interface is 192.168.1.1.

That would be the default gateway for all the 192.168.1.0/24 stations.

New Member

Re: Connected subnet not being advertised by OSPF, why?

Note the difference between your route and the ACL entry.

The prefix value has to match the ACL entry exactly and it

does not.

> CORE-L3a#sh ip route 192.168.118.16

>access-list 2 permit 192.168.118.0

Alex

New Member

Re: Connected subnet not being advertised by OSPF, why?

Alex,

I see your point. I'm going to try to change the ACL to match the network. Once I do this, how to I "force" this change to propogate? Unlike RIP, I don't think OSPF will send out an update unless there is a major segment change.

Thanks,

-Peter

Silver

Re: Connected subnet not being advertised by OSPF, why?

It should take effect once the change is done , If you want to make certain you can do a sh ip o redistribution. This clears all the type 5 lsa's from the database , By the way a standard acl will include all subnets for the class , An extended ACL has to be an exact match , for example

access list 1 permit 192.168.1.0 will include all subnets in the range

access-list 100 permit 192.168.1.0 255.255.255.0 will only match the specific network not all the subnets .

501
Views
0
Helpful
9
Replies
CreatePlease login to create content