Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Connecting a remote and head office using ISDN BRIs and Static routes

--begin ciscomoderator note-- The following post has **NOT** been edited to remove potentially confidential information because it appears to be lab configuration or test configuration information. Please refrain from posting confidential information on the site including passwords, hostnames, encryption keys, access lists and/or real IP addresses to reduce security risks to your network. Please email NP-Moderator@external.cisco.com with questions or concerns. -- end ciscomoderator note --

Hi,

I'm having trouble setting up a remote office with ISDN BRI Dialup to access the head office which answers the dialup using an ISDN 4-port BRI module. The remote office router is from the Cisco 800 series and the head office router is from the Cisco 2600 series. The remote office and head office both have to go through the head office router to access the internet.

I have setup 2 dialer profiles on the head office router, Dialer0 to send & recieve information to/from the remote office and Dialer 2 to provide access to the internet for either the remote office or the head office.

The configuration of the head office router is below.

Static routes are used between the two offices (ie no routing protocol)

I have set NAT on the BRI interface of the head office router that accepts calls from the remote office to NAT any traffic coming from that interface. NAT is also set on the Fast Ethernet interface which is the LAN side of the Head Office. I'm hoping that this is correct or makes sense.

The name-server is the ISPs DNS server.

A default route is set to send unknown traffic out to the ISP

A static route is also set to send traffic to the remote office.

There is only one access-list set to allow any traffic in/out as a basic connectivity test between the remote office, the head office and the internet.

The configuration was working but now isn't. Basically, the I could telnet into the remote office router from the headoffice router, ping the ISPs DNS server and get a reply. I could also ping it from the head office router. There are other remote offices that will be connected later on so the remaining 2 BRI interfaces on the head office router will be used to send/receive information to/from those sites.

I think that there is a problem with the Dialer Profiles but cannot see the problem myself. If anybody could check the configuration I would appreciate it. I have used public ip addresses on the subnet between the remote and head office to try and eliminate incorrect subnetting as one of the problems.

When the other remote offices come on stream, I will make them members of the same dialer pool-member 1.

Thanks

Gerry

hostname hqrouter01

!

enable secret password

enable password password

!

username remrouter02 password access

ip subnet-zero

no ip source-route

!

!

ip name-server 160.160.16.1

!

no ip bootp server

isdn switch-type basic-net3

!

interface FastEthernet0/0

ip address 192.168.26.9 255.255.255.0

no ip proxy-arp

ip nat inside

duplex auto

speed auto

no cdp enable

!

interface BRI1/0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

interface BRI1/1

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

interface BRI1/2

no ip address

encapsulation ppp

dialer pool-member 2

isdn switch-type basic-net3

no cdp enable

!

interface Dialer0

ip address 199.174.182.1 255.255.255.252 (199.174.182.2 is the remote routers BRI ip address)

ip nat inside

encapsulation ppp

dialer pool 1

dialer remote-name remrouter02

dialer string 011739145

dialer string 011739140

dialer-group 5

no cdp enable

!

interface Dialer2

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 2

dialer idle-timeout 300

dialer string 1890110110

dialer-group 1

no cdp enable

ppp authentication chap pap callin (Chap is used by the remote offices and the ISP)

ppp chap hostname ispusername

ppp chap password isppassword

!

ip nat inside source list 100 interface Dialer2 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer2

ip route 192.168.26.9 255.255.255.0 Dialer0

!

dialer-list 1 protocol ip list 100

dialer-list 5 protocol ip permit

access-list 100 permit ip any any time-range WORKINGDAY

no cdp run

!

time-range WORKINGDAY

periodic weekdays 8:00 to 19:00

1 REPLY
Bronze

Re: Connecting a remote and head office using ISDN BRIs and Stat

I was wondering if it is absolutely necessart to NAT twice. I would recommend that you NAT only once and see if the setup works. YOu could also see http://www.cisco.com/en/US/tech/tk801/tk133/technologies_tech_note09186a0080094e6c.shtml for guidelines for configuring dialer profiles.

97
Views
0
Helpful
1
Replies
CreatePlease to create content