Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Connecting from Cat 2950 to Cat 6509

I am connecting a 2950 to a 6509 in the following way. The Cat 6509 has MSFC which does the routing. My intention is for the Cat2950 to receive info from the Cat6509 MSFC.

A cross over cable between Cat 2950 int fa0/1 to Cat6509 7/4. I have configured the port int fa0/1 as follows

Cat 2950

vlan database

vtp client

int fa 0/1

speed 100

duplex full

switchport mode trunk

int fa 0/24

speed 100

duplex full

switchport access vlan 822

int vlan 1

ip address 10.10.10.10 255.255.255.192

ip default-gateway 10.10.10.254

On the Cisco6509

Port 7/4

set trunk 7/4 on

Encapsulation dot1q

native vlan 1

* - indicates vtp domain mismatch

Port Mode Encapsulation Status Native vlan

-------- ----------- ------------- ------------ -----------

7/4 on dot1q trunking 1

Using this, I cannot ping anything or telnet to it from my network

When I first configured it as thus:

Cat 2950

vlan database

vtp client

int fa 0/1

speed 100

duplex full

switchport mode trunk

int fa 0/24

speed 100

duplex full

switchport access vlan 622

int vlan 1

no ip address

shutdown

int vlan 5

ip address 10.10.10.10 255.255.255.192

ip default-gateway 10.10.10.254

On the Cisco6509

* - indicates vtp domain mismatch

Port Mode Encapsulation Status Native vlan

-------- ----------- ------------- ------------ -----------

7/4 on dot1q trunking 1

Port 7/4

set trunk 7/4 on

Encapsulation dot1q

native vlan 1

With this, I could telnet to the cat 2950 from my network. I could ping all the devices on the Cat6509 but plugging a device into Cat2950 int fa0/24 does not pick up any ip addresses from the DHCP server and when I changed the vlan to a staic vlan, i could not ping the default gateway.

The management vlan on the Cat 6509 is on vlan 5.

What am i doing wrong?

Thanks for yor quick help as this is rather urgent.

12 REPLIES
Bronze

Re: Connecting from Cat 2950 to Cat 6509

The default gateway of your 2950 is not on the same subnet as the switch's address. If you are going to use the IP address 10.10.10.10/26, your default gateway must be in the same range, i.e., 10.10.10.0 through 10.10.10.63. Also, it is possible that the IP address of the switch is compatible with VLAN 5, not VLAN 1. You must have consistency between your VLANs and your subnets.

Good Luck.

Mark

New Member

Re: Connecting from Cat 2950 to Cat 6509

Yes Sorry. Those were hypothetical ip addresses.

The ip address on vlan 1 Cat 2950 is actually in the same subnet as that of the gateway. 10.22.24.205 255.255.255.192 and the default gateway is 10.22.24.254. But no connection

On the Cat6509, apart from te trunking having a native vlan of 1 we have set the int sc0 to that in vlan 5 10.22.24.206 255.255.255.192.

When the ip address on Cat 2950 was in vlan 5, it was working ok but devices plugged int the 2950 could not connect onto the network. be we were able to talk to the switch.

Is there something extar I have to do on the Ca2950 to ake this work?

Uregnt Help. I have to get this working today

Thanks

Bronze

Re: Connecting from Cat 2950 to Cat 6509

Do the cats show the trunk is up? Does the 2950 have the other vlans defined or using VTP is it learning them? Is int vlan1 up in the 2950? Command to see the trunk status on 2950 is "sh int fa0/1 switch". Forcing speed/duplex on 2950 and not on 6509 may be causing problems.

Bronze

Re: Connecting from Cat 2950 to Cat 6509

Do you have VLAN interfaces set up in the MFSC? This will be a separate configuration from the config in the 6509. You must have VLANs set up just as you would set up ethernet connections.

Mark

New Member

Re: Connecting from Cat 2950 to Cat 6509

Sorry, I dont understand. Is this the MSFc in the 6509. When you say separate, do mean a new vlan needs to be configued on the Cat 2950 and also on the Cat6509.

But how does this explain that it should receive all its vlan from the vtp server. And then vlan xxx has been configured to receive dhcp on the Cat 6509 MSFC, so what I have done is to put

int fa 0/24 into Vlan xxx so that It can receive dhcp from the same place on Cat2950. On the Cat 2950 switch, i can ping the dhcp server.

Devices plugged into the Cat6509 and placed in vlan xxx receives dhcp adresses.

Thanks

New Member

Re: Connecting from Cat 2950 to Cat 6509

Yes the cats show the trunk is up

------------

Switch#sh int fa0/1

FastEthernet0/1 is up, line protocol is up

Hardware is Fast Ethernet, address is 000a.f46b.2e81 (bia 000a.f46b.2e81)

MTU 1500 bytes, BW 100000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:02, output hang never

Last clearing of "show interface" counters 05:06:57

Input queue: 5/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

and

Name: Fa0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Protected: false

and

Name: Fa0/24

Switchport: Enabled

Administrative Mode: dynamic desirable

Operational Mode: static access

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: native

Negotiation of Trunking: On

Access Mode VLAN: 5 (Management)

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Protected: false

--------------------------------------------------------------------------------

The 2950 is using vtp to learn the other vlan as below:

VTP Version : 2

Configuration Revision : 109

Maximum VLANs supported locally : 64

Number of existing VLANs : 52

VTP Operating Mode : Client

VTP Domain Name : xxxx

VTP Pruning Mode : Enabled

VTP V2 Mode : Enabled

VTP Traps Generation : Enabled

Interface Vlan 1 is down as I have moved the management inteface to vlan 5

and as soon as I did that it shut down the VLan 1 interface

Switch#sh int

Vlan1 is administratively down, line protocol is down

Hardware is CPU Interface, address is 000a.f46b.2e80 (bia 000a.f46b.2e80)

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 04:24:25, output never, output hang never

Vlan5 is up, line protocol is up

Hardware is CPU Interface, address is 000a.f46b.2e80 (bia 000a.f46b.2e80)

Internet address is 10.22.24.205/26

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output never, output hang never

Last clearing of "show interface" counters 05:10:08

-------------------------------------------------------

The speed and duplex on both the 2950 and 6509 are the same

Thanks

New Member

Re: Connecting from Cat 2950 to Cat 6509

Please help! Anyone out there.

Becasue our management vlan is on 5 and the interface configred for commincation is also on vlan 5 on the Cat2950, I am able t telnet to ti and continue working. But I still cannot get any deivce plugged into the 2950 to work.

Please help.

Thans

Bronze

Re: Connecting from Cat 2950 to Cat 6509

try a "sho trunk 7/4 det" o the 6509. See if it give you any hints about whats going on. see if thee is trunk traffic, check allowed vlans and pruned vlans. Pruning should no tbe able to block vlan1 but there might be some clues there. Next question is spanning tree. try a "sho spantree 7/4" and see if anything is getting blocked.

New Member

Re: Connecting from Cat 2950 to Cat 6509

bcilnd-65c1a sh trunk 7/4

* - indicates vtp domain mismatch

Port Mode Encapsulation Status Native vlan

-------- ----------- ------------- ------------ -----------

7/4 on dot1q trunking 1

Port Vlans allowed on trunk

-------- ---------------------------------------------------------------------

7/4 1-1005,1025-4094

Port Vlans allowed and active in management domain

-------- ---------------------------------------------------------------------

7/4 1,5,814-823

Port Vlans in spanning tree forwarding state and not pruned

-------- ---------------------------------------------------------------------

7/4 1,5

Sh spantree

bcilnd-65c1a sh spantree 7/4

Port Vlan Port-State Cost Prio Portfast Channel_id

------------------------ ---- ------------- --------- ---- -------- ----------

7/4 1 forwarding 3100 32 enabled 0

7/4 5 forwarding 3100 32 enabled 0

7/4 814 forwarding 3100 32 enabled 0

7/4 815 forwarding 3100 32 enabled 0

......

7/4 823 forwarding 3100 32 enabled 0

Thanks. Nothing is being blocked. Can we changed management vlans on Cat 2950?

New Member

Re: Connecting from Cat 2950 to Cat 6509

Sorry, but my english is very bad, ...

You need change the version of IOS in the switch 2950G. The version 12.9(EA1) it has errors, example : with the fastethernet port or gigaethernet uplink and many others problems. The solucion is replace version (downgrade) with the 12.6(EA2B).

Good luck

Bronze

Re: Connecting from Cat 2950 to Cat 6509

It looks like it has pruned the trunk. The original vlan for port fa0/24 (I think it was 622) along with all all the other vlans are pruned. Try actvating another port on another vlan besides 1 and 5 and see if it then shows up on the "not pruned" list. If it does and the host on that port still cannot communicate then I'd have to think there is something wrong in the MSFC (router) configuration. What does the msfc config for say vlan622 look like?

New Member

Re: Connecting from Cat 2950 to Cat 6509

Thank you all so very very much. I really appreciate your help.

I plugged in devices on to the 2950 and did a

show mac-address and could see it and did a

show cam on the 6509 and i could see the mac address of the device. At least at L2 level, it was ok

I did a reboot before this and this cleared the cache entry which i think was messed up. And everything worked fine after this.

The portfast on the int fa0/1 is disabled and those on the ohter interfaces are all enabled on the 2950. While the int 7/4 on the 6509 is also portfast disabled.

All worked well.

Thank you so very much

242
Views
0
Helpful
12
Replies