Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

dal
New Member

Connecting two 1751 - same subnet

New install - Two 1751 routers each with a WIC-1T serial card in slot 0. I have router A set as 192.168.0.21 with port unnumbered. I want router B to be on the same subnet - 192.168.0.22 w/port unnumbered also. It gives me a conflict when I attempt to have both on the same subnet. I have done this in the past with the same model router and a DSU card. But for the life of me I can't remember how. I hope some of you more experienced router folks can help me out. Thanks in advance. LDB

10 REPLIES
Bronze

Re: Connecting two 1751 - same subnet

Are you saying you are putting the same network on both ethernet interfaces and connecting them using IP unnumbered e0? Wont work. You dont put the same IP network in two different places in you network, routing wont know where to send packets destined for that network. If the routers are on the saem network then they have to be connected on those interfaces.

dal
New Member

Re: Connecting two 1751 - same subnet

I am saying putting both routers on the same subnet (192.168.0.XXX). And yes, have both routers port unumbered to e0. Each router will have a seperate IP, but on the same subnet. This works great for maintaing small remote sites. I have done this in the past but cannot remember how / or what the command line should read for "IRB" and "BVI". If anyone has any experience with setting up "IRB" and/or "BVI" I would appreciate some advice. Thanks

Re: Connecting two 1751 - same subnet

You need to bridge the traffic on both routers to use same subnet on both sides. Below is a sample IRB / BVI config for doing this. You could also turn off IP routing (no ip routing) and just bridge on the interfaces.

Router 1 cfg;

int e0

no ip address

bridge-group 1

int s0

bridge-group 1

bridge irb

bridge 1 bridge ip

bridge 1 protocol ieee

int bvi1

ip address 192.168.0.1 255.255.255.0

Router 2 cfg;

int e0

no ip address

bridge-group 1

int s0

bridge-group 1

bridge irb

bridge 1 bridge ip

bridge 1 protocol ieee

int bvi1

ip address 192.168.0.2 255.255.255.0

dal
New Member

Re: Connecting two 1751 - same subnet

Thanks for the info. I will try this today. I will let you know the outcome. Thanks again.

New Member

Re: Connecting two 1751 - same subnet

Use /32 subnet mask on both the loopback interfaces.

like 192.168.0.21 255.255.255.255

-Deepu

dal
New Member

Re: Connecting two 1751 - same subnet

I guess I will have plead ignorant here, but how will that help? If both interfaces are already on the same subnet. Thanks

New Member

Re: Connecting two 1751 - same subnet

Hi, if you don't mind, please send me a copy of the config for both routers to slleong@ntscorp.com

Thanks.

dal
New Member

Re: Connecting two 1751 - same subnet

I don't mind at all. It will be delayed a couple of days until the local telcom gets the lines working. This was complicating the problem. I appreciate your help and will forward in a couple of days. Thanks again. LDB

dal
New Member

Re: Connecting two 1751 - same subnet

Just got telcom issues resolved. Here is the config. Both routers are the same except for IP. Any help greatly appreciated.

CiscoDalton#show configuration Configure static map list

Using 723 out of 29688 bytesdomain name

!n

version 12.2

service timestamps debug uptime Configu

service timestamps log uptimemcap Modem

service password-encryption

forward

!r

hostname CiscoDalton

multilink

!

enable secret xxxxx

!

!

!

!

!n

interface FastEthernet0/0

^

description connected to EthernetLANst Build a priority lis

ip address 192.168.0.22 255.255.255.0

privilege

speed autod privilege

!a

interface Serial0/0al, m

no ip addressst-routing

version 2

network 192.168.0.0

no auto-summary

!

ip classless

no ip http server

!

!

snmp-server community public RO

snmp-server enable traps tty

!

line con 0

exec-timeout 0 0

password xxxx

login

line aux

line vty

password xxxx

login

!

no scheduler allocate

end

dal
New Member

Re: Connecting two 1751 - same subnet

Here is the correct configuration for both routers - I cut and pasted the wrong one on the previous reply. Ip address the only difference.

Using 876 out of 29688 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname CiscoChattanooga

!

enable password 7 1404071B1C0B383F75

!

memory-size iomem 25

ip subnet-zero

no ip domain lookup

!

!

!

bridge irb

!

!

interface FastEthernet0/0

description connected to EthernetLAN_1

no ip address

no keepalive

speed auto

bridge-group 1

!

interface Serial0/0

description connected to CiscoDalton

ip unnumbered FastEthernet0/0

bridge-group 1

!

interface BVI1

ip address 192.168.0.21 255.255.255.0

!

router rip

version 2

network 192.168.0.0

no auto-summary

!

ip classless

no ip http server

!

!

snmp-server community public RO

snmp-server enable traps tty

bridge 1 protocol ieee

!

line con 0

exec-timeout 0 0

password 7 111A0C15071D1918

login

line aux 0

line vty 0 4

password 7 095F5B19090A0506

login

!

no scheduler allocate

end

150
Views
0
Helpful
10
Replies
CreatePlease login to create content