Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Connection problem with Mica modem over on 3640

I try to connect with 56k modem but I lose the connection after one minute.

This is 3640 configuration:

username test password test

modem country mica italy

ip subnet-zero

!

!

!

async-bootp gateway 192.168.0.1

async-bootp dns-server 192.168.0.239

async-bootp nbns-server 192.168.0.237

isdn switch-type basic-net3

!

!

!

interface Loopback0

ip address 192.168.1.1 255.255.255.0

interface ethernet 0/0

ip address 192.168.0.200 255.255.255.0

!

interface BRI1/0

no ip address

isdn switch-type basic-net3

isdn incoming-voice modem

!

interface BRI1/1

no ip address

isdn switch-type basic-net3

isdn incoming-voice modem

!

interface BRI1/2

no ip address

isdn switch-type basic-net3

isdn incoming-voice modem

!

interface BRI1/3

no ip address

isdn switch-type basic-net3

isdn incoming-voice modem

!

interface Group-Async1

ip unnumbered Loopback0

dialer idle-timeout 600

encapsulation ppp

dialer in-band

async mode interactive

peer default ip address pool bologna

ppp authentication pap chap ms-chap

group-range 65 70

!

ip local pool bologna 192.168.0.201 192.168.0.210

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip http server

ip pim bidir-enable

!

!

!

line con 0

line 65 70

modem InOut

autoselect ppp

login local

line aux 0

line vty 0 4

login

!

!

end

This is Debug:

01:25:07: As65 PPP: O pkt type 0x0021, datagramsize 101

01:25:07: As65 PPP: I pkt type 0xC021, datagramsize 8

01:25:07: As65 PPP: I pkt type 0xC021, datagramsize 8

01:25:07: As65 LCP: I TERMREQ [Open] id 2 len 4

01:25:07: As65 LCP: O TERMACK [Open] id 2 len 4.

01:25:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, changed state to down

01:25:09: As65 LCP: TIMEout: State TERMsent

01:25:09: ISDN BR1/0: VOICE_HANGUP Event: call id 0xE, bchan 0, ces 1, cause 0x10

01:25:09: ISDN BR1/0: Event: Voice hangup call to call id 0xE

01:25:09: ISDN BR1/0: process_disconnect(): call id 0xE, call type is VOICE, b_idb 0x6119A698, ces 1, cause Normal call clearing(0x1

0)

01:25:09: %ISDN-6-DISCONNECT: Interface BRI1/0:1 disconnected from 348xxxxxxx, call lasted 135 seconds

01:25:09: ISDN: get_isdn_service_state(): idb 0x6119A698 bchan 2 is_isdn 1 Not a Pri

01:25:09: CCBRI_Go Fr Host InPkgInfo (Len=13) :

01:25:09: 5 8 1 0 E 3 8 1 90 8 2 80 90

01:25:09:

01:25:09: ISDN BR1/0: TX -> INFOc sapi=0 tei=94 ns=3 nr=1 i=0x0801C94508028090

01:25:09: DISCONNECT pd = 8 callref = 0xC9

01:25:09: Cause i = 0x8090 - Normal call clearing

Thanks

2 REPLIES
Cisco Employee

Re: Connection problem with Mica modem over on 3640

Above debug shows that the connection has lasted for 135 secs..

01:25:09: %ISDN-6-DISCONNECT: Interface BRI1/0:1 disconnected from 348xxxxxxx, call lasted 135 seconds

Now try to configure the following commands to configure the idle-timeout properly..

conf t

dialer-list 1 protocol ip permit

!

interface Group-Async1

dialer-group 1

!

That will make the all the ip traffic as interesting so link should stay up for atleast 600 secs..If not lets get

debug dialer

debug modem csm

debug modem

debug isdn q931

New Member

Re: Connection problem with Mica modem over on 3640

Hi,

In my opinion is that when you say 'login local' the default exec-timeout is 2 minutes.

This is what we use:

line 65 70

modem InOut

modem autoconfigure discovery

transport input all

autoselect during-login

autoselect ppp

stopbits 1

flowcontrol hardware

No problems with that !!!

Edwin van Wijk

89
Views
0
Helpful
2
Replies