Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Continuous 2950 management VLAN problem

According to all the Cisco instructions you are able to change the management VLAN on the 2950 from the default(1) to another number. I want my management VLAN to be 10. My problem is that every time 10 is set up and I bring up VLAN 1 the switch locks up and VLAN 10 will be shut down. It would seem strange that if you designate another VLAN as the management you can never bring up 1 again. Is it a bug where VLAN1 has to remain down. It can't be that you can only have one active VLAn running! I have configured 10 with an IP and have also done the following clustering commands:

cluster enable management 4

cluster management-vlan 10

cluster run

I don't want any memebrs no none were assigned, thus I don't need the timer or hold time commands. HELP...

4 REPLIES
Cisco Employee

Re: Continuous 2950 management VLAN problem

It's not a bug. On a CAt2950/XL switches you can have only one VLAN interface up and up at any point in time. It's a layer 2 switch only and having multiple VLAN interfaces up/up does not give any benefit

Community Member

Re: Continuous 2950 management VLAN problem

So all my other VLAN interfaces have to be administratively down for this to work.

Community Member

Re: Continuous 2950 management VLAN problem

Yes, as mentioned before, you can only have one management VLAN interface up at a time but you can configure multiple ports to be in multiple VLANs.

In the config below I have created Interface VLAN 2 and have placed additional ports on the switch into that VLAN. The remaining ports are all on the default VLAN 1. We have three ports doing trunking because this is a distribution switch and we have the router off one of the ports and an access switches downstream the other ports.

You will also notice that the default VLAN 1 is shutdown. There is no way to change that.

scms010#sh run

Building configuration...

Current configuration:

!

version 12.0

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime localtime

service password-encryption

!

hostname scms010

!

logging buffered 8192 debugging

no logging console

enable secret 5 $1$VnCI$E3UCMOWZdAe2sR4yegk7C1

!

!

!

!

!

!

ip subnet-zero

ip domain-name infosys.monterey

ip name-server 172.25.4.8

cluster enable Distribution 0

cluster member 1 mac-address 0008.a3c1.4540

cluster member 2 mac-address 0008.a3c0.7fc0

!

cluster discovery hop-count 1

!

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

switchport access vlan 2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

switchport access vlan 2

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface VLAN1

no ip address

no ip directed-broadcast

ip nat outside

shutdown

!

interface VLAN2

ip address 172.25.130.220 255.255.255.0

no ip directed-broadcast

ip nat outside

!

ip default-gateway 172.25.130.200

ip nat inside source list 199 interface VLAN2 overload

access-list 199 dynamic Cluster-NAT permit ip any any

snmp-server engineID local 0000000902000008E3FC5900

Community Member

Re: Continuous 2950 management VLAN problem

What the other poster said is true. But it is different than saying that you cannot have multiple VLANs on your switch. You CAN have multiple VLANs on your switch but you will most likely have to do some sort of trunking, either ISL or 802.1q.

You can have only ONE management VLAN up at a given time, but you can still put ports 1-10 in VLAN1 and ports 11-24 in your VLAN 10.

Does this make sense?

124
Views
0
Helpful
4
Replies
CreatePlease to create content