Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

copy running-config tftp: on a C3500XL Switch

I am backing up my switches to a TFTP server and have run into a small problem. I have several switches to back up, and they are all C3500XL switches, but they run 2 different IOS versions. When I run the command from the "web console" to <copy running-config tftp://172.16.8.245/landsw5.cfg> it runs fine under IOS 11.2 , but it hangs up for IOS 12.0 . Was there an error bulletin that I missed? I have successfully telneted into IOS 12.0 switches and run this same command. However I'm puzzled as to why the web console did not work when I entered this same command?

5 REPLIES
Bronze

Re: copy running-config tftp: on a C3500XL Switch

The default behavior for the write net (copy run tftp) command was changed in 12.0 code - CSCdm43709. Do you see any error messages on the screen when it hangs on 12.0 or does the connection just hang?

New Member

Re: copy running-config tftp: on a C3500XL Switch

When I enter the command "copy running-config tftp:" using the Web Console I get the following error message "%Error opening tftp:///running config (Bad file number)". However the system does not hang. You should note that I did not supply the necessary info following TFTP: because the system never gave me the opportunity to enter that info (using the Web Console), as it did under version 11 . BTW I never was able to find the error info relating to CSCdm43709, as referenced in your reply, although I searched the entire CISCO site???

Re: copy running-config tftp: on a C3500XL Switch

Hi,

it seems to me like an error in the propper HTML file.

I was trying to issue the same command via Web console running Netscape browser. The same error.

But when you go to View -> Page Source in your Netscape screen (in the moment befor clicking on tftp: choose for copy destination), you see the page code and the line for tftp: destination looks the same way as the line for nvram: destination. So there is no additional question about tftp server IP address and the command crashes similar way like when you issue copy runn tftp: without any IP ddress of the tftp server.

So it seems to me (I'm not a web page programmer) there is an error in the IOS 12.0 HTML (CMS) files which are installed together with IOS.

You migth try to open the page source on 11.2 switch and see if there is any difference.

Regards,

Milan

Bronze

Re: copy running-config tftp: on a C3500XL Switch

I'm not sure how you searched, but if you go to www.cisco.com and enter the bug id in the search box, you will see:

Best Bets:

Lookup this bug in Bug Toolkit - Login required

Click on that url and log in and you will see the bug details.

Or you can go directly to the bug toolkit:

http://www.cisco.com/cgi-bin/Support/Bugtool/launch_bugtool.pl

click on launch bug toolkit, then enter the bug id...

New Member

Re: copy running-config tftp: on a C3500XL Switch

Raymong, I previously had used BugTraq to research the code you gave me ( CSCdm43709 )...and just now I tried it again. The BugTraq system continues to tell me that this code does not exist????

398
Views
3
Helpful
5
Replies
CreatePlease login to create content