Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Correcting a "%OSPF-4-ERRRCV: Received invalid packet:" message

All,

I am looking for help in correcting an issue I having in my lab environment of OSPF. Basically, one of the routers is receiving the error message “%OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 192.168.1.15, Ethernet0”

I have checked to ensure that my backbone routers (router 1 and router 2) are in the correct area; area 0. I have ensured they have connectivity to each other. Router1 and Router are connected via their Ethernet0 ports. While Router3 and Router1 are connected via their S0 ports and a HDLC point to point circuit. The above error message is received when connected to the Console port of Router3.

Looking at the Cisco website, http://www.cisco.com/warp/public/104/19.html#3 has not helped me correct the error message. Any and all help would be appreciated.

Following are the configurations and show ip route commands

Router1:

Current configuration:

!

version 11.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname router1

!

enable password cisco

!

ip host router2 192.168.254.2

ip host router3 192.168.254.3

ip host router1 192.168.254.1

!

interface Loopback0

ip address 192.168.254.1 255.255.255.255

logging event subif-link-status

!

interface Ethernet0

ip address 192.168.1.15 255.255.255.0

logging event subif-link-status

!

interface Serial0

description NOWHERE WAN

ip address 192.168.3.15 255.255.255.0

logging event subif-link-status

no fair-queue

!

interface Serial1

ip address 172.17.1.1 255.255.255.252

logging event subif-link-status

clockrate 64000

!

router ospf 55

redistribute connected

network 192.168.254.1 0.0.0.0 area 254

network 192.168.1.0 0.0.0.255 area 0

network 192.168.3.0 0.0.0.255 area 3

network 172.17.0.0 0.0.255.255 area 17

!

ip classless

tftp-server flash c1600-sy-l.112-26.P4.bin

!

line con 0

password cisco

login

line vty 0 4

password cisco

login

!

end

router1#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, Ethernet0

C 192.168.3.0/24 is directly connected, Serial0

O IA 192.168.4.0/24 [110/74] via 192.168.1.16, 00:01:58, Ethernet0

O E2 192.168.5.0/24 [110/20] via 172.17.1.2, 00:01:58, Serial1

192.168.254.0/32 is subnetted, 2 subnets

O IA 192.168.254.2 [110/11] via 192.168.1.16, 00:01:58, Ethernet0

C 192.168.254.1 is directly connected, Loopback0

172.17.0.0/30 is subnetted, 1 subnets

C 172.17.1.0 is directly connected, Serial1

router1#

Router2:

router2#wr t

Building configuration...

Current configuration:

!

version 11.2

no service udp-small-servers

no service tcp-small-servers

!

hostname router2

!

enable password cisco

!

ip host router1 192.168.254.1

ip host router2 192.168.254.2

ip host router3 192.168.254.3

!

interface Loopback0

ip address 192.168.254.2 255.255.255.255

!

interface Ethernet0

description Connected to TJLAN

ip address 192.168.1.16 255.255.255.0

!

interface Serial0

ip address 192.168.4.1 255.255.255.0

no ip mroute-cache

!

interface Serial1

no ip address

shutdown

!

router ospf 55

redistribute connected

network 192.168.254.2 0.0.0.0 area 254

network 192.168.1.0 0.0.0.255 area 0

network 192.168.3.0 0.0.0.255 area 3

network 192.168.4.0 0.0.0.255 area 4

!

ip classless

!

!

line con 0

password cisco

login

line aux 0

line vty 0 4

password cisco

login

!

end

router2#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, Ethernet0

O IA 192.168.3.0/24 [110/74] via 192.168.1.15, 00:03:19, Ethernet0

C 192.168.4.0/24 is directly connected, Serial0

O E2 192.168.5.0/24 [110/20] via 192.168.1.15, 00:03:19, Ethernet0

192.168.254.0/32 is subnetted, 2 subnets

C 192.168.254.2 is directly connected, Loopback0

O IA 192.168.254.1 [110/11] via 192.168.1.15, 00:03:19, Ethernet0

172.17.0.0/30 is subnetted, 1 subnets

O IA 172.17.1.0 [110/74] via 192.168.1.15, 00:03:19, Ethernet0

router2#

Router3:

router3#wr t

Building configuration...

Current configuration:

!

version 11.2

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname router3

!

enable password cisco

!

ip host router1 192.168.254.1

ip host router2 192.168.254.2

ip host router3 192.168.254.3

!

interface Loopback0

ip address 192.168.254.3 255.255.255.255

logging event subif-link-status

!

interface Ethernet0

ip address 192.168.5.15 255.255.255.0

logging event subif-link-status

!

interface Serial0

no ip address

logging event subif-link-status

shutdown

!

interface Serial1

ip address 172.17.1.2 255.255.255.252

logging event subif-link-status

!

router ospf 55

redistribute connected

network 192.168.254.3 0.0.0.0 area 254

network 192.168.5.0 0.0.0.255 area 5

network 172.17.0.0 0.0.255.255 area 17

!

ip classless

!

line con 0

password cisco

login

line vty 0 4

password cisco

login

!

end

router3#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR

Gateway of last resort is not set

O IA 192.168.1.0/24 [110/74] via 172.17.1.1, 00:04:37, Serial1

O IA 192.168.3.0/24 [110/128] via 172.17.1.1, 00:04:37, Serial1

O IA 192.168.4.0/24 [110/138] via 172.17.1.1, 00:04:37, Serial1

C 192.168.5.0/24 is directly connected, Ethernet0

192.168.254.0/32 is subnetted, 3 subnets

O IA 192.168.254.2 [110/75] via 172.17.1.1, 00:04:37, Serial1

C 192.168.254.3 is directly connected, Loopback0

O IA 192.168.254.1 [110/65] via 172.17.1.1, 00:04:37, Serial1

172.17.0.0/30 is subnetted, 1 subnets

C 172.17.1.0 is directly connected, Serial1

router3#

5 REPLIES

Re: Correcting a "%OSPF-4-ERRRCV: Received invalid packet:" mess

I see that your topology is like this.

R3----R1---R2

R3 has area 5 which has no direct link to area 0 (link between R1 and R2).

area 5 needs to be directly attached to area 0, for in this case you need to configure a virtual link between R3 and R1. The transit area would be area 17.

Give a show ip ospf neighbor command on R3 and R1 and find out the router ids of each of them. Now configure a virtual link on R3 and R1 as follows

router ospf 55

area 17 virtual-link

On R3 use R1's router id and on R1 use R3's router id.

Hope that solves your problem

New Member

Re: Correcting a "%OSPF-4-ERRRCV: Received invalid packet:" mess

Hmm.

I have added the following to Router1 configuration:

router ospf 55

redistribute connected

network 192.168.254.1 0.0.0.0 area 254

network 192.168.1.0 0.0.0.255 area 0

network 192.168.3.0 0.0.0.255 area 3

network 172.17.0.0 0.0.255.255 area 17

area 17 virtual-link 192.168.254.3

While Router3 has the following:

router ospf 55

redistribute connected

network 192.168.254.3 0.0.0.0 area 254

network 192.168.5.0 0.0.0.255 area 5

network 172.17.0.0 0.0.255.255 area 17

area 17 virtual-link 192.168.254.1

But I am still getting the error :

%OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 192.168.1.16, Ethernet0

AND sometimes I get:

%OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 192.168.1.15, Ethernet0

Silver

Re: Correcting a "%OSPF-4-ERRRCV: Received invalid packet:" mess

On router 3 you have an area 254 and an area 5 . These areas do not touch the area 0 . One of the rules of OSPF is that all areas must touch area 0. This is why you are getting the mismatch area id messages .

one more thing is that on router 2 you have a network statement for 192.168.3.0 area 3 , although it is not hirting anything This is not needed , you may want to remove it.

New Member

Re: Correcting a "%OSPF-4-ERRRCV: Received invalid packet:" mess

O.K.

On router3 I have added virtual links for area 5 and area 17 to its neighbor router1 which is also in the backbone. Here is the current configuration

router3#wr t

Building configuration...

Current configuration:

!

version 11.2

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname router3

!

enable password cisco

!

ip host router1 192.168.254.1

ip host router2 192.168.254.2

ip host router3 192.168.254.3

!

interface Loopback0

ip address 192.168.254.3 255.255.255.255

logging event subif-link-status

!

interface Ethernet0

ip address 192.168.5.15 255.255.255.0

logging event subif-link-status

!

interface Serial0

no ip address

logging event subif-link-status

shutdown

!

interface Serial1

ip address 172.17.1.2 255.255.255.252

logging event subif-link-status

!

router ospf 55

redistribute connected

network 192.168.254.3 0.0.0.0 area 254

network 192.168.5.0 0.0.0.255 area 5

network 172.17.0.0 0.0.255.255 area 17

area 17 virtual-link 192.168.254.1

area 254 virtual-link 192.168.254.1

!

ip classless

!

line con 0

password cisco

login

line vty 0 4

password cisco

login

!

end

router3#

However, I am still getting the error:

%OSPF-4-ERRRCV: Received invalid packet: mismatch area ID, from backbone area must be virtual-link but not found from 192.168.1.15, Ethernet0

Also, I have removed the erroneous network statement on router2 of network 192.168.3.0 area 3

Silver

Re: Correcting a "%OSPF-4-ERRRCV: Received invalid packet:" mess

area 5 does not have a virtual link , I do not think you need the virual link for area 17 , that area touches the backbone on router 1

530
Views
0
Helpful
5
Replies
CreatePlease to create content