Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

could NAT every source IP address ?

hallo

I have a router with an inside (Eth0) and an outside (Serial0) interfaces.

This router has a default route "ip route 0.0.0.0 0.0.0.0 serial 0".

I would like to NAT the source Ip addresses of all the traffic exiting the S0 interface even if that source addresses aren't in the Eth0 subnet (inside).

Is it possible ?

Francesco

4 REPLIES
Bronze

Re: could NAT every source IP address ?

Yes it is as long as you do not like to have a 1 to 1 NAT.

Just create a nat pool with an ACL permits everything.Following a sample:

ip nat pool "Poolname" netmask

ip nat inside source list 30 pool "Poolname" overload

!

access-list 30 permit any

Hope that helps

Roger

New Member

Re: could NAT every source IP address ?

Hi Francesco,

You may also use this syntax.

interface ethernet 0

ip address 192.168.10.1 255.255.255.0

ip nat inside

interface serial0

ip address yy.yy.yy.yy 255.255.255.0

ip nat outside

ip nat inside source list 1 interface serial 0 overload

access-list 1 permit 192.168.10.0 0.0.0.255

Hope this helps.

Best Regards,

Ansley R. Verzosa

New Member

Re: could NAT every source IP address ?

is there any command like ip nat everything 0.0.0.0 0.0.0.0 if port 25 or 110 to 10.0.0.1

I mean can i redirect tcp ports 25 and 110 to inside address ?

Bronze

Re: could NAT every source IP address ?

How about this?

ip nat inside source static tcp 10.0.0.1 25 PUBLIC 25

It works both ways, from inside out, as well as outside in.

107
Views
0
Helpful
4
Replies