Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

crc error between 2950 and 3620 router

I have connected the 2950 to the 3620, and the running-config of 2950 below:

2950#show running-config

Building configuration...

Current configuration : 1279 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 2950

!

enable secret xxxx

!

no ip subnet-zero

no ip finger

no ip domain-lookup

!

interface FastEthernet0/1

duplex half

speed 10

!

interface FastEthernet0/2

!

……

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface FastEthernet0/24.122

!

interface FastEthernet0/24.123

!

interface Vlan1

bandwidth 10000

ip address 192.168.10.200 255.255.255.0

no ip route-cache

delay 100

!

ip default-gateway 192.168.10.254

no ip http server

!

line con 0

transport input none

line vty 0 4

password xxx

login

line vty 5 15

login

!

end

And the 3620 router just set the interface ethernet0/3:

interface Ethernet0/3

ip address 192.168.10.254 255.255.255.0

half-duplex

I have connected the f0/1 of switch to the eth0/3 of router. There are many crc errors between the switch and router, and try to change the duplex and speed rate, but it didn't take effect. I ensure the cable is good.

Thank you for your suggestion!

1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: crc error between 2950 and 3620 router

Trying changing the speed of from 10 to 100 and also the duplex as the reason why u add a hub,the problem disappear is because of this.

OR

can try to check the link below, cause if the above is not the cause,it could be the field notice below:

http://www.cisco.com/warp/public/770/fn26174.shtml

Please rate if this post is helpful..

thks,

rgds,

ken L

14 REPLIES

Re: crc error between 2950 and 3620 router

Hi

Duplex and Speed settings depends on the interface type you use on both the sides.

In your case Cisco 3620 is currently having a ethernet port which can support half-duplex and 10Mbps.

Are you seeing this CRC error only in the router side or on both the sides ? do remember to clear the counters on both the ends before start monitoring the same..

do you have any free fastethernet port available in 3620 so that you can patch up this connection to that port and check ?

Also are you seeing only CRC or again input errors too ?

regds

Community Member

Re: crc error between 2950 and 3620 router

First, thank you for your notice of my problems.

Yes. When I ping from both directions, I'm seeing the CRC error only in the switch. And I have cleared the counters in both ends.

And I try to connect to another port of the router, It exists the same problem.

I'm seeing both of the input errors and CRC errors.

The interface of f0/1 (in switch)is following:

2950#show int f0/1

FastEthernet0/1 is up, line protocol is up

Hardware is Fast Ethernet, address is 0007.84fc.d1c1 (bia 0007.84fc.d

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 219/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 10Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:03:10, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:11:25

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 1000 bits/sec, 1 packets/sec

5 minute output rate 1000 bits/sec, 3 packets/sec

299 packets input, 39511 bytes, 0 no buffer

Received 5 broadcasts, 0 runts, 0 giants, 0 throttles

164 input errors, 164 CRC, 0 frame, 0 overrun, 33 ignored

0 input packets with dribble condition detected

1058 packets output, 81544 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

2950#

Re: crc error between 2950 and 3620 router

Hi Friend,

Check this

reliability 219/255 <----------

Reliability of the link is less, that's why when u ping or send traffic you are getting a lot of CRC's.

This indicates some problem with the media.Please replace the cable with some other good known cable. Try to change the switchport as well.

HTH, Please rate if it does.

-amit singh

Community Member

Re: crc error between 2950 and 3620 router

I think the reliability value is the result of the crc errors. And it is the same problem "Why are there some many crc error?"

I have changed many cables and many ports to connect, but it's the same problem.

And please notice that this problem is just existing when the switch is connected to the 3620 router. I'm sure that the switch, router and cable are all goot.

I think we can exclude the hardware problems and there are some strange problems between 3600 serial router and 2950 catalyst switch.

Re: crc error between 2950 and 3620 router

Hi,

What is the IOS you are running on the router. It could be the IOS issue or may be the hardware is faulty. Please paste a "show version" from your router.

Please try to upgrade the IOS on your router and see if that makes any diffrence.Once we come to the conclusion that software is not the issue we can think that it could be a hardware issue.

HTH, please rate if it does.

-amit singh

Community Member

Re: crc error between 2950 and 3620 router

Hi:

CRC errors usually are related to physical problems

Please check cable category (for 10 Mb cat 3 is OK)

Check there are not an EMI source of interference.

Just in case try to change the cable and the switch port.

Hope it help. Rate helpfull posts.

Best regards

Alberto Giorgi from spain.

Community Member

Re: crc error between 2950 and 3620 router

the ios of the router:

Router#show version

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3620-IS-M), Version 12.3(9), RELEASE SOFTWARE (fc2)

Copyright (c) 1986-2004 by cisco Systems, Inc.

Compiled Fri 14-May-04 17:34 by dchih

Image text-base: 0x60008B00, data-base: 0x618F6000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (f

c1)

Router uptime is 3 weeks, 4 days, 6 hours, 30 minutes

System returned to ROM by power-on

System image file is "flash:c3620-is-mz.123-9.bin"

cisco 3620 (R4700) processor (revision 0x81) with 61440K/4096K bytes of memory.

Processor board ID 28026966

R4700 CPU at 80MHz, Implementation 33, Rev 1.0

Bridging software.

X.25 software, Version 3.0.0.

4 Ethernet/IEEE 802.3 interface(s)

DRAM configuration is 32 bits wide with parity disabled.

29K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Community Member

Re: crc error between 2950 and 3620 router

Hi:

Did you change the port?

Did you change the link cable?

Same results?

Regards

Alberto Giorgi from spain.

Community Member

Re: crc error between 2950 and 3620 router

Yes, I changed everything(port,cable, duplex, speed)I could.

Community Member

Re: crc error between 2950 and 3620 router

And when i add a hub between the router and switch, it's will be ok, no crc error.

So, what's the problem?

Community Member

Re: crc error between 2950 and 3620 router

Trying changing the speed of from 10 to 100 and also the duplex as the reason why u add a hub,the problem disappear is because of this.

OR

can try to check the link below, cause if the above is not the cause,it could be the field notice below:

http://www.cisco.com/warp/public/770/fn26174.shtml

Please rate if this post is helpful..

thks,

rgds,

ken L

Community Member

Re: crc error between 2950 and 3620 router

Trying changing the speed of from 10 to 100 and also the duplex as the reason why u add a hub,the problem disappear is because of this.

OR

can try to check the link below, cause if the above is not the cause,it could be the field notice below:

http://www.cisco.com/warp/public/770/fn26174.shtml

Please rate if this post is helpful..

thks,

rgds,

ken L

Community Member

Re: crc error between 2950 and 3620 router

Trying changing the speed of from 10 to 100 and also the duplex as the reason why u add a hub,the problem disappear is because of this.

OR

can try to check the link below, cause if the above is not the cause,it could be the field notice below:

http://www.cisco.com/warp/public/770/fn26174.shtml

Please rate if this post is helpful..

thks,

rgds,

ken L

Community Member

Re: crc error between 2950 and 3620 router

Thank you, I think my problem is in it. My switch session number is in it.

228
Views
0
Helpful
14
Replies
CreatePlease to create content