Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

CRC/Framing error -Internal CSU/DSU clock speed

I have a Cisco 3640 router that host 3 t1 circuits. 1 is to our frame, the other 2 load balance between a remote site. We have been seeing CRC/Framing errors on 1 of 2 circuits going to the remote site and have had the line tested clean. The CSU's are internal so cables are not an issue. From what I've read it sounds most likely to be a clocking issue but the configs look OK. Does anybody have any suggestions?

4 REPLIES
Silver

Re: CRC/Framing error -Internal CSU/DSU clock speed

ussually if you have a clocking problem you will see aborts increment , Can you paste in sh int and a sh run from both sides .

Have you given the carrier any loops to try to determine where the problem is ?

New Member

Re: CRC/Framing error -Internal CSU/DSU clock speed

Had the carrier on site...he could loop both ends. Ran several different test patterns and they tested good.

Appreciate the help.

*****Near side*******

TLC-Gateway#show interfaces ser 3/1

Serial3/1 is up, line protocol is up

Hardware is DSCC4 with integrated T1 CSU/DSU

Internet address is 192.168.236.1/24

MTU 1500 bytes, BW 2048 Kbit, DLY 20000 usec,

reliability 255/255, txload 13/255, rxload 4/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:05:15

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/4/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1536 kilobits/sec

5 minute input rate 38000 bits/sec, 37 packets/sec

5 minute output rate 110000 bits/sec, 39 packets/sec

11933 packets input, 1921504 bytes, 0 no buffer

Received 37 broadcasts, 0 runts, 0 giants, 0 throttles

111 input errors, 48 CRC, 63 frame, 0 overrun, 0 ignored, 0 abort

12548 packets output, 4341973 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

-------------------------------------------------------

show running config output (had to shorten, got rid of sub interface on the frame)

ip subnet-zero

!

!

no ip domain-lookup

ip domain-name totallogistic.com

ip name-server 192.81.228.2

!

ip address-pool dhcp-proxy-client

isdn switch-type primary-dms100

!

controller T1 1/0

framing esf

linecode b8zs

pri-group timeslots 1-24

!

!

!

interface Loopback0

description Interface for Async (Dialin) Users

ip address 192.168.253.1 255.255.255.0

!

interface Loopback1

description Interface for ISDN (Backup) Users

ip address 192.168.254.1 255.255.255.0

!

interface FastEthernet0/0

ip address 192.81.228.14 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

description Connection to Frame

bandwidth 1544

no ip address

encapsulation frame-relay IETF

service-module t1 timeslots 1-24

frame-relay lmi-type ansi

!

interface Serial0/1

description T1 Connection to Holland

bandwidth 1544

ip address 192.168.236.1 255.255.255.0

no ip route-cache

no ip mroute-cache

shutdown

!

interface Serial1/0:23

no ip address

encapsulation ppp

dialer rotary-group 1

dialer-group 1

isdn switch-type primary-dms100

isdn incoming-voice modem

no cdp enable

ppp authentication chap

ppp multilink

!

interface Serial3/0

description to Holland Office

ip address 192.168.235.1 255.255.255.0

no ip route-cache

no ip mroute-cache

!

interface Serial3/1

ip address 192.168.236.1 255.255.255.0

no ip route-cache

no ip mroute-cache

!

interface Group-Async0

ip unnumbered Loopback0

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer in-band

dialer idle-timeout 3600

dialer-group 1

async mode dedicated

peer default ip address pool ASYNC

no fair-queue

ppp authentication chap pap

group-range 65 88

!

interface Dialer1

ip unnumbered Loopback1

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer in-band

dialer idle-timeout 180

dialer-group 1

no peer default ip address

no cdp enable

ppp authentication chap

ppp multilink

!

ip local pool ASYNC 192.168.253.2 192.168.253.254

ip classless

ip route 0.0.0.0 0.0.0.0 192.81.228.47

ip route 192.168.10.0 255.255.255.0 192.168.213.2

ip route 192.168.15.0 255.255.255.0 192.168.233.2

ip route 192.168.20.0 255.255.255.0 192.168.212.2

ip route 192.168.25.0 255.255.255.0 192.168.214.2

ip route 192.168.30.0 255.255.255.0 192.168.235.2

ip route 192.168.30.0 255.255.255.0 192.168.236.2

ip route 192.168.31.0 255.255.255.0 192.168.235.2

ip route 192.168.31.0 255.255.255.0 192.168.236.2

ip route 192.168.35.0 255.255.255.0 192.168.216.2

ip route 192.168.40.0 255.255.255.0 192.168.217.2

ip route 192.168.45.0 255.255.255.0 192.168.218.2

ip route 192.168.50.0 255.255.255.0 192.168.219.2

ip route 192.168.55.0 255.255.255.0 192.168.220.2

ip route 192.168.60.0 255.255.255.0 192.168.221.2

ip route 192.168.65.0 255.255.255.0 192.168.222.2

ip route 192.168.70.0 255.255.255.0 192.168.223.2

ip route 192.168.75.0 255.255.255.0 192.168.224.2

ip route 192.168.80.0 255.255.255.0 192.168.225.2

ip route 192.168.85.0 255.255.255.0 192.168.226.2

ip route 192.168.90.0 255.255.255.0 192.168.227.2

ip route 192.168.95.0 255.255.255.0 192.168.228.2

ip route 192.168.100.0 255.255.255.0 192.168.229.2

ip route 192.168.105.0 255.255.255.0 192.168.230.2

ip route 192.168.105.0 255.255.255.0 192.168.254.2 200

ip route 192.168.110.0 255.255.255.0 192.168.231.2

ip route 192.168.115.0 255.255.255.0 192.168.232.0

ip route 192.168.120.0 255.255.255.0 192.168.234.2

ip route 206.230.208.0 255.255.255.0 192.168.214.2

no ip http server

ip pim bidir-enable

!

logging 192.81.228.100

dialer-list 1 protocol ip permit

xxxxxx

no snmp-server enable traps tty

!

line con 0

password xxxx

login

line 65 88

timeout login response 100

no flush-at-activation

login local

modem Dialin

modem autoconfigure discovery

autoselect ppp

line aux 0

password xxxxx

login

speed

line vty 0 4

password xxxxx

login

!

end

------------------------------------------------------

Gateway#show service-module ser 3/1

Module type is T1/fractional

Hardware revision is 0.88, Software revision is 0.2,

Image checksum is 0x73D70058, Protocol revision is 0.1

Receiver has no alarms.

Framing is ESF, Line Code is B8ZS, Current clock source is line,

Fraction has 24 timeslots (64 Kbits/sec each), Net bandwidth is 1536 Kbits/sec.

Last user loopback performed:

no loopback

duration 00:07:35

Last module self-test (done at startup): Passed

Last clearing of alarm counters 00:08:20

loss of signal : 0,

loss of frame : 0,

AIS alarm : 0,

Remote alarm : 0,

Module access errors : 0,

Total Data (last 96 15 minute intervals):

15569 Line Code Violations, 10076 Path Code Violations

1033 Slip Secs, 1043 Fr Loss Secs, 7454 Line Err Secs, 12137 Degraded Mins

6391 Errored Secs, 2577 Bursty Err Secs, 51 Severely Err Secs, 1033 Unavail

Secs

Data in current interval (564 seconds elapsed):

255 Line Code Violations, 183 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 60 Line Err Secs, 9 Degraded Mins

59 Errored Secs, 24 Bursty Err Secs, 1 Severely Err Secs, 0 Unavail Secs

---------------------------------------------------------------------------------

show contr ser 3/1 output

DSCC4 SCC specific errors:

9 input aborts on receiving flag sequence

0 throttles, 0 enables

0 overruns

0 transmitter underruns

0 transmitter CTS losts

0 dma tx err, 9 dma rx err

12 scc frame length exceeded

0 xoffs received

245776097 fecpm intr, 57187074 rx intr, 62081680 tx intr, 0 num holdq

31 rxbd overflow

New Member

Re: CRC/Framing error -Internal CSU/DSU clock speed

Remote side configuration......

*********REMOTE SIDE**********************************************************

show running config output

ip subnet-zero

!

!

!

!

!

!

interface Serial0

ip address 192.168.235.2 255.255.255.0

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

!

interface Serial1

ip address 192.168.236.2 255.255.255.0

no ip directed-broadcast

no ip route-cache

no ip mroute-cache

!

interface FastEthernet0

ip address 192.168.30.1 255.255.255.0

no ip directed-broadcast

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.235.1

ip route 0.0.0.0 0.0.0.0 192.168.236.1

!

logging 192.81.228.100

xxxx

!

line con 0

password xxxx

login

transport input none

line aux 0

password xxxx

login

password xxxxx

login

!

end

--------------------------------------------------------------------------------------------

CDO#show interfaces ser 1

Serial1 is up, line protocol is up

Hardware is PQUICC with Fractional T1 CSU/DSU

Internet address is 192.168.236.2/24

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliablility 255/255, txload 6/255, rxload 20/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 1d08h

Input queue: 0/75/0 (size/max/drops); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/12/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 123000 bits/sec, 41 packets/sec

5 minute output rate 37000 bits/sec, 35 packets/sec

3526789 packets input, 2092005274 bytes, 0 no buffer

Received 15717 broadcasts, 0 runts, 0 giants, 0 throttles

980 input errors, 307 CRC, 663 frame, 0 overrun, 0 ignored, 10 abort

3384387 packets output, 558937931 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

2 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

--------------------------------------------------------------------------------------------

CDO#show ser

CDO#show service-module ser 1

Module type is T1/fractional

Hardware revision is 0.96, Software revision is 1.08,

Image checksum is 0xB8C1E847, Protocol revision is 0.1

Receiver has no alarms.

Framing is ESF, Line Code is B8ZS, Current clock source is line,

Fraction has 24 timeslots (64 Kbits/sec each), Net bandwidth is 1536 Kbits/sec.

Last module self-test (done at startup): Passed

Last clearing of alarm counters 1d08h

loss of signal : 0,

loss of frame : 0,

AIS alarm : 0,

Remote alarm : 1, last occurred 02:56:54

Module access errors : 0,

Total Data (last 96 15 minute intervals):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 5 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

3 Errored Secs, 0 Bursty Err Secs, 5 Severely Err Secs, 0 Unavail Secs

Data in current interval (206 seconds elapsed):

0 Line Code Violations, 0 Path Code Violations

0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

CDO#

--------------------------------------------------------------------------------------------

Show controller ser 1

CC HDLC PARAMETER RAM (at 0xFF003D38)

CRC Preset [C_PRES]=0xFFFF, Mask [C_MASK]=0xF0B8

Errors: CRC [CRCEC]=308, Aborts [ABTSC]=10, Discards [DISFC]=0

Nonmatch Addr Cntr [NMARC]=0

Retry Count [RETRC]=0

Max Frame Length [MFLR]=1608

Rx Int Threshold [RFTHR]=0, Frame Cnt [RFCNT]=47375

User-defined Address 0000/0000/0000/0000

User-defined Address Mask 0x0000

buffer size 1524

PowerQUICC SCC specific errors:

145 input aborts on receiving flag sequence

0 throttles, 0 enables

0 overruns

0 transmitter underruns

0 transmitter CTS losts

Silver

Re: CRC/Framing error -Internal CSU/DSU clock speed

most of the time in point to point scenarios the carrier does not provide clock , have you verified from the carrier if they are providing clock?

Also is there an extended demarc at either side ?

Another thing you may want to do is have the carrier put up a monitor and monitor the port for a day or 2 then have them pull the port stats , your errors could be bursty and when they test they do not see the errors, more often than not it is a carrier issue ,

also find out where they are testing from

are they testing from the nearest dax if so have them move back as close to eith side then run to loops that you provide ,

If you do not have the service module configured to be able to be lop\oped remotely they will not be able to do it,service-module t1 fdl both is the command , if this is not on there there is no way they could have looped the csu

320
Views
0
Helpful
4
Replies
CreatePlease to create content