Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

creating NAT overload for vlsm network

Hello. I have created a 5 different subnetworks using vlsm, they are all connected to the same router and each end device can talk to each other the problem is i am trying to implement NAT overload (PAT) so that the end devices using the private ip address scheme i have used can access the internet sharing a single IP address. However the data cannot find its way out of the private network onto the internet. When i try and ping the web server on my topology i get a 'destination host unreachable' error from my default gateway.

The following is a copy of my router log and a picture of my topology.

Router>enable
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#enable secret class
Router(config)#enable password cisco
Router(config)#hostname router1

router1(config)#int fa8/0
router1(config-if)#ip address 192.168.0.1 255.255.255.224
router1(config-if)#ip nat inside
router1(config-if)#no shutdown

router1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet8/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet8/0, changed state to up

router1(config-if)#int fa7/0
router1(config-if)#ip address 192.168.0.33 255.255.255.240
router1(config-if)#ip nat inside
router1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet7/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet7/0, changed state to up

router1(config-if)#int se2/0
router1(config-if)#ip address 201.224.1.1 255.255.255.0
router1(config-if)#clock rate 56000
router1(config-if)#bandwidth 56
router1(config-if)#ip nat outside
router1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial2/0, changed state to up

router1(config-if)#int fa1/0
router1(config-if)#ip address 192.168.0.49 255.255.255.240
router1(config-if)#ip nat inside
router1(config-if)#no shutdown

router1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0, changed state to up

router1(config-if)#int fa6/0
router1(config-if)#ip address 192.168.0.65 255.255.255.248
router1(config-if)#ip nat inside
router1(config-if)#no shutdown

router1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet6/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet6/0, changed state to up

router1(config-if)#int fa0/0
router1(config-if)#ip address 192.168.0.73 255.255.255.248
router1(config-if)#ip nat inside
router1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

router1(config-if)#exit
router1(config)#ip route 201.224.2.0 255.255.255.0 se2/0
router1(config)#ip host router1 192.168.0.1 192.168.0.33 192.168.0.49
router1(config)#line con 0
router1(config-line)#login
% Login disabled on line 0, until 'password' is set
router1(config-line)#password cisco
router1(config-line)#line vty 0 5
router1(config-line)#login
% Login disabled on line 66, until 'password' is set
% Login disabled on line 67, until 'password' is set
% Login disabled on line 68, until 'password' is set
% Login disabled on line 69, until 'password' is set
% Login disabled on line 70, until 'password' is set
% Login disabled on line 71, until 'password' is set
router1(config-line)#password cisco
router1(config-line)#exit
router1(config)#access-list 100 remark standard
router1(config)#access-list 100 permit ip 192.168.0.0 0.0.0.255 any
router1(config)#ip nat inside source list 100 interface se2/0 overload
 
router1(config)#exit
router1#

[IMG]http://i57.tinypic.com/2jal2cy.jpg[/IMG]

http://tinypic.com/r/2jal2cy/8

 

Everyone's tags (2)
1 REPLY
New Member

Dear Dazasingh,Did you set

Dear Dazasingh,

Did you set reverse route for 201.224.1.1 at Web server and remoter router. ICMP or other IP packet need reverse route to reach back to source address.

 

Don't forget to rate helpful posts

Sajid Ali Pathan

189
Views
0
Helpful
1
Replies
CreatePlease login to create content