cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
404
Views
0
Helpful
3
Replies

DDR Backup WIC-1AM 1750

bobd
Level 1
Level 1

Whenever I activate my DDR line it connects just fine until I try to send traffic across it. Then it disconnects the line. Config and debug below - any help would be appreciated.

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname MONTGOMERY

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication login NO_AUTHEN none

aaa authentication ppp default local

aaa session-id common

enable secret xxxx

!

username JSSB-MAIN password xxxx

username admin password xxxx

memory-size iomem 20

ip subnet-zero

!

!

!

!

chat-script backup "" "AT" TIMEOUT 30 OK "ATDT 1111111" TIMEOUT 30 CONNECT \c

!

crypto isakmp policy 1

authentication pre-share

crypto isakmp key xxxx address 0.0.0.0 0.0.0.0

!

!

crypto ipsec transform-set AllNets esp-3des esp-md5-hmac

!

crypto map mymap 10 ipsec-isakmp

set peer 10.1.0.29

set transform-set AllNets

match address 101

!

!

!

!

interface FastEthernet0/0

ip address 10.1.70.1 255.255.255.0

ip helper-address 10.1.1.10

speed auto

full-duplex

!

interface Serial0/0

no ip address

encapsulation frame-relay

no fair-queue

!

interface Serial0/0.100 point-to-point

ip address 10.1.0.30 255.255.255.252

frame-relay interface-dlci 100

crypto map mymap

!

interface Async2

ip address 10.1.4.70 255.255.255.0

encapsulation ppp

dialer in-band

dialer idle-timeout 60

dialer map ip 10.1.1.0 name MONTGOMERY broadcast 1111111

dialer map ip 10.1.4.1 name MONTGOMERY broadcast 1111111

dialer watch-group 1

dialer-group 1

async mode dedicated

ppp authentication chap

ppp chap hostname MONTGOMERY

ppp chap password 7 0307595C530B734649510B5245

!

router eigrp 100

network 10.0.0.0

auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.0.29

ip route 0.0.0.0 0.0.0.0 Async2 250

no ip http server

ip pim bidir-enable

!

!

access-list 101 permit ip 10.1.70.0 0.0.0.255 10.1.1.0 0.0.0.255

access-list 102 deny eigrp any any

access-list 102 permit ip any any

dialer watch-list 1 ip 10.1.1.0 255.255.255.0

dialer watch-list 1 delay connect 1

dialer watch-list 1 delay disconnect 60

dialer-list 1 protocol ip list 102

!

radius-server retransmit 3

radius-server authorization permit missing Service-Type

!

line con 0

password 7 xxxx

line 2

flush-at-activation

script dialer backup

modem InOut

transport input all

autoselect ppp

stopbits 1

speed 115200

flowcontrol hardware

line aux 0

password 7 xxxx

line vty 0 4

password 7 xxxx

line vty 5 15

password 7 xxxx

!

end

DEBUG:

MONTGOMERY#ping 10.1.4.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.4.1, timeout is 2 seconds:

3w4d: As2 DDR: Dialing cause ip (s=10.1.4.70, d=10.1.4.1)

3w4d: As2 DDR: Attempting to dial 1111111

3w4d: CHAT2: Attempting async line dialer script

3w4d: CHAT2: Dialing using Modem script: backup & System script: none

3w4d: CHAT2: process started

3w4d: CHAT2: Asserting DTR

3w4d: CHAT2: Chat script backup started.....

Success rate is 0 percent (0/5)

MONTGOMERY#

3w4d: CHAT2: Chat script backup finished, status = Success

3w4d: %LINK-3-UPDOWN: Interface Async2, changed state to up

MONTGOMERY#

3w4d: As2 DDR: Dialer statechange to up

3w4d: As2 DDR: Dialer call has been placed

3w4d: As2 DDR: Remote name for JSSB-MAIN

3w4d: As2 DDR: Authenticated host JSSB-MAIN with no matching dialer map

3w4d: As2 DDR: dialer protocol up

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async2, changed state to u

p

MONTGOMERY#ping 10.1.4.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.4.1, timeout is 2 seconds:

3w4d: As2 DDR: No free dialer - starting fast idle timer

3w4d: As2 DDR: starting fast idle timer 13808 ticks.

3w4d: As2 DDR: No free dialer - starting fast idle timer.

3w4d: As2 DDR: No free dialer - starting fast idle timer.

3w4d: As2 DDR: No free dialer - starting fast idle timer.

3w4d: As2 DDR: No free dialer - starting fast idle timer.

Success rate is 0 percent (0/5)

MONTGOMERY#ping 10.1.4.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.4.1, timeout is 2 seconds:

3w4d: As2 DDR: No free dialer - starting fast idle timer

3w4d: As2 DDR: fast idle timeout

3w4d: As2 DDR: disconnecting call.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 8/10/12 ms

MONTGOMERY#

3w4d: %LINK-5-CHANGED: Interface Async2, changed state to reset

3w4d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async2, changed state to d

ownpin

3w4d: %LINK-3-UPDOWN: Interface Async2, changed state to dow

3w4d: As2 DDR: re-enable timeout

3w4d: DDR: Dialer Watch: watch-group = 1

3w4d: DDR: network 10.1.1.0/255.255.255.0 UP,

3w4d: DDR: primary

1 Accepted Solution

Accepted Solutions

tepatel
Cisco Employee
Cisco Employee

The problem is with the dialer map..In the dialer map you need to configure the ip address and the exact name of the host receiving the call..

In your config the hostname MONTGOMERY belongs to the router dialing out..and hostname JSSB-MAIN belongs to router which is receiving the call.

as per the debug line

3w4d: As2 DDR: Remote name for JSSB-MAIN

3w4d: As2 DDR: Authenticated host JSSB-MAIN with no matching dialer map

So on this MONTGOMERY router the dialer map should look like this

dialer map ip 10.1.4.1 name JSSB-MAIN broadcast 1111111

So once you will change the dialermap, it will work fine.

View solution in original post

3 Replies 3

tepatel
Cisco Employee
Cisco Employee

The problem is with the dialer map..In the dialer map you need to configure the ip address and the exact name of the host receiving the call..

In your config the hostname MONTGOMERY belongs to the router dialing out..and hostname JSSB-MAIN belongs to router which is receiving the call.

as per the debug line

3w4d: As2 DDR: Remote name for JSSB-MAIN

3w4d: As2 DDR: Authenticated host JSSB-MAIN with no matching dialer map

So on this MONTGOMERY router the dialer map should look like this

dialer map ip 10.1.4.1 name JSSB-MAIN broadcast 1111111

So once you will change the dialermap, it will work fine.

Does this work differently for an async than an ISDN connection? I've got a very similar config using ISDN as opposed to the ASYNC, and it works perfectly. The BRI in the router config listed below is dialing into a PRI on the same router that MONTGOMERY is attempting to access on a WIC-2AM without any problems.

interface BRI1/0

ip address 10.1.2.10 255.255.255.0

encapsulation ppp

dialer map ip 10.1.1.0 name DUBOISTOWN broadcast 1111111

dialer map ip 10.1.2.1 name DUBOISTOWN broadcast 1111111

dialer load-threshold 1 outbound

dialer watch-group 1

dialer-group 1

isdn switch-type basic-ni

isdn spid1 11111110101

isdn spid2 11111110101

ppp authentication chap

ppp chap hostname DUBOISTOWN

ppp chap password xxxx

ppp multilink

This worked just fine. I had a second problem as well, and that was the chat script was timing out too soon. I increased the timeout from 30 to 60 seconds and everything worked great. Thanks for the reply.

Bob