Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Cisco Employee

DDR Dialer Profiles idle-timeout not getting reset

Basically, this router connects to the Internet, and a private corporate network. It brings up links correctly, and routes traffic correctly, even NAT seems to work just fine.

My problem is that when the dialer idle-timeout expires, it hangs up. Interesting traffic (while being routed properly) does not reset this timer and keep the link up. So it goes up and down and up and down... in this case, every 300 secs.

It is an 804, with 12.2(6) IOS. I was running 12.0 but upgraded just in case this was a bug. I am completely open to not using route-maps if that is the problem, however I was unable to get it to work without them when I initially set this up--with open access lists it seemed unable to figure out where to route traffic (at one point it was using the Dialer1 internet address to try to access the Dialer2 private network... that didn't work well at all).

I'm stumped.

Here's the config.

homenet_isdn#sh run

Building configuration...

Current configuration : 2830 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname homenet_isdn

!

boot system flash c800-y6-mw.122-6.bin

boot system flash

enable secret 5 **********************

enable password ****

!

!

ip subnet-zero

!

isdn switch-type basic-ni

!

!

!

interface Ethernet0

ip address 10.0.0.1 255.255.255.0

ip access-group 110 in

ip nat inside

no ip route-cache

fair-queue

no cdp enable

!

interface BRI0

no ip address

ip nat outside

encapsulation ppp

no ip route-cache

dialer pool-member 1

isdn switch-type basic-ni

isdn spid1 *********

isdn spid2 *********

isdn incoming-voice modem

no cdp enable

ppp authentication pap callin

ppp multilink

!

interface Dialer1

description Internet - Verizon

ip address negotiated

ip nat outside

encapsulation ppp

no ip route-cache

dialer pool 1

dialer idle-timeout 300 either

dialer string ****************

dialer load-threshold 120 either

dialer-group 1

fair-queue

no cdp enable

ppp authentication pap callin

ppp pap sent-username ******* password 7 ***************

ppp multilink

!

interface Dialer2

description *************

ip address negotiated

ip nat outside

encapsulation ppp

no ip route-cache

shutdown

dialer pool 1

dialer idle-timeout 300

dialer string ***************

dialer load-threshold 120 either

dialer-group 2

fair-queue

no cdp enable

ppp authentication chap callin

ppp chap hostname ntdomain\username

ppp chap password 7 **************

ppp multilink

!

ip nat inside source route-map private interface Dialer2 overload

ip nat inside source route-map internet interface Dialer1 overload

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 167.230.0.0 255.255.0.0 Dialer2

ip route 172.21.0.0 255.255.0.0 Dialer2

ip route 192.168.1.0 255.255.255.0 Null0

!

logging trap debugging

logging facility syslog

logging 10.0.0.3

access-list 3 permit 10.0.0.0 0.0.0.255

access-list 101 deny ip 10.0.0.0 0.0.0.255 172.21.0.0 0.0.255.255

access-list 101 deny ip 10.0.0.0 0.0.0.255 167.230.0.0 0.0.255.255

access-list 101 permit ip 10.0.0.0 0.0.0.255 any

access-list 102 permit ip 10.0.0.0 0.0.0.255 172.21.0.0 0.0.255.255

access-list 102 permit ip 10.0.0.0 0.0.0.255 167.230.0.0 0.0.255.255

access-list 110 deny udp any any eq netbios-ns

access-list 110 deny udp any any eq netbios-dgm

access-list 110 deny udp any any eq netbios-ss

access-list 110 permit ip any any

dialer-list 1 protocol ip list 101

dialer-list 2 protocol ip list 102

no cdp run

route-map internet permit 10

match ip address 101

match interface Dialer1

!

route-map private permit 10

match ip address 102

match interface Dialer2

!

!

line con 0

stopbits 1

line vty 0 4

access-class 3 in

password **********

login

!

!

end

homenet_isdn#

1 REPLY

Re: DDR Dialer Profiles idle-timeout not getting reset

Often times complex troubleshooting issues are best addressed in an interactive trouble-shooting session with one of our trained technical assistance engineers. While other forum users may be able to help, it’s often difficult to do so for this type of issue.

To utilize the resources at our Technical Assistance Center, please visit http://www.cisco.com/tac and to open a case with one of our TAC engineers, visit http://www.cisco.com/tac/caseopen

If anyone else in the forum has some advice, please reply to this thread.

Thank you for posting.

120
Views
0
Helpful
1
Replies
CreatePlease to create content