Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DDR problems

Hope someone can help, I am having problems getting DDR to work. The config is below. I have run a number of checks and if the link is lifted manually all routing etc works perfectly. If i make the specfic call that should cause the link to be lifted DEBUG DIALER PACKETS, shows IP PERMIT but nothing happens. DEBUG ISDN or BRI0 etc show no activity. The boxes (1721's)contain two frame relay links that are used to connect to HQ however for one app I want to use ISDN because of latency & cost issues. For the ip address of the server involved I have put in a static route using the ISDN link. Suggestions on whats wrong would help. I have two routers behaving this way so I think hardware is not a problem.

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname type

!

enable secret 5 $1$D6TA$ODOpnBPZMN8pqt/ir3HXK/

enable password cisco1

!

username INVER password 0 ********

ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-net3

!

!

!

interface Loopback0

ip address 42.42.42.42 255.255.255.255

!

interface BRI0

description ISDN interface

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

interface FastEthernet0

description LAN interface

ip address 57.42.31.1 255.255.128.0

speed auto

half-duplex

no cdp enable

!

interface Serial0

description Frame relay main interface

no ip address

ip helper-address 57.200.127.255

ip directed-broadcast

encapsulation frame-relay

no fair-queue

frame-relay lmi-type ansi

!

interface Serial0.16 point-to-point

description Backup PVC to HQ

bandwidth 256

ip address 57.5.42.129 255.255.255.128

ip directed-broadcast

ip ospf authentication-key cisco

ip ospf cost 4000

no cdp enable

frame-relay class data

frame-relay interface-dlci 16

frame-relay payload-compression packet-by-packet

!

interface Serial0.17 point-to-point

description Primary link to longman

bandwidth 256

ip address 57.5.42.1 255.255.255.128

ip directed-broadcast

ip ospf authentication-key cisco

no cdp enable

frame-relay class data

frame-relay interface-dlci 17

frame-relay payload-compression packet-by-packet

!

interface Dialer1

ip address 57.3.11.2 255.255.255.128

encapsulation ppp

dialer pool 1

dialer remote-name INVER

dialer string 01953714050

dialer-group 1

no cdp enable

ppp authentication chap

ppp chap hostname I_type

ppp chap password 7 0452180201791B5C0616

!

router ospf 100

log-adjacency-changes

area 0.0.0.42 authentication

area 0.0.0.42 stub

area 0.0.0.100 authentication

area 0.0.0.100 nssa

redistribute connected metric 2000 metric-type 1 subnets

network 57.5.42.1 0.0.0.0 area 0.0.0.42

network 57.5.42.129 0.0.0.0 area 0.0.0.100

network 57.42.31.1 0.0.0.0 area 0.0.0.42

!

ip classless

ip route 57.200.4.18 255.255.255.255 57.3.11.1

no ip http server

!

!

!

map-class frame-relay data

no frame-relay adaptive-shaping

frame-relay cir 192000

frame-relay bc 192000

frame-relay be 64000

frame-relay mincir 192000

access-list 101 permit ip any any

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx deny

no cdp run

snmp-server community public RO

snmp-server community private RW

snmp-server host 57.200.91.65 private

!

!

no scheduler allocate

end

13 REPLIES

Re: DDR problems

You did not specify the next hop for 57.3.11.1. With DDR this is a required step. The fact that int di1 is in the same subnet is not relevant in this case. Add a route to 57.3.11.1 like this:

ip route 57.3.11.1 255.255.255.255 dialer1

This will probably make some difference. I did not check the config extensively enough to state that this is the only issue. It will help you one step further though.

Regards,

Leo

New Member

Re: DDR problems

Leo,

The next hop address i.e. the other end of the isdn link is 57.3.11.1 I however tried your suggestion but unfortunately it didn't work. I also tried altering the ip route statement to

ip route 57.200.4.18 255.255.255.255 dialer1

this didn't work either.

I have included the output of the debug commands below, firstly as is and secondly the result of the link being brought up from the far end.

type#sh debug

Dial on demand:

Dial on demand events debugging is on

Dial on demand packets debugging is on

PPP:

PPP authentication debugging is on

PPP protocol negotiation debugging is on

ISDN:

ISDN events debugging is on

ISDN Q931 packets debugging is on

ISDN events debug DSLs. (On/Off/No DSL:1/0/-)

DSL 0 --> 31

1 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)

DSL 0 --> 31

1 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

type#ping 57.200.4.18

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 57.200.4.18, timeout is 2 seconds:

02:41:52: Di1 DDR: ip (s=57.3.11.2, d=57.200.4.18), 100 bytes, outgoing interest

ing (ip PERMIT).

02:41:54: Di1 DDR: ip (s=57.3.11.2, d=57.200.4.18), 100 bytes, outgoing interest

ing (ip PERMIT).

02:41:56: Di1 DDR: ip (s=57.3.11.2, d=57.200.4.18), 100 bytes, outgoing interest

ing (ip PERMIT).

02:41:58: Di1 DDR: ip (s=57.3.11.2, d=57.200.4.18), 100 bytes, outgoing interest

ing (ip PERMIT).

02:42:00: Di1 DDR: ip (s=57.3.11.2, d=57.200.4.18), 100 bytes, outgoing interest

ing (ip PERMIT).

Success rate is 0 percent (0/5)

type#

*************************************************************************

This is a what happens when the link is lifted manually from the other end

*************************************************************************

type#

02:44:176093659135: CCBRI_Go Fr L3 pkt (Len=25) :

02:44:171798691840: 5 1 81 90 A1 4 2 88 90 18 1 89 70 7 81 36 30 35 34 32 31 7C

2 88 90

02:44:171798691840:

02:44:171798691840: ISDN BR0: Incoming call id = 0x0002, dsl 0

02:44:176093659135: ISDN BR0: LIF_EVENT: ces/callid 1/0x2 HOST_INCOMING_CALL

02:44:171798691840: ISDN BR0: HOST_INCOMING_CALL: (non-POTS) DATA

02:44:171798691840: ISDN BR0: HOST_INCOMING_CALL: (1) call_type = DATA

02:44:171798691840: ISDN BR0: llc valid, speed 64, call type is DATA

speed:0 async:N

02:44:171798691840: ISDN BR0: HOST_INCOMING_CALL: voice_answer_data = FALSE call

type is DATA

02:44:171798691840: ISDN BR0: Event: Received a DATA call from on B1 a

t 64 Kb/s

02:44:171798691840: ISDN BR0: Event: Accepting the call id 0x2

02:44:176093659135: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1

02:44:176093659135: ISDN BR0: RM returned call_type 0 resource type 0 response 2

02:44:172607289908: CCBRI_Go Fr Host InPkgInfo (Len=9) :

02:44:171798691840: 7 0 1 0 2 3 18 1 89

02:44:171798691840:

02:44:176093659135: SAM: NULL_STATE to DL_IDLE_STATE. ev=57

02:44:40: ISDN BR0: isdn_send_connect(): msg 4, call id 0x2, ces 1 bchan 0, call

type DATA

02:44:40: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up

02:44:40: ISDN: get_isdn_service_state(): idb 0x80E95B24 bchan 2 is_isdn 1 Not a

Pri

02:44:171798691840: CCBRI_Go Fr Host InPkgInfo (Len=6) :

02:44:171798691840: 4 0 1 0 2 0

02:44:171798691840:

02:44:176093659136: CCBRI_Go Fr L3 pkt (Len=4) :

02:44:176093659136: F 1 81 92

02:44:176093659136:

02:44:178254754852: ISDN BR0: LIF_EVENT: ces/callid 1/0x2 HOST_CONNECT

02:44:176093659136: ISDN BR0: Event: Connected to on B1 at 64 Kb/s

02:44:41: Di1 IPCP: Install route to 57.3.11.1

02:44:42: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1, changed state

to up

02:44:46: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 01463 INVER

type#ping 57.200.4.18

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 57.200.4.18, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 40/41/44 ms

type#

02:45:55: Di1 DDR: ip (s=57.3.11.2, d=57.200.4.18), 100 bytes, outgoing interest

ing (ip PERMIT)

02:45:55: Di1 DDR: ip (s=57.3.11.2, d=57.200.4.18), 100 bytes, outgoing interest

ing (ip PERMIT)

02:45:55: Di1 DDR: ip (s=57.3.11.2, d=57.200.4.18), 100 bytes, outgoing interest

ing (ip PERMIT)

02:45:55: Di1 DDR: ip (s=57.3.11.2, d=57.200.4.18), 100 bytes, outgoing interest

ing (ip PERMIT)

02:45:55: Di1 DDR: ip (s=57.3.11.2, d=57.200.4.18), 100 bytes, outgoing interest

ing (ip PERMIT)

type#

Silver

Re: DDR problems

Tom

What is the next hop across the dialer ?

You should be able to ping this no problem assuming you are on the same subnet .

Can you paste in debug dialer , debug ppp neg debug ppp auth , sh isdn st

Bronze

Re: DDR problems

What "specific call" are you making to try to make it call? You should be pinging the other side. I dont think the route statement is needed.

New Member

Re: DDR problems

The specific call is to 57.200.4.18 via 57.3.11.1 rather than the 57.5.42.2 on serial1/0.17 in the config. I am trying to test the link with a ping to 57.200.4.18 the results of which I've included in my answer to Leo above.

Tom

New Member

Re: DDR problems

deilert,

I have pasted the debug output in my answer to Leo, also the next hop address is 57.3.11.1.

Tom

Silver

Re: DDR problems

Tom what does the config on the remote end look like ?

New Member

Re: DDR problems

The remote end is actually a 3com NetbuilderII, however if I lift the call the link performs perfectly. The output of the debug seems to me to be saying that the DDR config is failing to lift the link or even attempting it. Any idea on how I can investigate further ?

Tom

Silver

Re: DDR problems

Tom

Is this in the US ?

If it is configure your dialer to dial your second spid as a dialer string see if it connects

New Member

Re: DDR problems

The network is spread over the north of scotland. We are not required to set spid's on isdn.

Tom

Silver

Re: DDR problems

I think I know what the problem is

when you do a sh int di 1 is the interface up (spoofing) up (spoofing) ?

If no add the command 'dialer in-band'

This will allow the dialer to go up (spoofing) up (spoofing) your router never dials out because a router will never route a packet out a down interface

New Member

Re: DDR problems

sorry the interface dialer1 is up and spoofing

Tom

New Member

Re: DDR problems

If anyone is interested I got the solution eventually, it is a software problem. I replaced the code version with 12.3 and it now works with exactly the same config.

the version of code I was using is 12.2(4)YA2 system image file c1700-y7-mz.122-4.bin

i.e. don't use this version to do DDR over isdn.

Tom

117
Views
0
Helpful
13
Replies