Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

debug isdn q931 errors !!!

HI All ,

I have a situtation here , IM trying to dial in from a remote site with

a cisco 801 into a cisco 2610 which has 4 port modular slot.

But am facint typical problems which IM sure some one would have come

accross , but if some one could kindly give me that clue.

Since the call from 801 to 2610 failed I tried calling from 801 to 801

but again no success , I ran a debug of isdn q931 and got the followng

results , could you please explain what is the meaning of

"destination barred " is it that the nuber im dialing cannot be dialed

from the router as that is a number of another location and

requires 06 prefix to be added , and also " destination out of order"

cisco also goes on to say that this could mean the rotuer is switched

off , but the router is very much on and the show ISDN status of the

ISDN shows the ISDN up and Active , but it still does not receive calls.

Is the ISDN line which is the problem R is the cisco 2610 R is the Module

R could it be the configuration........

Your input in this regard will be highly appreciated ,

Thanx in advance.

Tauseef.

Network support Engineer

<A HREF="mailto:tauseef@cadgulf.com">tauseef@cadgulf.com</A>

when 801 calls another 801 the call is not established but get the

following error on the debug isdn q931 on the router that dials

in .....

00:08:08: CC_CHAN_GetIdleChanbri: dsl 0

00:08:08: Found idle channel B1

00:08:08: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 93 changed to up

00:08:08: ISDN BR0: TX -> SETUP pd = 8 callref = 0x07

00:08:08: Bearer Capability i = 0x8890

00:08:08: Channel ID i = 0x83

00:08:08: Called Party Number i = 0x80, '065339165', Plan:Unknown, Type:

Unknown

00:08:08: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0x87

00:08:08: Cause i = 0x8295 - Call rejected

00:08:09: Display i = 'DESTINATION', 0x202020202020, 'BARRED'

00:08:09: CCBRI_Go Fr L3 pkt (Len=33) :

00:08:09: 5A 1 7 99 8 2 82 95 28 17 44 45 53 54 49 4E 41 54 49 4F 4E 20 20 20 20

20 20 42 41 52 52 45 44

00:08:09:

00:08:09: ISDN BR0: LIF_EVENT: ces/callid 1/0x8007 HOST_DISCONNECT_ACK

00:08:09: ISDN BR0: Error: Unfound B-channel on Disconnect_Ack - callid 0x8007

00:08:09: ISDN BR0: HOST_DISC_ACK Voice cid 0x8007 error no table entry to free.

....

Success rate is 0 percent (0/5)

when the 801 dials a 2610 router with N/M module ( isdn 4 port s/t )

module the call is not established and the debug isdn q931 gives the

following error.This debug is carried out on the rotuer that dials

in ....

But the show isdn status shows the ISDN line active.

08:14:59: ISDN BR0: TX -> SETUP pd = 8 callref = 0x0B

08:14:59: Bearer Capability i = 0x8890

08:14:59: Channel ID i = 0x83

08:14:59: Called Party Number i = 0x80, '037212846', Plan:Unknown, Type:

Unknown

08:14:59: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x8B

08:14:59: Channel ID i = 0x89

08:14:59: CCBRI_Go Fr L3 pkt (Len=7) :

08:14:59: 2 1 B 98 18 1 89

08:14:59:

08:14:59: ISDN BR0: LIF_EVENT: ces/callid 1/0x800B HOST_PROCEEDING

08:15:00: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x8B

08:15:00: Cause i = 0x849B - Destination out of order

08:15:00: CCBRI_Go Fr L3 pkt (Len=8) :

08:15:00: 45 1 B 96 8 2 84 9B

08:15:00:

08:15:00: ISDN BR0: LIF_EVENT: ces/callid 1/0x800B HOST_DISCONNECT

08:15:00: ISDN BR0: Event: Call to 037212846 was hung up.

08:15:00: ISDN BR0: process_disc_ack(): call id 0x800B, ces 1, call type DATA

08:15:00: ISDN: get_isdn_service_state(): idb 0x27A51AC bchan 2 is_isdn 1 Not a

Pri

08:15:00: CCBRI_Go Fr Host InPkgInfo (Len=10)

THE CONFIGURATION FOR THE ROUTERS ARE AS FOLLOWS :

2610 ROUTER

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname Alain

!

enable password gulf

username sharjha password gulf

username abudhabi password gulf

!

no ip name-server

!

isdn switch-type basic-net3

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Dialer 1

description connected to sharjha

ip address 192.168.100.2 255.255.255.252

no ip split-horizon

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer hold-queue 10

dialer map snapshot 1 name sharjha broadcast 065339165

dialer map ip 192.168.100.1 name sharjha speed 64 broadcast 065339165

dialer-group 1

ppp authentication chap

no ppp multilink

snapshot client 15 360 suppress-statechange-update dialer

no cdp enable

!

interface Dialer 2

description connected to abudhabi

ip address 192.168.110.2 255.255.255.252

no ip split-horizon

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer hold-queue 10

dialer map snapshot 1 name abudhabi broadcast 026131924

dialer map ip 192.168.110.1 name abudhabi speed 64 broadcast 026131924

dialer-group 1

ppp authentication chap

no ppp multilink

snapshot client 15 360 suppress-statechange-update dialer

no cdp enable

!

interface Ethernet 0/0

no shutdown

description connected to EthernetLAN

ip address 192.168.0.250 255.255.255.0

keepalive 10

!

interface BRI 1/0

no shutdown

description connected to sharjha

no ip address

dialer rotary-group 1

!

interface BRI 1/1

no shutdown

description connected to abudhabi

no ip address

dialer rotary-group 2

!

interface BRI 1/2

no description

no ip address

shutdown

!

interface BRI 1/3

no description

no ip address

shutdown

!

! Dialer Control List 1

!

no dialer-list 1

dialer-list 1 protocol ip permit

!

router rip

version 2

network 192.168.100.0

network 192.168.110.0

network 192.168.0.0

no auto-summary

!

!

ip classless

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password gulf

login

!

line vty 0 4

password gulf

login

!

end

801 ROUTER

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname sharjha

!

enable password gulf

username Alain password gulf

!

no ip name-server

!

isdn switch-type basic-net3

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Dialer 1

description connected to Alain

ip address 192.168.100.1 255.255.255.252

no ip split-horizon

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer hold-queue 10

dialer map snapshot 1 name Alain broadcast

dialer map ip 192.168.100.2 name Alain speed 64 broadcast 037212846

dialer-group 1

ppp authentication chap

no ppp multilink

snapshot server 15 dialer

no cdp enable

!

interface Ethernet 0

no shutdown

description connected to EthernetLAN_1

ip address 192.168.1.250 255.255.255.0

keepalive 10

!

interface BRI 0

no shutdown

description connected to Alain

no ip address

dialer rotary-group 1

!

! Dialer Control List 1

!

no dialer-list 1

dialer-list 1 protocol ip permit

!

router rip

version 2

network 192.168.100.0

network 192.168.1.0

no auto-summary

!

!

ip classless

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password gulf

login

!

line vty 0 4

password gulf

login

!

end

4 REPLIES
New Member

Re: debug isdn q931 errors !!!

When debugging isdn Q93 look at the cause codes they will tell you what you need to know as far as switch output debugs are concerned for example take your first set of debugs

00:08:08: Cause i = 0x8295 - Call rejected

00:08:09: Display i = 'DESTINATION', 0x202020202020, 'BARRED'

0x82 means that the Local Telco switch is the message sender

95 means that the local telco switch is not wanting to accept this call.

I am not familiar with your dialing scheme but you may wanna try and see if the spids are set up for long distance calling if it is not you will have to do this.

also your dialing format may be incorrect make sure that 065339165 is correct you may need to change this up a bit.

also try doing some force dials from the 2600 and see if you can connect backwords.

Cisco Employee

Re: debug isdn q931 errors !!!

From 801 to 801 call, q931 reports "call rejected" with cause code "0x8295" where

82: From the public network near the local user (local telco switch).

95:call rejected..

For more information in "isdn q931 cause codes" visit

http://www.cisco.com/warp/public/129/isdn_disc_code.html

So talk to local BRI provider about that..

Now for 801 to 2610:::First of all we need to know "sh isdn status" at 2610 side. Since you have S/T port at 2610 for BRI, make sure that you have external NT1 box as well for bri line..

When 801 calls 2610, did call show up on 2610??

also get the "debug isdn q931" debug along with "sh isdn stat" on 2610.

Thx..Tejal

New Member

Re: debug isdn q931 errors !!!

Hello,

From TEI number given by the NT (TEI 93) , that's tell me that you are not connected directly to the ISP. I guess that there is a PABX inbetween.

THe error reported is from the Local Side as already mentionned above and PABX got table filtering option, which forbiden the number dialed.

I suggest you first to check with PABX team. and next to use a Phone set and try to ring the remote Phone. You will get quite the same message (most probably busy tone). Try an other site if possible.

Even if you start Debug on remote site, you will see nothing. Call is rejected locally.

Hope this help.

Rgds Patrick

New Member

Re: debug isdn q931 errors !!!

Thankyou all for the effort in helping me out , well frakly i am yet to try out these things as the site is a little far from my place well , will hopefully work Iinsha Allah.thanx .

Tauseef

1444
Views
0
Helpful
4
Replies
CreatePlease to create content