Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP and rate limiting

Does anyone know a way to configure a 2950 switch or 2811 so that the DHCP server assign's the same address to a port regardless of who plugs in.

Also is it possible to configure rate limiting by vlan # into a router interface?

Thanks a ton

--Steve

8 REPLIES
Purple

Re: DHCP and rate limiting

Hi Steve,

I don't believe that you can configure a DHCP server in such a way. You can have static MAC address to IP address mappings, though...

The 2950 cannot do per-vlan policing. In fact, you cannot do any sort of policing on egress. It also does not support shaping.

You can, however, apply ingress policing on a per-VLAN basis on the router interface.

Hope that helps - pls rate the post if it does.

Re: DHCP and rate limiting

Hello Steve,

The rate limit per VLAN can be achieved by

policy-map RateLimit1

class class-default

police 100000

policy-map RateLimit2

class class-default

police 50000

interface FastEthernet0/0.100

ip address ...

encapsulation dot1Q 100

service-policy output RateLimit1

service-policy input RateLimit2

So you can apply te same rate to in and out direction or you can have different rates. As an alternative you can use a shaper (shape 100000), which will queue packets, whereas a policer will either let them pass or drops them.

Regarding DHCP:

ip dhcp excluded-address 192.168.1.1 192.168.1.253

ip dhcp pool OneIP

network 192.168.1.0 255.255.255.0

default router 192.168.1.1

dns 4.2.2.2

interface ethernet0

ip address 192.168.1.1 255.255.255.0

As you exclude all addresses but 192.168.1.254, this should fulfil your requirements.

Adjust IP addresses and interfaces, etc. to your environment.

Hope this helps! Please rate all posts.

Regards, Martin

New Member

Re: DHCP and rate limiting

Thanks for your help, I did a little checking and discovered i can create sub classes with % bandwidth assigned to them.

The % guanrtee's avaibility if i under stand it right. So if say the T1 is maxed I could dedicate 50% to the dorm, 25% to the mailserver/web server and 25% to faculty.

ex

Policy map building_1

class students

bandwidth percent 50

class professors

bendwidth percent 25

How would I assign these classes to a particular VLAN?

Would it be

Router(int)# service-policy output students ??

This way if no one is using the bandwith it's avil to other users. Trying to maxamize what we pay for

Thanks again

Steve

Purple

Re: DHCP and rate limiting

Hi Steve,

When applying queuing on a per-VLAN basis, you need to use a hierarchical policy. For example, if you wanted to limit traffic to VLAN 100 to 128k and within that 128k, you wanted to assign 50% to the dorm, 25% to the mail/web server and 25% to faculty, you would have to do the following:

policy-map building_1

class students

bandwidth percent 50

class professors

bandwidth percent 25

class servers

bandwidth percent 25

!

policy-map Shape128k

class class-default

shape average 128000

service-policy building_1

!

int fastethernet0.100

encapsulation dot1q 100

service-policy output Shape128k

Since you are queueing on a sub-interface (VLAN) basis, you need to create a parent policy that creates a shaping queue.

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: DHCP and rate limiting

Almost...

What I'm looking to do is divide up the full t1 accross the 3 vlans. So would it be possible to assign a different class to a vlan?

In effect giving 50% (at max usage) to the students vlan, 25% to the prof's vlan and so on...

Thanks again

Steve

Purple

Re: DHCP and rate limiting

Ok, I get you now...

As long as you have specific destination addresses in each VLAN that you can match on, you should be able to define a class for each using:

class-map students

match access-group 101

!

class-map professors

match access-group 102

!

class-map servers

match access-group 103

!

policy-map building_1

class students

bandwidth remaining percent 50

class professors

bandwidth remaining percent 25

class servers

bandwidth remaining percent 25

!

int fastethernet0 ! main interface

service-policy output building_1

!

access-list 101 permit ip any

access-list 102 permit ip any

access-list 103 permit ip any

(you can have multiple lines per ACL to cover all your networks)

Hope that helps - pls rate the post if it does.

Paresh

New Member

Re: DHCP and rate limiting

Paresh thanks again for helping

I think I almost understand it. So in my config i have 3 sub interfaces (one for each vlan).

int fa0/0

no ip address

service_policy output building_1

int fa0/0.1

ip address

.... and so on

Does the policy engine automatically marry those classes from the primary interface to the subs or do i have to apply it to each sub interface in turn?

Thanks again. It's hard to expriment now that the router has gone live..

--steve

New Member

Re: DHCP and rate limiting

Do you have cisco router configure book??There are many commands about cisco route.could you tell me your e-mail address??I will send one to you.

177
Views
0
Helpful
8
Replies
CreatePlease login to create content