Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DHCP and VLANS - not getting IP addresses

Hello

I have to 4507R's that are etherchanneled together and have the floowing VLANS on each

VLAN 2 - 10.104.0.0/23

VLAN 3 - 10.103.0.0/23

VLAN 4 - Voice - 10.110.0.0/23

VLAN 5 - Connected to 2691 10.0.255.0/23

VLAN 411 - Management - 10.110.2.0/23

Each also has the AGM -WS-X4604-GWY module in it and 1 48-port 10/100 module

I configured

interface GigabitEthernet6/1

switchport trunk native vlan 411

switchport mode trunk

!

interface Vlan1

no ip address

shutdown

!

interface Vlan2

ip address 10.103.0.2 255.255.254.0

no ip redirects

standby 2 ip 10.103.0.1

standby 2 priority 110

standby 2 preempt

!

interface Vlan3

ip address 10.104.0.2 255.255.254.0

no ip redirects

standby 3 ip 10.104.0.1

standby 3 preempt

!

interface Vlan4

ip address 10.110.0.18 255.255.254.0

no ip redirects

standby 4 ip 10.110.0.1

standby 4 priority 110

standby 4 preempt

!

interface Vlan411

ip address 10.110.2.2 255.255.255.0

standby 255 ip 10.110.2.1

standby 255 priority 100

standby 255 preempt

GW-1

interface FastEthernet0/0

no ip address

duplex auto

speed auto

arp timeout 600

!

interface GigabitEthernet0/0

ip address 10.110.2.4 255.255.254.0

no negotiation auto

standby 255 ip 10.110.2.1

standby 255 preempt

AGM is in GW mode but using external 2691 router to get back to main site

1. If I do not configure subinterfaces on the Gig interface I cannot get back to CCM or any other VLAN

2. If i configure th interface like this then I never get an IP address in the VLAN that it is supposed to pull from it pulls from the VOICE DHCP

interface FastEthernet5/7

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 2

switchport voice vlan 4

spanning-tree portfast

I am running the 12.2(13)EW image.

Can any help out on this and can someone with a great knowledge of 4507R's, spanning-tree, and a few more other questions talk to me sometime to see if I am doing this the proper way.

Thanks for your assistance.

Brian bhenry33@adelphia.net

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: DHCP and VLANS - not getting IP addresses

I believe that you had a TAC case open as well and i was helping out the case owner on this one. The call manager/DHCP server port needs to be an Access vLAN. We changed the port to access VLAN 4 and had you reboot the Call manager to purge the DHCP cache. Rebooting alone would not have fixed this issue.

6 REPLIES
New Member

Re: DHCP and VLANS - not getting IP addresses

Hi Brian,

I am not familiar with most of the stuff you are running, but I may have a tip on the dhcp ip address issue. On each router interface (vlan) you need to configure an "ip helper" address that points to a dhcp server, so the router can redirect dhcp discovers to the correct server - unless the dhcp server exists in the same vlan as the dhcp client.

Hope this helps,

Jeremy

New Member

Re: DHCP and VLANS - not getting IP addresses

Thanks for the response but I did have the IP-helper address in the VLAN's but it made no difference, for which they were in there all day today when I was trying to get it to work and even with Csico on the phone Tier 1 support.

If you have any other recommndations I am all ears and thanks again for the response

pxh
New Member

Re: DHCP and VLANS - not getting IP addresses

I think you need to have a ip helper-address command under each vlan interface

interface Vlan3

ip address 10.104.0.2 255.255.254.0

ip helper-address IP_address_of_DHCP_server

no ip redirects

standby 3 ip 10.104.0.1

standby 3 preempt

New Member

Re: DHCP and VLANS - not getting IP addresses

The configs that were posted wer a little miss leading trying to type what was in the configs and missed a few lines, but the IP helper was in there but made no difference of pointing to the server dirreclty or using the broadcast addresss for the subnet that it sat on.

The fix is below

Thanks to all but it has been fixed by, you won't believe it, a reboot of the DHCP server which the service sits on the publisher CCM.

Who says that a reboot isn't good every once in awhile.

Thanks to all that responded!

Cisco Employee

Re: DHCP and VLANS - not getting IP addresses

I believe that you had a TAC case open as well and i was helping out the case owner on this one. The call manager/DHCP server port needs to be an Access vLAN. We changed the port to access VLAN 4 and had you reboot the Call manager to purge the DHCP cache. Rebooting alone would not have fixed this issue.

New Member

Re: DHCP and VLANS - not getting IP addresses

Sorry for the miss information but I thought that is was already an access VLAN, my bust. I do believe that the final config for that port for which the CCM/DHCP sat on looks like this.

If all it needs to have is the access command and the spanning-tree I will remove this am when I get in.

switchport access vlan 4

switchport trunk encapsulation dit1q

switchport mode trunk

spanning-tree portfast

spanning-tree guard root

Thanks for corecting me, trying to remember everything we tried and did after going out and having a few didn't mix.

Thanks again for everyones help!

B

537
Views
0
Helpful
6
Replies
CreatePlease to create content