Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DHCP and VLANS on 4507R - Help!

Does any know why on a 4507R with a 48 port inline power module that I have the following problem.

VLAN 2 - Data 1

VLAN 3 - Data 2

VLAN 4 - Voice

VLAN 5 - One subnet point to FE0/0 on 2691

VLAN 411 - Management

I have the switch ports configured just as you would a 3524 or 2550 but when the pc request an address it gets it from the Voice DHCP pool.

The DHCP server sits on the Voice VLAN.

Interface FastEthernet 5/47

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 2

switchport voice vlan 4

spanning-tree portfast

If I configure the port as an access port on the interface I can get an address from the appropriate pool? huh?

interface FastEthernet 5/46

switchport mode access

switchport access vlan 2

spanning-tree portfast

There are 2 4507R's linked together for the core through the uplinks and they are in an etherchannel.

If anyone would like to see the entire design and configs to help me solve this one I would greatly appreciate it and you can e-mail me at bhenry33@adelphia.net

Thanks for whomever can figure out this one :)

Brian

4 REPLIES
New Member

Re: DHCP and VLANS on 4507R - Help!

try the voice VLAN configuration without the trunking commands (switchport trunk encapsulation dot1q;

switchport mode trunk). voice VLAN should work without these automatically. trunking configuration was only required on 29/3500XL family, current IOS switches don't require it.

New Member

Re: DHCP and VLANS on 4507R - Help!

Thanks to all but it has been fixed by, you won't believe it, a reboot of the DHCP server which the service sits on the publisher CCM.

Who says that a reboot isn't good every once in awhile.

Thanks to all that responded!

Cisco Employee

Re: DHCP and VLANS on 4507R - Help!

I believe that you had a TAC case open as well and i was helping out the case owner on this one. The call manager/DHCP server port needs to be an Access vLAN. We changed the port to access VLAN 4 and had you reboot the Call manager to purge the DHCP cache. Rebooting alone would not have fixed this issue.

New Member

Re: DHCP and VLANS on 4507R - Help!

you have to write ip helper-address to point to the Dhcp server in vlans

116
Views
0
Helpful
4
Replies
CreatePlease to create content