Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DHCP for Dial-in Clients over PRI

Hi folks, here is my issue:

I am atempting to set up a 3745 running 12.3.6 Advancd Enterprise with a NM-2CE1T1-PRI and 30 Digital modems as a NAS to support a number of individual users over Async dial up.

I can connect to the NAS, and use RADIUS to complete authentication, but the DHCP I have set up on the router doesn't appear to work. I can use an address pool to hand out IP addresses, but I want to hand out Default Gateways and Subnet masks as well, so I figure that DHCP is the only way to go.

I ran a debug on DHCP (wouldn't you know it I don't have the output - I'll post it later if required) but all it said was it was unable to get NBNS Primary, DNS Secondary and NBNS Secondary.

Any advice will be gratefully recieved.

Here is the config:

!

version 12.3

card type e1 2

!

username <deleted> password <deleted>

clock timezone AEST 10

modem country mica australia

aaa new-model

!

aaa authentication login NO_AUTHEN none

aaa authentication ppp default group radius local

aaa authentication ppp dialin if-needed group radius

aaa authentication ppp radius group radius

aaa authorization network default group radius

aaa accounting update newinfo

aaa accounting exec default start-stop group radius

aaa accounting network default start-stop group radius

aaa session-id common

ip subnet-zero

ip cef

!

ip dhcp excluded-address 172.16.48.1

!

ip dhcp pool remote

   network 172.16.48.0 255.255.255.0

   domain-name <deleted>

   dns-server 172.16.32.103 172.16.36.101

   default-router 172.16.48.1

!

no ip domain lookup

ip name-server 172.16.32.103

ip audit po max-events 100

ip address-pool dhcp-proxy-client

ip dhcp-server 172.16.48.1

no ftp-server write-enable

async-bootp dns-server 172.16.32.103

!

isdn switch-type primary-net5

!

modemcap entry australia:MSC=-i20z

modemcap entry reset:MSC=&f\:t113=0-I20z

!

controller E1 2/0

framing CRC4 Australia

pri-group timeslots 1-31

!

controller E1 2/1

framing CRC4 Australia

pri-group timeslots 1-31

!

interface Loopback0

ip address 172.16.48.1 255.255.255.0

!

interface FastEthernet0/0

ip address 172.16.0.21 255.255.252.0

ip accounting output-packets

no ip mroute-cache

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial2/0:15

no ip address

ip directed-broadcast

encapsulation ppp

dialer-group 1

isdn switch-type primary-net5

isdn incoming-voice modem

no peer default ip address

ppp authentication pap

!

interface Group-Async1

ip unnumbered Loopback0

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer in-band

dialer idle-timeout 2147483

async default routing

async mode interactive

peer default ip address pool dhcp

ppp authentication pap

group-range 33 62

hold-queue 10 in

!

router ospf 1

log-adjacency-changes

network 172.16.0.0 0.0.255.255 area 0.0.0.0

network 172.19.0.0 0.0.3.255 area 0.0.0.0

network 172.31.0.0 0.0.0.255 area 0.0.0.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.0.51

!

ip http server

no ip http secure-server

ip ospf name-lookup

!

dialer-list 1 protocol ip permit

!

radius-server host 172.16.36.101 auth-port 1645 acct-port 1646

radius-server key <Deleted>

!

!

line con 0

exec-timeout 0 0

password <Deleted>

login authentication NO_AUTHEN

line 33 62

modem InOut

transport input all

autoselect ppp

line aux 0

exec-timeout 15 0

password <Deleted>

modem InOut

transport input all

stopbits 1

flowcontrol hardware

line vty 0 4

exec-timeout 15 0

password <deleted>

!

end

  • Other Network Infrastructure Subjects
2 REPLIES
Cisco Employee

Re: DHCP for Dial-in Clients over PRI

See if this sheds some light on your problem :

Using the Cisco IOS DHCP Server on Access Servers:

http://cco/en/US/tech/tk801/tk36/technologies_configuration_example09186a0080094a4e.shtml

However, I am wondering why would you like to supply default gateway and mask to a dialup client? As you know default gateway on a point-to-point link is not meaningful and hence its the client's own IP address itself while mask (that gets handed out via DHCP rather than IPCP) is only useful to give the peer a block of IP addresses that it can assign to CPE devices (if any) behind it on its network.

~Zulfi

New Member

Re: DHCP for Dial-in Clients over PRI

Thanks ~Zulfi - your straightening me out on point-to-point links solved my issues...

cheers

Greg

121
Views
0
Helpful
2
Replies
This widget could not be displayed.