Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP for different VLANs

Hi All,

I have a issue with dhcp clients communicating with DHCP server on windowds 2003.

Layer 3 switch is configured with IP helper to forward request to DHCP server on 152.153.238.0 /24 subnet users can get IP address from dhcp server when they are in particulae vlan but when a user moves from one vlan to other user is not getting IP address from dhcp server,Can anyone help me out here....

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: DHCP for different VLANs

I have heard of similar issues when using superscopes. Try breaking your superscope into seperate scopes.

19 REPLIES
Purple

Re: DHCP for different VLANs

Could you post your config ?

Have you configured a helper address on all of these VLAN interfaces ?

Paresh

New Member

Re: DHCP for different VLANs

Paresh ,

below is config..

sh runn

Building configuration...

Current configuration : 4169 bytes

!

! Last configuration change at 18:43:31 Msia Fri Aug 11 2006

! NVRAM config last updated at 18:40:33 Msia Fri Aug 11 2006

!

version 12.2

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname CORE1

!

logging buffered 20000 debugging

enable secret 5 $1$jofs$LDlLcqesLUYfOz9QOBMhP1

!

no aaa new-model

clock timezone Msia 8

switch 1 provision ws-c3750g-12s

ip subnet-zero

ip routing

!

ip dhcp-server 152.153.238.33

!

!

!

errdisable recovery cause udld

errdisable recovery cause bpduguard

errdisable recovery cause security-violation

errdisable recovery cause channel-misconfig

errdisable recovery cause pagp-flap

errdisable recovery cause dtp-flap

errdisable recovery cause link-flap

errdisable recovery cause gbic-invalid

errdisable recovery cause psecure-violation

errdisable recovery cause dhcp-rate-limit

errdisable recovery cause unicast-flood

errdisable recovery cause vmps

errdisable recovery cause loopback

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet1/0/1

description ##### Conn to Server Room | Module S/N: AGS1018L2W4 #####

no switchport

ip address 10.89.65.26 255.255.255.252

ip helper-address 152.153.238.33

!

interface GigabitEthernet1/0/2

description #### Conn to BSM_COMMSW01 Port Gig0/1 ####

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/3

description ##### Conn to EER Paint | Module S/N: FNS1019C1WQ #####

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/4

description ##### Conn to Store | Module S/N: AGS102005UC #####

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/5

description ##### Conn to Maintenance | Module S/N: AGS102005UQ #####

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/6

description ##### Conn to Logistics | Module S/N: AGS102005SM #####

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/7

description ##### Conn to IS | Module S/N: AGS102005TJ #####

switchport access vlan 2

switchport mode access

!

interface GigabitEthernet1/0/8

description ##### Conn to EER ZAL | Module S/N: FNS1019R0P8 #####

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/9

!

interface GigabitEthernet1/0/10

!

interface GigabitEthernet1/0/11

!

interface GigabitEthernet1/0/12

!

interface Vlan1

no ip address

shutdown

!

interface Vlan2

ip address 10.89.72.3 255.255.255.0

ip helper-address 152.153.238.33

!

interface Vlan3

ip address 10.89.73.11 255.255.255.0

!

interface Vlan4

ip address 10.89.74.11 255.255.255.0

!

ip default-gateway 10.89.65.25

ip classless

ip route 0.0.0.0 0.0.0.0 10.89.65.25

ip http server

!

arp 10.89.72.86 00e0.db06.89d7 ARPA

snmp-server community public RO

!

control-plane

!

banner motd ^CCC

!

line con 0

password 7 121A0C041104

logging synchronous

login

line vty 0 4

password 7 045802150C2E

no login

line vty 5 15

no login

!

ntp clock-period 36028692

ntp server 152.153.238.41

!

end

Purple

Re: DHCP for different VLANs

Hi,

Can you try the following:

interface Vlan3

ip helper-address 152.153.238.33

!

interface Vlan4

ip helper-address 152.153.238.33

!

That should fix it.

Pls do rate posts that help...

Paresh

New Member

Re: DHCP for different VLANs

do i have to remove gateway((interface Vlan3

ip address 10.89.73.11 255.255.255.0

!

interface Vlan4

ip address 10.89.74.11 255.255.255.0))

for that particular subnet and just place Ip helper-address for interface vlan3 & vlan4

Purple

Re: DHCP for different VLANs

NO, don't remove the addresses !!

Just add the config I supplied to what's already there...

PK

New Member

Re: DHCP for different VLANs

Sori to say but still same its not working........

Do i have to configure Dhcp relay agent or some thing like that

Purple

Re: DHCP for different VLANs

Have you configured appropriate scopes on your DHCP server for these subnets ?

Silver

Re: DHCP for different VLANs

Can you ensure the DHCP server is reachable from other than its original subnet ?

e.g. access from VLAN 2, 3, 4 VLAN subnet ?

Any default gateway in DHCP server ?

Please provide the trace route result from switch to DHCP server. Thx.

New Member

Re: DHCP for different VLANs

I have created superscope in dhcp server and added this subnets under that ,Problem i have here is users can get ip in all vlans but when a user move from vlan 2 to vlans 3 he is not able to get ip address from dhcp server & at same time i am getting error like DHCP server is not reachable....

Silver

Re: DHCP for different VLANs

Can you provide the trace route from a PC at VLAN 3 to the DHCP server ?

If add the ip-helper address at VLAN 3, it should work.

Purple

Re: DHCP for different VLANs

Are you doing a DHCP release on the user after you move them across to the new VLAN ?

New Member

Re: DHCP for different VLANs

Yep say when i am in vlan3 and move to vlan2 i relese ip address but when i renew i dont get IP address and after a while still still its getting ol ip addrees of vlan3 when i tracert it not reaching local gateway.

Silver

Re: DHCP for different VLANs

Sorry for state it clearly. What I mean use a PC w/ static or valid IP in VLAN 3 to trace route to the DHCP server. And also trace from DHCP server to the switch VLAN 3 interface. Please try it ans advise the result.

New Member

Re: DHCP for different VLANs

C:\Documents and Settings\sosrin>tracert 152.153.238.33

Tracing route to 152.153.238.33 over a maximum of 30 hops

1 <1 ms <1 ms <1 ms 10.89.72.3

2 <1 ms <1 ms <1 ms 10.89.65.25

3 <1 ms <1 ms <1 ms 152.153.238.33

Trace complete.

C:\Documents and Settings\sosrin>

and 10.89.65.25 is configured on this switch

sh runn

Building configuration...

Current configuration : 3827 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log datetime

no service password-encryption

service sequence-numbers

!

hostname C3750G

!

enable secret xxx

enable password

!

switch 1 provision ws-c3750g-24t

ip subnet-zero

ip routing

no ip dhcp relay information check

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

!

interface GigabitEthernet1/0/19

description RJ45 to ATI Rapier L3

no switchport

ip address 10.89.65.25 255.255.255.252

ip helper-address 152.153.238.33

!

interface GigabitEthernet1/0/20

switchport access vlan 238

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/21

switchport access vlan 238

switchport mode access

spanning-tree portfast

!

interface GigabitEthernet1/0/22

switchport access vlan 238

switchport mode access

speed 1000

duplex full

spanning-tree portfast

!

interface GigabitEthernet1/0/23

description RJ45 to Peribit appliance

no switchport

ip address 10.89.65.17 255.255.255.248

speed 100

duplex full

!

interface GigabitEthernet1/0/24

description Trunk connection CAT3550 int G0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan1

no ip address

!

interface Vlan238

ip address 152.153.238.3 255.255.255.0

!

interface Vlan240

ip address 10.89.75.11 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.89.65.19

ip route 1.1.1.0 255.255.255.0 10.89.65.26

ip route 10.89.72.0 255.255.255.0 10.89.65.26

ip route 10.89.73.0 255.255.255.0 10.89.65.26

ip route 10.89.74.0 255.255.255.0 10.89.65.26

ip http server

!

!

logging trap debugging

snmp-server community n5 RO

snmp-server enable traps tty

!

control-plane

!

!

line con 0

line vty 0 4

password

login

line vty 5 15

no login

!

end

Silver

Re: DHCP for different VLANs

The config. looks fine and correct routing setup for both VLAN 2 & 3. And the trace route is fine too. But can you trace from VLAN 3, 10.89.74.0 to DHCP server ? It helps to isolate the problem.

Is default gateway config. in DHCP server or static route config. in DHCP server ?

Thanks.

New Member

Re: DHCP for different VLANs

I have heard of similar issues when using superscopes. Try breaking your superscope into seperate scopes.

New Member

Re: DHCP for different VLANs

Yes i am using superscope in dhcp server and all 3 scopes are under that r u saying that i have remove superscope and leave scope as it is with respective gateways configured for scope in dhcp server ??

New Member

Re: DHCP for different VLANs

Precisely.

New Member

Re: DHCP for different VLANs

Tks u r correct removing superscope every thing works fine

273
Views
0
Helpful
19
Replies
CreatePlease login to create content