Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DHCP forwarding not working properly

Hi folks,

I know I am probably just missing something crazy, but I've moved a portion of our networks from a 2621XM to a 7600 yesterday.

Some of the networks need to ip helper-address enabled to forward requests to a central dhcp servers. Since moving them to the 7600, my dhcp servers are seeing the requests come from the vlan interface associated with the dhcp servers instead of the requesting vlan.

Here is an example of the old and new configurations.

<2621xm>

interface fa0/1.210

encapsulation dot1Q 210

ip address 172.16.210.1 255.255.255.0

ip helper-address 10.70.0.4

!

<7600>

interface vlan 210

ip vrf forwarding internal

ip address 172.16.210.1 255.255.255.0

ip helper-address 10.70.0.4

!

Here is an output of the dhcp logs:

Oct 26 09:15:35 dunnotar dhcpd: DHCPDISCOVER from 00:11:24:ca:be:10 via eth0: network 10.70.0.0/24: no free leases

Oct 26 09:15:40 dunnotar dhcpd: DHCPDISCOVER from 00:11:24:ca:be:10 via eth0: network 10.70.0.0/24: no free leases

Oct 26 09:15:49 dunnotar dhcpd: DHCPDISCOVER from 00:11:24:ca:be:10 via eth0: network 10.70.0.0/24: no free leases

Oct 26 09:15:57 dunnotar dhcpd: DHCPDISCOVER from 00:11:24:ca:be:10 via eth0: network 10.70.0.0/24: no free leases

I have also enable "ip forward-protocol udp bootps/c" think that might be the cause.

Some of the documentation that I have read suggests that I might need "ip dhcp relay information option vpn" but I don't see the "vpn" keyword

Has anyone seen this before, or might be able to shed some light on this.

Thanks.

-- Dominique

1 REPLY
New Member

Re: DHCP forwarding not working properly

Check to see if you have the 'ip directed-broadcast' command on any of the outbound interfaces that the UDP packets need to traverse. If you do, enter the 'no ip directed-broadcast' command on those interfaces, this command configures the router or switch to prevent the translation of a directed broadcast to a physical broadcast.

That might be the problem.

287
Views
0
Helpful
1
Replies