Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP HELP Please.......

I have all DHCP clients and server on same VLAN in the same subnet on CAT4507.

I can also ping DHCP server, but the clients are not getting IPs. I've checked DHCP config on server seems to be OK. When I turn on debug I get following:

1w3d:

-----Additional Debug------

1w3d: DHCP process ID FFFFFFFF status 0

1w3d: DHCP Network Discovery is disabled

1w3d: DHCP NetDiscovery Informs 0 Discovers 0 Period 0

1 ACCEPTED SOLUTION

Accepted Solutions

Re: DHCP HELP Please.......

can you make sure that "spanning-tree portfast" is enabled on the client port and server port? Can you also post the client and server port config, if possible?

6 REPLIES

Re: DHCP HELP Please.......

can you make sure that "spanning-tree portfast" is enabled on the client port and server port? Can you also post the client and server port config, if possible?

New Member

Re: DHCP HELP Please.......

I don't have spanning-tree port-fast enabled. I plugged in all cables into a small switch(i.e. bypassing CISCO) and worked fine!! So, I need to set something up in CISCO but what? Do I have enable DHCP somehow?

New Member

Re: DHCP HELP Please.......

This is what I have:

interface FastEthernet3/1

switchport access vlan 21

!

interface FastEthernet3/2

switchport access vlan 21

!

interface FastEthernet3/3

switchport access vlan 21

interface Vlan21

description VLAN21-SIGTRAN-EXCEL

ip address 10.18.89.126 255.255.255.192

!

New Member

Re: DHCP HELP Please.......

Enabling portfast worked!!! But why?

Thanks for your help

Re: DHCP HELP Please.......

without portfast the port goes through the usual stages of spanning-tree, blocking, learning, forwarding. This stages is enough to cause start-up delay issues with DHCP, windows, Novell, Etc. with portfast the port is put in forwarding mode immediately upon connection.

Re: DHCP HELP Please.......

try putting in "spanning-tree portfast" under the interfaces where the client and server are connected as I earlier suggested.

294
Views
0
Helpful
6
Replies