Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

DHCP on 871 Router

I'm having difficulties getting DHCP working on a Cisco 871 Router. Clients on either FE0 or Wireless don't receive an address at all. I have a pool setup on a BVI, with helper-addresses set up on the relevant interfaces, but still nothing. I feel like I'm probably missing something simple, but I can't figure out what. Below are what I believe to be the relevant portions of the config, Let me know if I'm missing something.

Thanks!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.100.1 192.168.100.99

ip dhcp excluded-address 192.168.100.201 192.168.100.254

!

ip dhcp pool ROCK0

import all

network 192.168.100.0 255.255.255.0

dns-server 192.9.1.1

default-router 192.168.100.1

domain-name company.com

...

interface FastEthernet0

no cdp enable

...

interface Dot11Radio0

no ip address

ip helper-address 192.168.100.1

!

encryption vlan 1 mode wep mandatory

!

ssid <removed>

vlan 1

authentication open eap eap_methods

authentication network-eap eap_methods

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

no dot11 extension aironet

no cdp enable

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

ip helper-address 192.168.100.1

no snmp trap link-status

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$

no ip address

ip helper-address 192.168.100.1

ip tcp adjust-mss 1452

bridge-group 1

!

interface BVI1

description $ES_LAN$$FW_INSIDE$

ip address 192.168.100.1 255.255.255.0

ip access-group 100 in

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

3 REPLIES
New Member

Re: DHCP on 871 Router

You don't need IP Helper statements...

Add the following..

bridge irb

bridge 1 route ip

One more thing you really don't need the import all

on your dhcp pool. This will import all the setting that the ISP provides when your FA4 interface receives an address. Your already specifing a DNS and DomainName...

New Member

Re: DHCP on 871 Router

Sorry for the delay, I've been sidetracked. I tried both of those, nothing. Both wired and wireless clients are unable to get DHCP. Attached is a cleaned configuration.

Any help is appreciated.

New Member

Re: DHCP on 871 Router

For testing remove the access list from BVI 1 and make int VLAN 1 look like this.

interface Vlan1

no ip address

no ip redirects

no ip proxy-arp

bridge-group 1

bridge-group 1 spanning-disable

124
Views
0
Helpful
3
Replies
CreatePlease to create content