Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

DHCP problems with 1720

Situation: site A with 2612 (IOS 12.1.5.YB5), server Windows/2000+active directory, DHCP-server. etc.

site B with 1720 (IOS 12.1.5.YB5) connected to site A over ADSL.

PROBLEM: the PC client don't receive IP address from the remote server.

ALL CHECKED: Server, DHCP-service, routing, etc seams to work correctly, but ...

Thank's.

Claudio

6 REPLIES
New Member

Re: DHCP problems with 1720

Try an IP Helper Address.

New Member

Re: DHCP problems with 1720

OBVIOUSLY I use IP Helper-address on the LAN interface (FastEthernet) ...

I used the same configuration I am using for the 26xx's: but with the 26xx's it works very wel.

Looking at IP accounting on the 1720, I see pakets with source 0.0.0.0 and destination , but NO returns pakets.

Re: DHCP problems with 1720

This may help:

http://www.cisco.com/warp/public/473/100.html

If not, can you post the config of the 1720 or sniff the dhcp to make sure it is replying?

Steve

New Member

Re: DHCP problems with 1720

!

version 12.1

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service dhcp

!

hostname rupe

!

no logging rate-limit

enable password (...)!

clock timezone italy 1

clock summer-time Italy recurring last Sun Mar 2:00 last Sun Oct 3:00

ip subnet-zero

no ip source-route

!

!

no ip finger

no ip domain-lookup

!

no ip dhcp-client network-discovery

!

source-bridge ring-group 2000

dlsw local-peer peer-id 10.123.30.6

dlsw remote-peer 0 tcp 10.123.30.110 keepalive 0 timeout 90 dynamic no-llc 1

dlsw icannotreach sap AA E0 F0

dlsw bridge-group 53

!

!

interface Loopback0

ip address 10.123.30.6 255.255.255.255

!

interface ATM0

description Connesso a RETE DSL

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache

no ip mroute-cache

atm vc-per-vp 256

no atm ilmi-keepalive

dsl operating-mode auto

no fair-queue

hold-queue 208 in

!

interface ATM0.1 point-to-point

description Connesso a sede

ip address 10.123.31.34 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

ip accounting output-packets

ip nat outside

no ip route-cache

no ip mroute-cache

pvc 8/35

encapsulation aal5snap

!

!

interface FastEthernet0

ip address 10.123.6.1 255.255.255.0

ip helper-address 10.123.0.23

ip accounting output-packets

no keepalive

speed auto

bridge-group 53

!

interface Serial0

description "Collegamento verso Bancomat"

no ip address

encapsulation sdlc

no keepalive

nrzi-encoding

clockrate 9600

sdlc role primary

sdlc vmac 4001.2300.6e00

sdlc poll-pause-timer 20

sdlc address B2

sdlc xid B2 05D306B2

sdlc partner 4000.1000.0002 B2

sdlc line-speed 9600

sdlc dlsw B2

!

router eigrp 52

redistribute static

network 10.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

no ip forward-protocol udp tftp

no ip forward-protocol udp domain

no ip forward-protocol udp time

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

no ip forward-protocol udp tacacs

ip route 0.0.0.0 0.0.0.0 ATM0.1

no ip http server

!

access-list 90 permit 10.120.0.15

access-list 90 permit 10.120.0.200

access-list 90 deny any log

access-list 100 deny eigrp any any

access-list 100 deny udp any any eq snmp

access-list 100 deny udp any any eq snmptrap

access-list 100 deny udp any any eq ntp

access-list 100 permit ip any any

access-list 110 permit tcp any eq 2065 any eq 2065

access-list 110 permit tcp 10.120.0.0 0.0.0.255 eq 1477 any

access-list 110 permit tcp 10.120.0.0 0.0.0.255 eq 1478 any

access-list 110 permit tcp any any eq 1477

access-list 110 permit tcp any any eq 1478

access-list 110 permit tcp 10.120.0.32 0.0.0.15 range 22001 25999 any

access-list 110 permit tcp 10.120.31.32 0.0.0.15 range 22001 25999 any

access-list 110 permit tcp any 10.120.0.32 0.0.0.15 range 22001 25999

access-list 110 permit tcp any 10.120.31.32 0.0.0.15 range 22001 25999

access-list 110 permit tcp any any eq telnet

access-list 110 permit tcp any eq telnet any

access-list 110 permit tcp host 10.120.0.24 eq 139 any

access-list 110 permit tcp host 10.120.0.25 eq 139 any

access-list 110 permit tcp host 10.120.0.33 eq 139 any

access-list 110 permit tcp host 10.120.0.34 eq 139 any

access-list 110 permit tcp host 10.120.0.42 eq 139 any

access-list 110 permit tcp host 10.120.0.43 eq 139 any

access-list 110 permit tcp host 10.120.0.51 eq 139 any

access-list 110 permit tcp host 10.120.0.52 eq 139 any

access-list 110 permit tcp any host 10.120.0.24 eq 139

access-list 110 permit tcp any host 10.120.0.25 eq 139

access-list 110 permit tcp any host 10.120.0.33 eq 139

access-list 110 permit tcp any host 10.120.0.34 eq 139

access-list 110 permit tcp any host 10.120.0.42 eq 139

access-list 110 permit tcp any host 10.120.0.43 eq 139

access-list 110 permit tcp any host 10.120.0.51 eq 139

access-list 110 permit tcp any host 10.120.0.52 eq 139

priority-list 1 protocol ip high tcp 2065

priority-list 1 protocol ip high tcp 1477

priority-list 1 protocol ip high tcp 1478

priority-list 1 protocol ip high tcp 1424

priority-list 1 protocol ip high tcp 1414

priority-list 1 protocol ip high tcp telnet

priority-list 1 protocol ip low gt 1024

priority-list 1 protocol ip high list 110

priority-list 1 protocol ip low tcp ftp

priority-list 1 protocol ip low tcp ftp-data

priority-list 1 queue-limit 40 40 20 7

!

!

snmp-server community public RO

snmp-server community crtnet RW 90

snmp-server trap-source Loopback0

snmp-server location (...)

bridge 53 protocol ieee

banner login (...)

!

line con 0

exec-timeout 60 0

transport input none

line aux 0

line vty 0 4

exec-timeout 60 0

password (...)

login

!

no scheduler max-task-time

no scheduler allocate

ntp clock-period 17180696

ntp server 10.120.31.254

ntp server 10.120.31.253

end

Re: DHCP problems with 1720

Quick points:

1. Where is the ip nat inside? Cut out of the post?

2. access-list 100 references a dialer-list?

3. acl 90 an access-class?

4. as a side note interesting you are redistributing a default route into eigrp, I thought this was a remote site.

Only things I can think of:

1. put a sniffer on to make sure dhcp is in fact replying

2. nat is messing with the helpered traffic (similiar to bug CSCdj92460).

New Member

Re: DHCP problems with 1720

1) Why do I need to use NAT? When in a "closed" network, without connection to InterNet, I usually don't use NAT

2) Acces-list 100 is NOT used (but YES, it refers to a Dialer-list)

3) ACL 90 is user to filter SNMP WR community

4) Right, I have to correct the mistake

Moreover: actually, I can't put a sniffer; I tried using IP ACCOUNTING, as I wrote inthe first post.

Thank's

118
Views
1
Helpful
6
Replies
CreatePlease to create content