Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

DHCP question

Hi,

I have enabled dhcp server on 2950, & the client pc's are getting the IP from it without any problem, now my question is, will the DHCP server provide the host name also?

8 REPLIES

Re: DHCP question

Hi,

you need manual bindings to get each PC with a fixed IP to be used with a DNS server.

ip dhcp pool Mars

host 172.16.2.254 mask 255.255.255.0

hardware-address 02c7.f800.0422 ieee802

client-name Mars

default-router 172.16.2.100 172.16.2.101

domain-name cisco.com

dns-server 172.16.1.102 172.16.2.102

netbios-name-server 172.16.1.103 172.16.2.103

netbios-node-type h-node

You would still need an entry in the DNS server to access the clients through DNS.

Hope this helps

Martin

Re: DHCP question

i tried this config. but it is not taking the IP address in the windows 2000.

Re: DHCP question

Hi,

can you post the relevant config?

Martin

Re: DHCP question

ip dhcp pool anand

network 10.196.1.0 255.255.255.0

dns-server 10.2.1.1 10.2.1.2

domain-name abc.com

default-router 10.196.1.252

ip dhcp snooping

ip dhcp-server 10.196.1.250

ip dhcp excluded-address 10.196.1.251 10.196.1.254

interface vlan 196

ip address 10.196.1.250 255.255.255.0

ip default-gateway 10.196.1.252

with this configuration it working fine, i mean clients are able to get the IP address along with the dns name & gateway ip addres which i hav put on the dhcp pool. i also tried your configuration, but it is not taking any ip address. if i go to "show ip dhcp binding" it is showing the IP address,hardware address,lease expiration & Type what ever i have typed, but i am getting the ip in the pc. also is there any option where i can specify a ip address for the particular mac-address in the DCHP?so that that particular IP address should be allocated only to that mac-address PC & not for any other PC's mac-address.

Re: DHCP question

Hi,

the config I gave should allocate the defined IP for the PC with the MAC address given. Did you configure the clients proper MAC address?

Martin

Re: DHCP question

yeah even the clients mac address is also correct, but still not working, the client OS is windows 2000 professional

Re: DHCP question

Actually my requirement is... i wanted each & every pc & network printers to obtain the IP address from the DHCP server, so when it comes to network printer, the IP address should be static, so i wanted to specify in such a way that this particular IP should be set only for this particular mac-address. so is that possible? Thanks in advance.

New Member

Re: DHCP question

Try the following config:

ip dhcp pool anand

network 10.196.1.0 255.255.255.0

dns-server 10.2.1.1 10.2.1.2

domain-name abc.com

default-router 10.196.1.252

IP dhcp pool reserve

default-router 10.196.1.252

host 10.196.1.xxx

hardware-address aaaa.aaaa.aaaa OR

client-identifier 01aa.aaaa.aaaa.aa

It appears you have to have a second pool for the reserved address. I have just done this on rtr and hardware-address did not work but client-identifier did

118
Views
0
Helpful
8
Replies