Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP Server on Cisco 3750

Hi,

I need to subnet my network into 5 segments. I need to give DHCP on all the subnets withy the 3750 as the DHCP server.

I do not have realy agents .How do I configure the 3750 to give addresses for multiple subnets.

thanx

3 REPLIES
Cisco Employee

Re: DHCP Server on Cisco 3750

Hi Sanjay,

You need to create multiple DHCP pools on your 3750 and enable "service dhcp" command on global config mode.

Also to create mutliple DHCP pools try these commands

ip dhcp pool

network

default-router

Apply the same commands for number fo pools you want for different subnets.Default router will work as a gateway for that pool.

To know about more dhcp related commands check this link

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipras_r/1rfdhcp.htm#1018170

HTH

Ankur

Re: DHCP Server on Cisco 3750

Hi Sanjay,

juz issue the commands mentined below for ur 3750 for u r5 network segmentz

!

ip routing

ip dhcp pool segment1

network 10.0.0.0 255.255.255.0

dns-server a.b.c.d

domain-name yourdomain.com

default-router 10.0.0.1

!

ip dhcp-server 10.0.0.1

ip dhcp pool segment2

network 10.1.0.0 255.255.255.0

dns-server a.b.c.d

domain-name yourdomain.com

default-router 10.1.0.1

!

ip dhcp-server 10.1.0.1

ip dhcp pool segment3

network 10.2.0.0 255.255.255.0

dns-server a.b.c.d

domain-name yourdomain.com

default-router 10.2.0.1

!

ip dhcp-server 10.2.0.1

ip dhcp pool segment4

network 10.3.0.0 255.255.255.0

dns-server a.b.c.d

domain-name yourdomain.com

default-router 10.3.0.1

!

ip dhcp-server 10.3.0.1

ip dhcp pool segment5

network 10.4.0.0 255.255.255.0

dns-server a.b.c.d

domain-name yourdomain.com

default-router 10.4.0.1

!

ip dhcp-server 10.4.0.1

interface vlan 2

ip address 10.0.0.1 255.255.255.0

interface vlan 3

ip address 10.1.0.1 255.255.255.0

interface vlan 4

ip address 10.2.0.1 255.255.255.0

interface vlan 5

ip address 10.3.0.1 255.255.255.0

interface vlan 5

ip address 10.4.0.1 255.255.255.0

hope this helps.

rate this post if your is cleared.

New Member

Re: DHCP Server on Cisco 3750

Hi,

Thanx for your help.I appreciate your help.

sanjay

547
Views
14
Helpful
3
Replies
CreatePlease login to create content