Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

DHCP, Some Leases have wrong Subnet Mask, causing IP address conflicts

We have been having a weird set of issues come up recently. We have several subnets that we are getting reports of IP address conflicts errors from end users. We are assigning addresses via DHCP. The addresses (hardware, and IP) that are being listed as being in conflict are usually not the same. I initialy thought this could be a dhcp server issue, so I changed one subnet with issues to a different DHCP server with a differant scope of addresses. No change the issue still exists. Then errors started occuring on a subnet in a remote location, running a totally differant setup for dhcp(The main site uses Microsoft's DHCP Server propagating dhcp traffic across a Cisco 6509 Switch's subnets with helper addresses setup, and the remote site with a single subnet with a Cisco 4006 switch, and running DHCP Server on the 1750 Cisco Router at that location) Finally I found one lead but am not sure what it means. We just got in a new Fluke Optiview Network analyser, and I put it on each subnet with issues. The Optiview shows that on each subnnet about 6 PC's have the wrong subnet mask, It should be a class C subnet mask but is coming up as class A or B. I verified that these PC's were not set with static IP addresses, and if you release and renew the ip address manually the correct mask appears, but within a couple days the incorect mask reappears. The only thing in common with these computers seems to be that they are running Windows 98, they are all of several differant brands, and also are running several differant brands of Network cards (3Com, integrated Dell, and Aopen) My thoughts are that since the subnet masks are not right the dhcp servers cannot tell that the IP addresses they are assigning are in use and they reassign the same address. Any ideas? Am I even on the right track here?

Jim Matuska

4 REPLIES
Community Member

Re: DHCP, Some Leases have wrong Subnet Mask, causing IP address

We have a Fluke Optiview also. You have to watch how it reports subnets. Ours shows the network's natural mask (10.0.0.0/8), and then the specific "child" subnets underneath (like 10.10.10.0/24). Even though there are no workstations with A-class masks, the natural network address still shows up.

Secondly, you may want to temporarily put up a local DHCP server and disable DHCP on the 1750. This way, you can rule out a workstation config problem versus a router DHCP server config problem.

It sounds like it may be remote, so I would probably try to duplicate the problem at your location.

Question: Do you really want to run the DHCP server off the 1750? Usually, I see customers with just a few DHCP servers at the data center/central site, with most or all remote sites being serviced from those same servers. I hardly ever see a small site serviced with it's own DHCP server (assuming since you have a 1750 that it is a small site).

Community Member

Re: DHCP, Some Leases have wrong Subnet Mask, causing IP address

The Optiview shows errors with about 7-9 Client "error wrong subnet mask" If you go to the client PC and run winipcfg, and look at the subnet mask it is wrong, manually release and renew the address and the mask comes up correctly but within a few days is back to the wrong number. This is also occuring at our main site on several subnets that are being serviced by a Microsoft DHCP server. Any other ideas?

Community Member

Re: DHCP, Some Leases have wrong Subnet Mask, causing IP address

Perhaps enabling some detailed logging on your MS DHCP server may yield some clues. I've solved many problems by spending time examining the logs (Unix logs are pretty darned detailed, not sure how good Microsoft's would be). At any rate, you can look at the DHCP requests, the hint information, and the whole transaction. One key thing would be to look for the actual DHCP offer, to see if the parameters are faulted, or if the workstation is corrupting it once it is received.

Perhaps taking some of the wrong settings (ex: the wrong subnet mask) and searching for it in the workstation's registry (also search for the hex version of the masks) and you may see some entries that don't match.

Secondly, try to see if there are any patterns regarding which workstations exhibit the problem, which subnets, how often, how long they stay fixed before they get corrupted again. Also take note of who *doesn't* have these problems. Perhaps you can correlate the issue with certain levels of the Win98 load, or certain hardware platforms, or something else...

One thing to remember is that the workstation tries to renew the lease halfway through it. So if it is a 10 day lease, it'll try to renew it at 5 days.

Another thing to do is search for similar symptoms on Microsoft's support sites, and even their forums.

Looks like some detective work is in order. To make things easier on you, I'd consolidate all your DHCP services to two servers, unless there's a compelling connectivity issue at certain locations. You can always add some back in later, after the issue is solved.

Good luck. Let us know what you find!

Community Member

Re: DHCP, Some Leases have wrong Subnet Mask, causing IP address

I have had the exact same problem. I have seen this with Win98 clients getting an address from a LAN Microsoft NT 4.0 DHCP server or a IOS router running DHCP service. The issue seems to be caused by Win98. I have fixed this by installing the Microsoft WINS server service on the server for name resolution and enabling that with the h-node argument on the DHCP scope. I'm not sure why this matters but it seems that win98 just sucks when it comes to corporate style networking. BTW, you don't need a helper address for WINS the machines will register over the WAN or VLAN segements when they boot up.

The really wierd thing it, some do it and others don't, it must be a certain NIC driver or something? I havent investigated that far yet but if you find out let me know.

:)

2142
Views
0
Helpful
4
Replies
CreatePlease to create content