Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

DHCP with 2 LANs and 2 DHCP POOLs

Hello,

I have two LAN segments

Ethernet 0/0 and Ethernet 0/1

Ethernet0/0

description *** LAN 1 ***

ip address 192.168.0.1 255.255.255.0

no ip proxy-arp

ip accounting access-violations

and

Ethernet0/1

description *** LAN 2 ***

ip address 192.168.1.1 255.255.255.0

no ip proxy-arp

ip accounting access-violations

arp timeout 1200

I use also DHCP pool for the first LAN

ip dhcp pool lan

network 192.168.0.2 255.255.255.0

domain-name mydomain.gr

dns-server 192.168.0.3

default-router 192.168.0.1

netbios-node-type b-node

lease 30

How can I use the second DHCP pool for the second LAN ??

Thanks

George

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

Re: DHCP with 2 LANs and 2 DHCP POOLs

Hello George,

just configure two DHCP pools, the clients will get their addresses from the pool that is in the same range as the respective Ethernet interfaces to which the clients are connected:

ip dhcp excluded-address 192.168.0.1

ip dhcp excluded-address 192.168.1.1

ip dhcp excluded-address 192.168.0.3

!

ip dhcp pool lan0 (pool for LAN1)

network 192.168.0.0 255.255.255.0

domain-name mydomain.gr

dns-server 192.168.0.3

default-router 192.168.0.1

netbios-node-type b-node

lease 30

!

ip dhcp-pool lan1 (pool for LAN1)

network 192.168.1.0 255.255.255.0

domain-name mydomain.gr

dns-server 192.168.0.3

default-router 192.168.1.1

netbios-node-type b-node

lease 30

I don't know if you are using the same DNS server for both LANs, otherwise change the addresses accordingly.

Regards,

GP

1 REPLY
VIP Purple

Re: DHCP with 2 LANs and 2 DHCP POOLs

Hello George,

just configure two DHCP pools, the clients will get their addresses from the pool that is in the same range as the respective Ethernet interfaces to which the clients are connected:

ip dhcp excluded-address 192.168.0.1

ip dhcp excluded-address 192.168.1.1

ip dhcp excluded-address 192.168.0.3

!

ip dhcp pool lan0 (pool for LAN1)

network 192.168.0.0 255.255.255.0

domain-name mydomain.gr

dns-server 192.168.0.3

default-router 192.168.0.1

netbios-node-type b-node

lease 30

!

ip dhcp-pool lan1 (pool for LAN1)

network 192.168.1.0 255.255.255.0

domain-name mydomain.gr

dns-server 192.168.0.3

default-router 192.168.1.1

netbios-node-type b-node

lease 30

I don't know if you are using the same DNS server for both LANs, otherwise change the addresses accordingly.

Regards,

GP

191
Views
0
Helpful
1
Replies