Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

DHCP

I have Cisco 2501, running IOS 11.2(18). I am trying to configure DHCP. When I typed "no ip dhcp conflict logging", I got the error message: Translating "conflict"...domain server (165.8.1.8) (165.8.1.1)

^

% Invalid input detected at '^' marker.

When I typed "ip dhcp pool ls", I got the error message:

Translating "pool"...domain server (165.8.1.8) (165.8.1.1)

^

% Invalid input detected at '^' marker.

Do you have any suggestions? Thanks.

15 REPLIES
Gold

Re: DHCP

Hi - you'll need to disable ip domain lookup, here's an example, the config below is on a c1600 IOS 12.1(6). This router is being used as a DHCP Server, modify the below config for your network and you should be okay to go.

ip subnet-zero

no ip finger

no ip domain-lookup

no ip dhcp conflict logging

ip dhcp excluded-address 192.x.x.x 192.x.x.x

ip dhcp pool internalnetwork

network 192.x.x.x

default-router 192.x.x.x

domain-name

dns-server

netbios-name-server

netbios-node-type h-node

lease 10

Hope this helps / Jay.

New Member

Re: DHCP

I typed "no ip-domain lookup", it accepts it. However, when I typed "no ip dhcp conflict logging", I still got the same error message.

Do you have any suggestions?

Thanks.

New Member

Re: DHCP

When you are typing "no ip dhcp conflict logging" the router is interpreting the word "conflict" as a hostname not a keyword. Same thing with "pool". By disabling domain-lookup you will won't get the same message, but you will still have a problem most likely.

With 11.2(18) code, I'm not sure that functionality is available. I would try using the trusty ? after the commands you are having trouble with try typing "no ip dhcp ?" and "no ip dhc?". This will tell you whether or not that command is actually available or not.

Hope this helps.

New Member

Re: DHCP

You are right. By typing "no ip domain-lookup", I no longer got the same message. But, I still have the problem.

By typing "no ip dhcp?" or "no ip dhc?", I got a return message: dhcp server. Does it mean it will accept dhcp?

Thanks.

New Member

Re: DHCP

IOS DHCP was released into IOS 12.0. You will need to upgrade your IOS for this functionality. The following link shows the new features introduced by 12.0 mainline and "Cisco IOS DHCP" is one of them.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1830/products_feature_guide09186a008008089d.html

Scroll down to the C's and click on Cisco IOS DHCP for configuration guidelines.

Hope this helps,

Regards,

New Member

Re: DHCP

Thank you for the information.

I am trying to upgrade the flash to ver. 12 (file name: c2500-8-l.120-5.T2.bin) on Cisco 2501. After typing "config-reg 0x2101" and "reload", the router came back with the prompt as

hostname(boot)>

Then, after typing "copy tftp flash", I got the following screen:

hostname(boot)#copy tftp flash

Flash: invalid chip id 0x9105

unable to configure flash for erase or write.

Flash chips recognized by system :

Code Chip-Sz Cmd-grp Chip-name

89B4 0x20000 1 INTEL 28F010

89BD 0x40000 1 INTEL 28F020

01A7 0x20000 1 AMD 28F010

012A 0x40000 1 AMD 28F020

012A 0x40000 1 AMD 28F020

1CD0 0x40000 1 M5M 28F101P

89A2 0x100000 2 INTEL 28F008SA

Flash address space cannot be written to.

Memory type is Flash. Chips are not identifiable.

Here is the screen for show ver:

hostname(boot)>show ver

3000 Software (IGS-RXBOOT Bootstrap), Version 9.14(6)[fc2], RELEASE SOFTWARE

Patchlevel = 9.1(10)

Copyright (c) 1986-1994 by cisco Systems, Inc.

Compiled Thu 07-Apr-94 13:58 by chansen

System Bootstrap, Version 4.14(6)[fc3], SOFTWARE

Hostname uptime is 1 minute

System restarted by power-on

Running default software

cisco 2500 (68030) processor (revision A) with 4096K/2048K bytes of memory.

Processor board serial number 01201364

DDN X.25 software, Version 2.0, NET2 and BFE compliant.

Enterprise software set supported. (0x0)

1 Ethernet/IEEE 802.3 interface.

2 Serial network interfaces.

32K bytes of non-volatile configuration memory.

8192K bytes of Flash address space sized on CPU board.

Configuration register is 0x2101

Do you have any suggestions? Thanks.

New Member

Re: DHCP

The hostname(boot)# indicates that your router has loaded an image from bootflash vise the standard image in the flash. issue the command

show boot

to see what you are booting with. Next check the flash to see if that image reflects

dir flash:

Next if the image is different in flash than it is from what show boot told you, issue the following command to boot from the image in flash (from the global config, config t)

boot system flash:imagename.bin

Next continue the upgrade as usual:

copy tftp flash

Let me know if you still have problems.

New Member

Re: DHCP

Here is the error message for "show boot"

hostname(boot)>show boot

% Unrecognized subcommand - "boot"

% Type "show ?" for a list of subcommands

hostname(boot)>show ?

arap ARAP information

hosts Host/address cache

sessions Telnet and rlogin connections

terminal Terminal parameters

users Summary of active lines and connections

version Hardware configuration and software version

hostname(boot)>en

Password:

hostname(boot)#show boot

% Unrecognized subcommand - "boot"

% Type "show ?" for a list of subcommands

Here is the error message for "dir flash"

Hostname(boot)>dir flash

Translating "DIR"...domain server (165.8.1.8) (165.8.1.1)

% Unknown command or computer name, or unable to find computer address

Do you want me to do the next step which is to type the command "boot system flash:imagename.bin"?

Thanks.

New Member

Re: DHCP

Feature navigator is a good tool to use.

http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

It sounds like the DHCP command that you want is not available on the image you are using. To see the options available, enter "ip dhcp

?"

New Member

Re: DHCP

Thanks for the info.

When I typed the command ip dhcp ?, it responded with:

hostname(boot)#ip dhcp?

hostname(boot)#ip dhcp

New Member

Re: DHCP

Why are you doing this from the boot config prompt?

New Member

Re: DHCP

I don't know why the router booted from the boot config. I tried to upgrade the IOS.

Bronze

Re: DHCP

The messages in your posting of Mar 3 at 7:03 are reporting problems with the flash. Did you upgrade the flash to enable the IOS upgrade? I think you have a very old 2501 and the boot rom (yours is 9.14(6) needs to be upgraded to handle the extra flash.

New Member

Re: DHCP

No, I did not upgrade the flash. How do I upgrade the flash? Thanks.

New Member

Re: DHCP

Save time, save money, just upgrade your flash to 16M and upgrade your DRAM to 16M, you can use any 2500 IOS from 12.3.6 to 9.4.xxxxx. I never use IOS low then version 10.

buy Flash/DRAM on ebay, and install them.

529
Views
5
Helpful
15
Replies