Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

dial backup using dialer watch

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

I am trying to impliment PSTN dial backup on AUX port to back up the main serial link. The branch router config is as follows;

xxxxxxxxx#sh run

Building configuration...

Current configuration : 1786 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname xxxxxxx

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication ppp default local

aaa session-id common

enable password xxxxxxx

!

username xxxxxxx password 0 xxxxxxx

username xxxxxxx password 0 xxxxxxx

username R3 password 0 cisco

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

!

!

!

ip audit notify log

ip audit po max-events 100

!

!

!

!

interface Loopback0

ip address 172.16.30.94 255.255.255.252

!

interface FastEthernet0

ip address 172.16.24.254 255.255.255.0

speed auto

no cdp enable

!

interface Serial0

ip address 172.16.31.94 255.255.255.252

encapsulation ppp

shutdown

no cdp enable

!

interface Serial1

no ip address

shutdown

no cdp enable

!

interface Async5

ip address 172.16.29.94 255.255.255.252

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer in-band

dialer idle-timeout 30

dialer map ip 0.0.0.0 name R3 broadcast 2511

dialer map ip 172.16.29.93 name R3 broadcast 2511

dialer watch-group 8

dialer-group 1

async default routing

async mode interactive

ppp authentication chap

!

interface Dialer1

no ip address

no cdp enable

!

router ospf 1

log-adjacency-changes

area 1 stub no-summary

network 172.16.24.254 0.0.0.0 area 1

network 172.16.30.94 0.0.0.0 area 1

network 172.16.31.94 0.0.0.0 area 1

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.29.93 150

no ip http server

ip pim bidir-enable

!

!

dialer watch-list 8 ip 0.0.0.0 0.0.0.0

dialer-list 1 protocol ip permit

no cdp run

!

!

line con 0

line aux 0

modem InOut

modem autoconfigure discovery

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line vty 0 4

password xxxxxxxxx

!

end

xxxxxxxxx#

Problem: Once the main link goes down, the backup link comes up and I can pass the traffice over the backup line ( eg ping).

But, the backup link never stays up: It re-sets and re-dials.

Following is the "debug dialer" output:

2:41:41: As5 DDR: Dialer Watch: resetting call in progress

02:41:41: DDR: Dialer Watch: watch-group = 8

02:41:41: DDR: network 0.0.0.0/0.0.0.0 DOWN,

02:41:41: DDR: primary DOWN

02:41:41: DDR: Dialer Watch: Dial Reason: Secondary of group 8 DOWN

02:41:41: DDR: Dialer Watch: watch-group = 8,

02:41:41: DDR: dialing secondary by dialer string 2511 on As5

02:41:41: As5 DDR: Attempting to dial 2511

02:41:41: CHAT5: Attempting async line dialer script

02:41:41: CHAT5: no matching chat script found for 2511

02:41:41: CHAT5: Dialing using Modem script: d0efault-d0ials0cript & System script: none

02:41:41: CHAT5: process started

02:41:41: CHAT5: Asserting DTR

02:41:41: CHAT5: Chat script d0efault-d0ials0cript started

02:42:04: CHAT5: Chat script d0efault-d0ials0cript finished, status = Success

02:42:06: %LINK-3-UPDOWN: Interface Async5, changed state to up

02:42:06: As5 DDR: Dialer statechange to up

02:42:06: As5 DDR: Dialer Watch: resetting call in progress

02:42:06: As5 DDR: Dialer call has been placed

02:42:08: As5 DDR: dialer protocol up

02:42:09: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async5, changed state to up

02:42:36: As5 DDR: idle timeout

02:42:36: DDR: Dialer Watch: watch-group = 8

02:42:36: DDR: network 0.0.0.0/0.0.0.0 UP,

02:42:36: DDR: primary DOWN

02:43:06: As5 DDR: idle timeout

02:43:06: DDR: Dialer Watch: watch-group = 8

02:43:06: DDR: network 0.0.0.0/0.0.0.0 UP,

02:43:06: DDR: primary DOWN

02:43:36: As5 DDR: idle timeout

02:43:36: DDR: Dialer Watch: watch-group = 8

02:43:36: DDR: network 0.0.0.0/0.0.0.0 UP,

02:43:36: DDR: primary DOWN

02:44:06: As5 DDR: idle timeout

02:44:06: DDR: Dialer Watch: watch-group = 8

02:44:06: DDR: network 0.0.0.0/0.0.0.0 UP,

02:44:06: DDR: primary DOWN

02:44:12: %LINK-5-CHANGED: Interface Async5, changed state to reset

02:44:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async5, changed state to down

02:44:13: DDR: Dialer Watch: watch-group = 8

02:44:13: DDR: network 0.0.0.0/0.0.0.0 DOWN,

02:44:13: DDR: primary DOWN

02:44:13: DDR: Dialer Watch: Dial Reason: Primary of group 8 DOWN

02:44:13: DDR: Dialer Watch: watch-group = 8,

02:44:13: DDR: Dialer Watch: No free dialer on As5

02:44:13: DDR: Dialer Watch: watch-group = 8

02:44:13: DDR: network 0.0.0.0/0.0.0.0 DOWN,

02:44:13: DDR: primary DOWN

02:44:13: DDR: Dialer Watch: Dial Reason: Primary of group 8 DOWN

02:44:13: DDR: Dialer Watch: watch-group = 8,

02:44:13: DDR: Dialer Watch: No free dialer on As5

02:44:17: %LINK-3-UPDOWN: Interface Async5, changed state to down

02:44:27: As5 DDR: re-enable timeout

02:44:27: DDR: Dialer Watch: watch-group = 8

02:44:27: DDR: network 0.0.0.0/0.0.0.0 DOWN,

02:44:27: DDR: primary DOWN

02:44:27: As5 DDR: Dialer Watch: resetting call in progress

02:44:27: As5 DDR: Dialer Watch: Check reconnection needed

02:44:27: As5 DDR: Dialer Watch: resetting call in progress

02:44:27: DDR: Dialer Watch: watch-group = 8

02:44:27: DDR: network 0.0.0.0/0.0.0.0 DOWN,

02:44:27: DDR: primary DOWN

02:44:27: DDR: Dialer Watch: Dial Reason: Secondary of group 8 DOWN

02:44:27: DDR: Dialer Watch: watch-group = 8,

02:44:27: DDR: dialing secondary by dialer string 2511 on As5

02:44:27: As5 DDR: Attempting to dial 2511

02:44:27: CHAT5: Attempting async line dialer script

02:44:27: CHAT5: no matching chat script found for 2511

02:44:27: CHAT5: Dialing using Modem script: d0efault-d0ials0cript & System script: none

02:44:27: CHAT5: process started

02:44:27: CHAT5: Asserting DTR

02:44:27: CHAT5: Chat script d0efault-d0ials0cript started

02:44:50: CHAT5: Chat script d0efault-d0ials0cript finished, status = Success

02:44:52: %LINK-3-UPDOWN: Interface Async5, changed state to up

02:44:52: As5 DDR: Dialer statechange to up

02:44:52: As5 DDR: Dialer Watch: resetting call in progress

02:44:52: As5 DDR: Dialer call has been placed

02:44:55: As5 DDR: dialer protocol up

02:44:56: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async5, changed state to up

02:45:22: As5 DDR: idle timeout

02:45:22: DDR: Dialer Watch: watch-group = 8

02:45:22: DDR: network 0.0.0.0/0.0.0.0 UP,

02:45:22: DDR: primary DOWN

02:45:52: As5 DDR: idle timeout

02:45:52: DDR: Dialer Watch: watch-group = 8

02:45:52: DDR: network 0.0.0.0/0.0.0.0 UP,

02:45:52: DDR: primary DOWN

02:46:22: As5 DDR: idle timeout

02:46:22: DDR: Dialer Watch: watch-group = 8

02:46:22: DDR: network 0.0.0.0/0.0.0.0 UP,

02:46:22: DDR: primary DOWN

02:46:52: As5 DDR: idle timeout

02:46:52: DDR: Dialer Watch: watch-group = 8

02:46:52: DDR: network 0.0.0.0/0.0.0.0 UP,

02:46:52: DDR: primary DOWN

02:46:58: %LINK-5-CHANGED: Interface Async5, changed state to reset

02:46:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async5, changed state to down

02:46:59: DDR: Dialer Watch: watch-group = 8

02:46:59: DDR: network 0.0.0.0/0.0.0.0 DOWN,

02:46:59: DDR: primary DOWN

02:46:59: DDR: Dialer Watch: Dial Reason: Primary of group 8 DOWN

02:46:59: DDR: Dialer Watch: watch-group = 8,

02:46:59: DDR: Dialer Watch: No free dialer on As5

02:46:59: DDR: Dialer Watch: watch-group = 8

02:46:59: DDR: network 0.0.0.0/0.0.0.0 DOWN,

02:46:59: DDR: primary DOWN

I cannot figure out what is wrong with this debug output. But one thing is sure. That is, this config was woirking fine when I forst configure it. But after few changes, this problem happened.

Any clue to sort this problem out is greately appreciated.

6 REPLIES
Silver

Re: dial backup using dialer watch

I beleive your prblem is idle-timer. Your Async idle time-out is set to only 30 seconds. It is in seconds. Increase it.

Hope this help.

New Member

Re: dial backup using dialer watch

I tried with idle timer of 120 secs , still there is no big improvement.

Waht I want to achieve is;

1. The backup link should stay up regardless of the interesting traffic.

2. The link shouild be down if and only if the primary link is up.

What is the best parameter that I can iuse to achieve above ?

New Member

Re: dial backup using dialer watch

Your dialer watch looks like it's working ok locally. The idle-timeout parameter specifies how often the dialer watch will look at the watched route to see if it's up or down. You would normally set this fairly low

(30-60 seconds), depending on how often you want the watch to check. It looks like the distant end is hanging up on you, possibly? I would focus there.

Chris M.

New Member

Re: dial backup using dialer watch

According to the dialer watch document found at following link:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/dial_c/dcdbakdw.htm,

it says:

4. In the primary link goes down, Dialer Watch is immediately notified by the routing protocol and the secondary link is brought up.

5. Once the secondary link is up, at the expiration of each idle timeout, the primary link is rechecked.

6. If the primary link remains down, the idle timer is indefinitely reset.

7. If the primary link is up, the secondary backup link is disconnected. Additionally, you can set a disable timer to create a delay for the secondary link to disconnect, after the primary link is reestablished.

Therefore, the backup link should remain up irrespective of the dialer idle-timer. The idle timer specifies how often it should check for the wathed route.

As you said, there can be a problem at the remote end. Ther erelevant config portion at the remote end is as folows;

interface Async225

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer in-band

dialer pool-member 2

async default routing

async mode interactive

no peer default ip address

ppp authentication chap

!

interface Dialer2

ip address 172.16.29.93 255.255.255.252

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool 2

dialer remote-name testbranch

dialer-group 1

no peer default ip address

pulse-time 0

ppp authentication chap

!

!

line aux 0

modem InOut

modem autoconfigure discovery

transport input all

autoselect during-login

autoselect ppp

stopbits 1

speed 115200

flowcontrol hardware

!

There I use dialer profiles and have not specified any special timers, so everything should be in default value.

Any idea as to what could go wrong at the remote end ?

New Member

Re: dial backup using dialer watch

Hello,

Since you're not using a dialer watch here, you can set the "dialer idle-timeout" to zero. That way this end will never hang up and the remote end will be responsible for hanging up the connection when things return. Is this what you want?

Chris M.

New Member

Re: dial backup using dialer watch

As per your previous suggestion , I changed the Dialer Idle timeout at the remote end. It actually solved the problem !

( Though I had many debugs ON at the remote end as well, I vnever saw any clue as to find out that the remote end is actually closing the connection, therefore I never wanted to do any changes there. But after your suggestion, I just wanted to change the parameter at the remote end as well).

Many thanks for great idea !...

176
Views
5
Helpful
6
Replies
CreatePlease to create content